LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2012, 12:00 PM   #1
wulfsburg
LQ Newbie
 
Registered: Mar 2012
Posts: 15

Rep: Reputation: Disabled
vsftpd and users


All,

I need some help getting my local users to be able to log in. Somehow I managed to get one of the users to work, but not the other.

/etc/passwd shows the following for the users:

tnielsen:x:1000:1000:Trent Nielsen,,,:/home/tnielsen:/bin/bash
ftp:x:106:117:ftp daemon,,,:/srv/ftp:/bin/false
anielsen:x:1002:117:Adam Nielsen:/srv/ftp:/bin/sh
wrussell:x:1003:117:William Russell:/srv/ftp:/bin/sh


I am tnielsen. anielsen can log in no problem. wrussell, cannot however. I keep getting a login failed. I have tried to reset the password just in case, but it doesnt seem to want to work.

Here is the output from my group file:

tnielsen:x:1000:
lpadmin:x:115:
admin:x:116:
ftp:x:117:anielsen,tnielsen,wrussell

Please bear with me, as I am new to Linux, but cannot seem to find out why it is not working.

I am using vsftpd, and I have ensured that local users are able to login through the command config within the vsftpd.conf file.

Based upon my group output, it is logical to say, that in the group "ftp", all 3 users are part of that, and by logic it should allow me to connect?

Thank you for your help in advance.

Oh, and I am using Ubuntu server 10.4 LTS
 
Old 04-03-2012, 06:01 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Hi wulfsburg,

Welcome to LQ!!!

You do not need to add the users to FTP group to enable them to access FTP. If in your vsftpd.conf file you have setup local_enable=yes then that should be it.

Another thing that I have noticed is that you have setup /srv/ftp as home directory for anielsen and wrussell. Is there a particular reason for that?

What is the exact error message that you get? Do you get Error 530 login failed?

Have a look at the following link and see if that helps: http://ubuntuforums.org/showthread.php?t=518293

If not, then paste your vsftpd.conf file in this thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd and users wulfsburg Ubuntu 1 03-22-2012 03:50 PM
vsftpd users sailingbikeruk Linux - Newbie 5 08-06-2010 05:34 AM
Allow System Users and Virtual Users in VSFTPd Nickbrandson Linux - Software 0 01-24-2008 09:06 AM
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 07:29 AM
vsftpd Users Kane2002 Linux - Software 2 01-02-2007 05:43 AM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration