LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2006, 08:28 PM   #1
Fated.Design
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
vsFTPd


I am running Ubuntu 5.10

I need some help setting up an FTP for my website, obviously located in /vare/www

can someone help me install and setup svFTPd?
 
Old 05-17-2006, 08:35 PM   #2
Harpune
Member
 
Registered: Sep 2002
Location: Seattle, WA
Distribution: Ubuntu
Posts: 101

Rep: Reputation: 15
What exactly do you need help with? I would start by installing vsftpd from the ubuntu repositories. Use either synaptic or apt-get:

Code:
# sudo apt-get install vsftpd
Once it is installed, read through the config file. that will go a long way towards explaining everything involved in setting it up, as well as explaining how the program works. Usually the config file is located at /etc/vsftpd.conf (or maybe something like /etc/vsftpd.conf.sample)

If you have any specific questions from that, post them here.

Hope this gives you a solid jumping-off point. good luck.
 
Old 05-21-2006, 05:45 PM   #3
Fated.Design
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Original Poster
Rep: Reputation: 0
what directory do i place files in.
For instance, I want to have my web files in the FTP.
Web files are located all in /var/www/ so how would i set up the FTP to run in that directory only?
 
Old 05-21-2006, 07:05 PM   #4
Fated.Design
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Original Poster
Rep: Reputation: 0
I have only just installed it, with no configuration of the vsftpd.conf file at all really. When I use ftp://localhost it just comes up with a blank page with the title "Index of ftp://localhost/"
with no files or folders shown. If I use nautilus and put files in the /var/ftp/ directory and restart the ftp, there still arent files shown. All I want to do is set a directory so when I log in, it brings me to that directory.

Can someone help?
 
Old 05-22-2006, 11:02 PM   #5
Harpune
Member
 
Registered: Sep 2002
Location: Seattle, WA
Distribution: Ubuntu
Posts: 101

Rep: Reputation: 15
the /etc/vsftpd.conf file that came with the vsftpd package has enough information on how to configure vsftpd in most situations. In your case, you would probably be best to create a new user on your machine, set that user's home directory to /var/www and give that user ftp login permission. Make sure that the new user has read/write permissions of /var/www.

I believe that it is vsftpd's default behaviour to chroot any ftp login into that user's home directory. You can probably change that in the config file.
 
Old 05-23-2006, 12:45 AM   #6
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
The default of vsftp is actually just the opposite, it doesn't chroot users unless you change the default config. Sort of odd for the security king FTP server, but that is the way it works. Of course given the permissions system, it does make some sense.

To the OP, you won't be able to upload files to /var/www until you make the changes the previous responders said. Typical users do not have write permissions for /var/www, so you will need to work with the configs of apache and vsftpd so that you have one user or group with read and write permissions for the directory where the website exists. Usually /var/www is either root:root, or www-data:www-data, which is the default owner of apache2 on most systems.

You should search here for how to chroot users in vsftpd. It is asked and answered all the time. Set the owner of the directory where the website is, make sure the permissions are square, and then also set that as their home directory. Then enable the chroot, and the site user (do NOT use your account, or you will be very sorry) should be able to upload/download files to and from the website. Also, if the site directory is owned by root:root, you'll have to change that, as root can't ftp through vsftp, because that is a major security risk.

peace,
JimBass
 
  


Reply

Tags
vsftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 11:31 PM
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 08:24 PM
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 07:29 AM
vsftpd & ssl - how do I tell if it's actually vsftpd maintaining the connections?? hunterhunter Linux - General 0 03-27-2006 05:41 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 02:05 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration