LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-17-2004, 09:40 PM   #1
nadsab
Member
 
Registered: Mar 2004
Posts: 30

Rep: Reputation: 15
VSFTPD 2.0.1 on RH 8; problem connecting, can't resolve host...


Hi there,

I'm having a terrible time getting VSFTPD running on Red Hat 8 Linux. I just installed it per the instructions at http://vsftpd.beasts.org. First of all does anyone know if VSFTPD 2.0.1 is compatible with Red hat 8?

Anyway, I am able to test start vsftpd from the command line by running: /usr/local/sbin/vsftpd & and then I can do a “ftp localhost” and connect via command line per the above install instructions...

Code:
[root@www etc]# /usr/local/sbin/vsftpd &
[root@www etc]# ftp localhost
Connected to localhost (127.0.0.1).
220 Welcome to blah FTP service.
Name (localhost:root): ftp
331 Please specify the password.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls -la
227 Entering Passive Mode (127,0,0,1,189,20)
150 Here comes the directory listing.
drwxr-xr-x    2 0        0            4096 Aug 15 04:20 .
drwxr-xr-x    2 0        0            4096 Aug 15 04:20 ..
226 Directory send OK.
ftp>
..seems to work. But then when I try to connect via Cute FTP, I can't get either an SFTP or an FTP connection - I keep getting "can't resolve www.whateverdomainname.com " errors.

I ran a netstat -atuvp to see if there is an FTP service running with a process ID after running the above, there is, and it seems that I should be able to connect with my FTP software Cute FTP, but I can't connect using any users, even though I seem to have my vsftpd.users and vsftpd.user_list files in /etc set up OK.

I've tried setting listen=YES in vsftpd.conf and that doesn't work either.

Can anyone give me an idea as to what I might be doing wrong?

Thanks anyone.

Last edited by nadsab; 08-17-2004 at 10:51 PM.
 
Old 08-18-2004, 02:00 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Sounds more like a DNS problem, try using the IP instead of "www.whateverdomainname.com"
 
Old 08-18-2004, 06:10 AM   #3
nadsab
Member
 
Registered: Mar 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Hi Demonbane

I tried that, used the correct IP address and still could not connect via Cute FTP. The error message was a bit different though; Cute said: "ERROR:> Can't connect to remote server. Socket error = #10061", instead of "can't resolve domainname".
"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd not starting correctly swatward Linux - Software 1 08-01-2005 10:08 PM
vsftpd not starting at boot neocookie Linux - Software 2 10-21-2004 11:55 AM
vsftpd not starting up! vmnrao Linux - General 8 09-11-2004 07:10 PM
Xinetd not starting vsftpd? simonmccourt Linux - Networking 0 02-22-2004 09:08 AM
Starting vsftpd on RH 2.1 AS rwolson Linux - Software 1 12-08-2003 08:54 PM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration