LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-18-2010, 10:22 AM   #1
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Rep: Reputation: 36
vsftp - some users see files, some don't, but all users are in same group


When I have different people log into our ftp and browse to the same folder, some people see the files inside, some don't. all the user accounts are in the same group, which has permission to this folder. but the one user who can see the files is the owner.

how can i fix it so everyone in that group who's the owner of the folder can see the files?
 
Old 01-18-2010, 10:52 AM   #2
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Quote:
Originally Posted by rjo98 View Post
When I have different people log into our ftp and browse to the same folder, some people see the files inside, some don't. all the user accounts are in the same group, which has permission to this folder. but the one user who can see the files is the owner.
Did you mean, only root was able to see the files, others did n't
is n't it ?


use chmod

#chmod 755 -R <folder name>
 
Old 01-18-2010, 10:54 AM   #3
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Original Poster
Rep: Reputation: 36
no, i meant the owner user of the folder could see them, but members of the group couldn't. but now, without me changing anything, group members can see the files now .. WEIRD
 
Old 01-18-2010, 10:57 AM   #4
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
may be "umask" has changed.

checkout default umask =022 => no other can see the files except owner.
if it is changed every user can see.

change umask value to default . i.e. 022
 
Old 01-18-2010, 10:58 AM   #5
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Original Poster
Rep: Reputation: 36
where do i find that at? nobody would have been changing settings on the server.
 
Old 01-18-2010, 11:01 AM   #6
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
a person can change his umask value. may be some users modified their umask value's.
 
Old 01-18-2010, 11:02 AM   #7
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Original Poster
Rep: Reputation: 36
how do i check it?
 
Old 01-18-2010, 11:17 AM   #8
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
open your terminal
Code:
#umask
if you recive 022 , then permissions are RWXR-XR-X

you can modify by simple teminal command.


Code:
#umask 077
now create a file and check. only owner can see the files. others are restricted.
 
Old 01-18-2010, 11:20 AM   #9
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Original Poster
Rep: Reputation: 36
none of the people who couldn't see the file temporarily have CLI access, so that can't be it. must just have been the server or ftp clients not behaving well together.
 
Old 01-18-2010, 05:15 PM   #10
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,261

Rep: Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028
You might want to

chmod g+s dir_in_question

which will ensure all files (subsequently) created in that dir are group owned by the dir's group.
http://en.wikipedia.org/wiki/Setuid
 
Old 01-18-2010, 07:41 PM   #11
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,455

Original Poster
Rep: Reputation: 36
Thanks Chris. I'll give it a shot. this was a real weird one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Secondary group users need to change the file permissions of primary group files? sunnybmv Linux - Newbie 3 12-10-2009 04:57 PM
How to share files between users from same group pintudelhi Linux - Newbie 7 08-25-2009 11:41 PM
Script to Auto-add Domain Users to Workstation Power Users Group doesn't work avinash.rao Ubuntu 0 08-22-2009 04:57 AM
Script to add a secondary group to all users except system default users Tekken Linux - Server 5 06-29-2009 04:02 PM
VSFTP Users daveginorge Linux - Server 6 10-18-2008 04:18 AM


All times are GMT -5. The time now is 07:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration