LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2002, 10:07 AM   #1
imposter
LQ Newbie
 
Registered: Nov 2002
Location: UK
Distribution: Debian Sarge
Posts: 17

Rep: Reputation: 0
Question vsftp Problems


After trying for the best part of a week to get some kind of reliable ftp server running for me to transfer web pages to my linux server I stumbled across vsftp and all seemed well.

However I now have the problem of not being able to create dirs or upload files as the user I have created.

Does anyone have any ideas what needs to be put in the vsftpd.conf (or other) files in order to enable this functionality?
 
Old 12-01-2002, 10:23 AM   #2
te_conway
Member
 
Registered: Apr 2001
Location: MA
Distribution: redhat 7.2
Posts: 182

Rep: Reputation: 30
Is write_enable=YES in your /etc/vsftpd.conf and do your users have permissions on the directory?
 
Old 12-01-2002, 10:40 AM   #3
imposter
LQ Newbie
 
Registered: Nov 2002
Location: UK
Distribution: Debian Sarge
Posts: 17

Original Poster
Rep: Reputation: 0
Yes although now I cannot get onto the server at all:

"500 OOPS: vsftpd: both local and anonymous access disabled!"

Think I need to go back to the drawing board about how to create user accounts. Its all so confusing and there are no guides aimed at people who dont know much about this
 
Old 12-01-2002, 12:13 PM   #4
te_conway
Member
 
Registered: Apr 2001
Location: MA
Distribution: redhat 7.2
Posts: 182

Rep: Reputation: 30
Assuming you do not have anon logins your config needs lines:
anonymous_enable=NO
local_enable=YES
userlist_deny=NO
userlist_enable=YES
chroot_local_user=YES
write_enable=YES

You need to put a list of users in /etc/vsftpd.user_list with one user per line.

Restart your services after editing

Here's a good link for creating no-shell accounts which is a good idea for ftp only users.

http://www.tldp.org/LDP/solrhe/Secu...ap29sec295.html
 
Old 12-01-2002, 04:29 PM   #5
pk21
Member
 
Registered: Jun 2002
Location: Netherlands - Amsterdam
Distribution: RedHat 9
Posts: 549

Rep: Reputation: 30
i dont think restarting xinetd is necessary.
 
Old 06-24-2003, 01:42 PM   #6
jasp2
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Rep: Reputation: 0
I believe you do need to restart after adjusting the the /etc/xinetd.d/vsftpd file. If you change the disable line from "yes" to "no" then a chkconfig --list will show vsftpd as on, HOWEVER... a "netstat -a | grep ftp" doesn't report a daemon listening for ftp until you restart xinetd. Of course you can just give it a "kill -HUP" as opposed to restarting it entirely.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftp problems with permissions lynchmob09 Linux - Networking 2 12-11-2008 03:21 AM
vsftp problems eckertc1 Linux - Software 3 02-28-2005 05:44 PM
Major vsFTP Problems!!! sjblasko82 Linux - Software 2 11-16-2004 04:55 PM
problems with vsftp laclac01 Linux - Software 3 06-03-2004 03:53 PM
vsftp problems XWolf Linux - Networking 5 10-01-2003 04:48 AM


All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration