LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2012, 01:58 PM   #1
paulwoodman
LQ Newbie
 
Registered: Feb 2012
Location: London, UK
Distribution: Slackware
Posts: 17

Rep: Reputation: Disabled
VSFTP install Slack


Hopefully a quick question ; )

Most people will be saying install from pkgtool but i just wanna learn this way first

I downloaded VSFTP and ran the make install, everything extracted fine and the vsftpd was loaded into /usr/local/sbin/ and the config was loaded in to /etc

I have edited the /etc/vsftpd.conf, listen=YES and ran the command /usr/local/sbin/vsftpd &

If i run: ftp localhost, i can login with my user details. Now what process is this "standalone"?
If i want the ftp server to start from boot from what i read i have to edit the inetd.conf line

# Very Secure File Transfer Protocol (FTP) server.
ftp stream tcp nowait root /usr/sbin/tcpd vsftpd and then run /etc/rc.d/rc.inetd restart.

I have tried this but it doesnt seem to work, can anyone see what i'm doing wrong?
 
Old 02-17-2012, 05:02 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Hi,

You need to use in /etc/inetd.conf:
Code:
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd /usr/local/sbin/vsftpd
And of course you should change the LISTEN directive to NO

Cheers
 
Old 02-17-2012, 05:13 PM   #3
paulwoodman
LQ Newbie
 
Registered: Feb 2012
Location: London, UK
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: Disabled
@bathory mate thanks. I did add the line "ftp stream tcp nowait root /usr/sbin/tcpd /usr/local/sbin/vsftpd"

but i didn't change Listen=No, i just commented it out!

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I cannot install vsftp careykwong Linux - Newbie 3 10-01-2009 04:06 PM
Dual-boot Slack/Ubuntu-install slack over XP-help with weird partition layout & lilo? linus72 Slackware 2 05-23-2009 11:03 AM
Install slack from usb hdd using the slack dvd iso? okos Slackware 6 01-01-2009 03:06 AM
using slack 9 CD to install slack current mr_mandrill Slackware - Installation 1 06-20-2004 02:23 AM
vsftp install jags Linux - Networking 1 04-30-2003 02:42 PM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration