LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2006, 12:37 PM   #1
blueboy
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
vsftp hide_file och deny_file not working


Hi,
I have set up my vsftp with virtual users and everything is working just fine. Except that I want to give some virtual userís private folder that other users donít have access too. I guess that the hide_file and deny_file could help me with that, only its not working for me.

I followed the guide from h t t p ://g0.g.la/blg/ when setting up my virtual users.

Any suggestion to why hide_file and deny_file doesnít work for me is appreciated.

Last edited by blueboy; 05-15-2006 at 03:35 PM.
 
Old 05-26-2006, 05:48 PM   #2
blueboy
LQ Newbie
 
Registered: May 2006
Posts: 3

Original Poster
Rep: Reputation: 0
fuck linux

evidently Linux is to complicated for any one out there to help me with an simple question about virtual ftp user access. I should probably use
a simple software as Win server 2003 instead. I mean it shouldnít be so hard to set up the user account in an ftp server as wildly spread as vsftp.


Quote:
Originally Posted by blueboy
Hi,
I have set up my vsftp with virtual users and everything is working just fine. Except that I want to give some virtual userís private folder that other users donít have access too. I guess that the hide_file and deny_file could help me with that, only its not working for me.

I followed the guide from h t t p ://g0.g.la/blg/ when setting up my virtual users.

Any suggestion to why hide_file and deny_file doesnít work for me is appreciated.
 
Old 05-26-2006, 06:07 PM   #3
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
No idea why you did not get an answer.

I have never used vsftp, and I do not know how to set the hide_file and deny_file parameters, but if you do not want other users to have access to a directory you could just change the permissions. Become root, and change the permissions on that directory so that only the owner can read, write, or execute within it.

You could open a shell, become root, and open konqueror, right click on the folder you want to change, and select the Permissions tab. Uncheck everything except the boxes under Owner. Close it and you should have a folder that is inaccessable to anyone except the owner.

Good luck.

C
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftp not working on Fedora5 yangontha Fedora 4 05-10-2006 11:25 PM
Vsftp Mojosue Linux - Software 3 02-18-2005 07:20 AM
help with vsftp a2carat Linux - Software 7 02-16-2004 11:38 AM
chroot not working for vsftp anymore noisybastard Linux - Newbie 5 11-26-2003 11:31 PM
vsFTP not working over modem lansman Linux - Networking 1 06-17-2003 09:32 PM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration