LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2015, 01:18 PM   #1
helloagain
LQ Newbie
 
Registered: Feb 2015
Posts: 2

Rep: Reputation: Disabled
VPN Mullvad client won't install proper -dependency problems(?)-


Hello all

I'm having trouble with installing the Mullvad VPN client on my computer. The configuration files work fine and there is a connection but the client just won't work (there is a icon in the applications but when clicking on it, password is asked and then nothing happens). Using Debian Wheezy 7.
I'm in contact with Mullvad but we haven't made any progress yet, and it's weekend now.

I tried a couple of thing but this is where i'm now:

- Fresh installed system.

→ Going to Downloads map in terminal
→ login as root
→ trying to install Mullvad by dpkg -i mullvad_48-1_all.deb
→ seeing error installing Mullvad
→ apt-get install -f
→ installing “mullvad depends on packages”
apt-get install pytho
apt-get install python-wxgtk2.8
apt-get install python-appindicator
→ trying to install Mullvad by dpkg -i mullvad_48-1_all.deb
→ seeing problem(?)
“ dpkg: dependency problems prevent configuration of mullvad:
mullvad depends on python:any (>= 2.7.1-0ubuntu2).

dpkg: error processing mullvad (--install):
dependency problems - leaving unconfigured “ (what is this?)
→ trying to install python_2.7.3-4+deb7u1_all.deb by dpkg -i python_2.7.3-4+deb7u1_all.deb
→ then: apt-get install -f
→ trying to install Mullvad: dpkg -i mullvad_48-1_all.deb
→ still not working

Code:
userone@debianuser:~$ cd ~/Downloads
userone@debianuser:~/Downloads$ su
Password: 
root@debianuser:/home/userone/Downloads# dpkg -i mullvad_48-1_all.deb
Selecting previously unselected package mullvad.
(Reading database ... 139936 files and directories currently installed.)
Unpacking mullvad (from mullvad_48-1_all.deb) ...
dpkg: dependency problems prevent configuration of mullvad:
 mullvad depends on python:any (>= 2.7.1-0ubuntu2).
 mullvad depends on python-wxgtk2.8; however:
  Package python-wxgtk2.8 is not installed.
 mullvad depends on python-appindicator; however:
  Package python-appindicator is not installed.

dpkg: error processing mullvad (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 mullvad
root@debianuser:/home/userone/Downloads# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  mullvad
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 627 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 139987 files and directories currently installed.)
Removing mullvad ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
root@debianuser:/home/userone/Downloads# apt-get install python
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debianuser:/home/userone/Downloads# apt-get install python-wxgtk2.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libwxbase2.8-0 libwxgtk2.8-0 python-wxversion
Suggested packages:
  libgnomeprintui2.2-0 wx2.8-doc wx2.8-examples editra
The following NEW packages will be installed:
  libwxbase2.8-0 libwxgtk2.8-0 python-wxgtk2.8 python-wxversion
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.8 MB of archives.
After this operation, 46.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://ftp.us.debian.org/debian/ wheezy/main libwxbase2.8-0 amd64 2.8.12.1-12 [678 kB]
Get:2 http://ftp.us.debian.org/debian/ wheezy/main libwxgtk2.8-0 amd64 2.8.12.1-12 [3,411 kB]
Get:3 http://ftp.us.debian.org/debian/ wheezy/main python-wxversion all 2.8.12.1-12 [91.8 kB]
Get:4 http://ftp.us.debian.org/debian/ wheezy/main python-wxgtk2.8 amd64 2.8.12.1-12 [8,579 kB]
Fetched 12.8 MB in 20s (608 kB/s)                                              
Selecting previously unselected package libwxbase2.8-0:amd64.
(Reading database ... 139936 files and directories currently installed.)
Unpacking libwxbase2.8-0:amd64 (from .../libwxbase2.8-0_2.8.12.1-12_amd64.deb) ...
Selecting previously unselected package libwxgtk2.8-0:amd64.
Unpacking libwxgtk2.8-0:amd64 (from .../libwxgtk2.8-0_2.8.12.1-12_amd64.deb) ...
Selecting previously unselected package python-wxversion.
Unpacking python-wxversion (from .../python-wxversion_2.8.12.1-12_all.deb) ...
Selecting previously unselected package python-wxgtk2.8.
Unpacking python-wxgtk2.8 (from .../python-wxgtk2.8_2.8.12.1-12_amd64.deb) ...
Setting up libwxbase2.8-0:amd64 (2.8.12.1-12) ...
Setting up libwxgtk2.8-0:amd64 (2.8.12.1-12) ...
Setting up python-wxversion (2.8.12.1-12) ...
Setting up python-wxgtk2.8 (2.8.12.1-12) ...
update-alternatives: using /usr/lib/wx/python/wx2.8.pth to provide /usr/lib/wx/python/wx.pth (wx.pth) in auto mode
root@debianuser:/home/userone/Downloads# apt-get install python-appindicator
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  indicator-application libappindicator1 libappindicator3-1 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libdbusmenu-gtk4 libindicator3-7 libindicator7
The following NEW packages will be installed:
  indicator-application libappindicator1 libappindicator3-1 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libdbusmenu-gtk4 libindicator3-7 libindicator7
  python-appindicator
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 632 kB of archives.
After this operation, 1,392 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://ftp.us.debian.org/debian/ wheezy/main libdbusmenu-glib4 amd64 0.6.2-1 [109 kB]
Get:2 http://ftp.us.debian.org/debian/ wheezy/main libdbusmenu-gtk3-4 amd64 0.6.2-1 [95.0 kB]
Get:3 http://ftp.us.debian.org/debian/ wheezy/main libdbusmenu-gtk4 amd64 0.6.2-1 [95.0 kB]
Get:4 http://ftp.us.debian.org/debian/ wheezy/main libindicator3-7 amd64 0.5.0-1 [56.6 kB]
Get:5 http://ftp.us.debian.org/debian/ wheezy/main libappindicator3-1 amd64 0.4.92-2 [56.1 kB]
Get:6 http://ftp.us.debian.org/debian/ wheezy/main indicator-application amd64 0.5.0-1 [62.4 kB]
Get:7 http://ftp.us.debian.org/debian/ wheezy/main libindicator7 amd64 0.5.0-1 [56.6 kB]
Get:8 http://ftp.us.debian.org/debian/ wheezy/main libappindicator1 amd64 0.4.92-2 [56.1 kB]
Get:9 http://ftp.us.debian.org/debian/ wheezy/main python-appindicator amd64 0.4.92-2 [45.3 kB]
Fetched 632 kB in 2s (216 kB/s)               
Selecting previously unselected package libdbusmenu-glib4:amd64.
(Reading database ... 141598 files and directories currently installed.)
Unpacking libdbusmenu-glib4:amd64 (from .../libdbusmenu-glib4_0.6.2-1_amd64.deb) ...
Selecting previously unselected package libdbusmenu-gtk3-4:amd64.
Unpacking libdbusmenu-gtk3-4:amd64 (from .../libdbusmenu-gtk3-4_0.6.2-1_amd64.deb) ...
Selecting previously unselected package libdbusmenu-gtk4:amd64.
Unpacking libdbusmenu-gtk4:amd64 (from .../libdbusmenu-gtk4_0.6.2-1_amd64.deb) ...
Selecting previously unselected package libindicator3-7.
Unpacking libindicator3-7 (from .../libindicator3-7_0.5.0-1_amd64.deb) ...
Selecting previously unselected package libappindicator3-1.
Unpacking libappindicator3-1 (from .../libappindicator3-1_0.4.92-2_amd64.deb) ...
Selecting previously unselected package indicator-application.
Unpacking indicator-application (from .../indicator-application_0.5.0-1_amd64.deb) ...
Selecting previously unselected package libindicator7.
Unpacking libindicator7 (from .../libindicator7_0.5.0-1_amd64.deb) ...
Selecting previously unselected package libappindicator1.
Unpacking libappindicator1 (from .../libappindicator1_0.4.92-2_amd64.deb) ...
Selecting previously unselected package python-appindicator.
Unpacking python-appindicator (from .../python-appindicator_0.4.92-2_amd64.deb) ...
Setting up libdbusmenu-glib4:amd64 (0.6.2-1) ...
Setting up libdbusmenu-gtk3-4:amd64 (0.6.2-1) ...
Setting up libdbusmenu-gtk4:amd64 (0.6.2-1) ...
Setting up libindicator3-7 (0.5.0-1) ...
Setting up libappindicator3-1 (0.4.92-2) ...
Setting up indicator-application (0.5.0-1) ...
Setting up libindicator7 (0.5.0-1) ...
Setting up libappindicator1 (0.4.92-2) ...
Setting up python-appindicator (0.4.92-2) ...
root@debianuser:/home/userone/Downloads# dpkg -i mullvad_48-1_all.deb
Selecting previously unselected package mullvad.
(Reading database ... 141685 files and directories currently installed.)
Unpacking mullvad (from mullvad_48-1_all.deb) ...
dpkg: dependency problems prevent configuration of mullvad:
 mullvad depends on python:any (>= 2.7.1-0ubuntu2).

dpkg: error processing mullvad (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 mullvad

root@debianuser:/home/userone/Downloads# dpkg -i python_2.7.3-4+deb7u1_all.deb
(Reading database ... 141737 files and directories currently installed.)
Preparing to replace python 2.7.3-4+deb7u1 (using python_2.7.3-4+deb7u1_all.deb) ...
Unpacking replacement python ...
Setting up python (2.7.3-4+deb7u1) ...
Processing triggers for man-db ...
root@debianuser:/home/userone/Downloads# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  mullvad
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 627 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 141736 files and directories currently installed.)
Removing mullvad ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
root@debianuser:/home/userone/Downloads# dpkg -i mullvad_48-1_all.deb 
Selecting previously unselected package mullvad.
(Reading database ... 141685 files and directories currently installed.)
Unpacking mullvad (from mullvad_48-1_all.deb) ...
dpkg: dependency problems prevent configuration of mullvad:
 mullvad depends on python:any (>= 2.7.1-0ubuntu2).

dpkg: error processing mullvad (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 mullvad
root@debianuser:/home/userone/Downloads#

I found this link about "Package has a Depends on python:any (>= 2.7.1-0ubuntu2)" https://qa.debian.org/debcheck.php?dist ... thon-gdata
It says : Package has a Depends on python:any (>= 2.7.1-0ubuntu2) which cannot be satisfied on amd64.
What does this mean for me?

I checked command # python -V The output is:
Code:
Python 2.7.3
 
Old 03-02-2015, 04:30 AM   #2
helloagain
LQ Newbie
 
Registered: Feb 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
SOLVED

SOLVED how:

- Extract the Mullvad client package
- Edit 'control' file > text > 'python:any (>= 2.7.1-0ubuntu2)' to 'python (>= 2.7.1)
- Save and repack into deb package
- Install package
- Run from terminal with 'sudo mullvad'

Used this to edit package:

CODE: SELECT ALL
dpkg-deb -x foo.deb tmpdir
dpkg-deb --control foo.deb tmpdir/DEBIAN
nano tmpdir/DEBIAN/control
dpkg -b tmpdir hacked.deb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cisco vpn client won't compile mbvo Slackware 6 07-23-2013 08:37 AM
Mullvad VPN Software. Safe to install? NotAComputerGuy Linux - Networking 2 06-12-2013 08:46 AM
Octave won't install because of dependency jwheel83 Linux - Desktop 1 10-08-2006 07:58 AM
Cisco VPN Client 3.5.2 won't install on RH9.1 PenguinPwrdBox Linux - Software 0 10-10-2003 09:40 AM
dependency problems (libImlib.so.1 won't install) obli Linux - General 2 02-13-2003 04:02 PM


All times are GMT -5. The time now is 02:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration