LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2015, 05:44 PM   #1
Tchiarot
Member
 
Registered: Feb 2013
Location: Lima, Peru
Distribution: Debian
Posts: 39

Rep: Reputation: Disabled
Unhappy Volume rise, lower and Mute doesn't work on debian 8.0 Jessie


Hi Friends,

I recently install a Debian 8.0 Jessie on a Laptop Dell latitude E6540 with gnome 3.14+3.
But the problem is that it doesn't recongnize my multimedia buttons, I tried some methods but I didn't get results.

Code:
$showkey --scancodes
volume up   -- 0xe0 0x30 0xe0 0xb0
volume down -- 0xe0 0x2e 0xe0 0xae
volume mute -- 0xe0 0x20 0xe0 0xa0

$showkey --keycodes
volume up   -- 115
volume down -- 114
volume mute -- 113
xev
Code:
Volume up produces:

FocusOut event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyGrab, detail NotifyPointer

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  1   0   0   0   0   0   0   0   0   0   0   0   0   0   0   8   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 
Volume down:

FocusOut event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Volume mute:

FocusOut event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 37, synthetic NO, window 0x2000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
On Setting --> Keyboard --> Shortcuts --> Sound and Media :

Volume up Audio mute
Volume down Audio lower volume
Volume mute Audio raise volume

On dconf org.gnome.settings-deamon.plugins.media-keys

Volume up XF86AudioLowerVolume
Volume down XF86AudioRiseVolume
Volume mute XF86AudioMute

When I reassinged the keys on Settings>Keyboard>Shortcuts to F7, F8 and F9 it works, but when use the keys volume up, down and mute It doesn't show anything.

The same happens with Fn + Brightness keys, in this case it worked the first time but then stop to work I don't know why..

Please some help with this..

Last edited by Tchiarot; 03-29-2015 at 05:47 PM.
 
Old 03-30-2015, 06:50 PM   #2
Tchiarot
Member
 
Registered: Feb 2013
Location: Lima, Peru
Distribution: Debian
Posts: 39

Original Poster
Rep: Reputation: Disabled
Hi Please,

Any help ?..
 
Old 03-30-2015, 08:11 PM   #3
Tchiarot
Member
 
Registered: Feb 2013
Location: Lima, Peru
Distribution: Debian
Posts: 39

Original Poster
Rep: Reputation: Disabled
Hi Additional to it,

When execute acpi_listen I get:

Code:
button/volumeup VOLUP 00000080 00000000 K
button/volumedown VOLDN 00000080 00000000 K
button/mute MUTE 00000080 00000000 K
For Brightness:

Code:
video/brightnessup BRTUP 00000086 00000000
 PNP0C14:00 000000d0 00000000
video/brightnessdown BRTDN 00000087 00000000
 PNP0C14:00 000000d0 00000000
 
Old 03-30-2015, 10:20 PM   #4
Tchiarot
Member
 
Registered: Feb 2013
Location: Lima, Peru
Distribution: Debian
Posts: 39

Original Poster
Rep: Reputation: Disabled
Hi Friends,

Sorry Finally found the error.. It was an autostart folder create on the .config file of user, this folder contains a Gnome-terminal file with some configuration that causes the error.

Remove the folder and all works fine.

Thanks for take a time for read.

Last edited by Tchiarot; 03-30-2015 at 10:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why doesn't Wicd use OpenDNS after I configured to (on debian jessie)? TheBatmanKiller Linux - Networking 10 08-21-2014 08:14 AM
Volume control doesn't work nix_dev Ubuntu 5 04-27-2009 08:35 PM
volume applet and mute illion Slackware 1 09-12-2007 02:24 PM
Volume Doesn't Work Japster001 Linux - General 5 09-11-2005 12:51 AM
mute/volume buttons to work? microsoft/linux Linux - Laptop and Netbook 7 08-20-2005 02:35 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration