LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-03-2009, 08:43 AM   #1
robtarr
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
VNC connection not working


I am trying to setup VNC from Fedora 10. I install vnc-server-4.1.3-1.fc10 (i386) and when I run 'vncserver' everything looks fine:
New 'sugar.tca.local:3 (rob)' desktop is sugar.tca.local:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/sugar.tca.local:1.log

But when I connect from my Windows box I just get a grey screen with three checkboxes in the top left corner:
__Accept clipboard from viewers
__Send clipboard to viewers
__Send primary selection to viewers

The first time I try to connect after starting the vncserver I get this error message:
"Could not connect to session bus. Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
When I click "Close" I get another message:
"Could not acquire name on session bus."

When I checked the error log on the Fedora box I see this:

Xvnc Free Edition 4.1.3
Copyright (C) 2002-2008 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10503000,


Mon Mar 2 10:45:40 2009
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0

Mon Mar 2 10:45:43 2009
Connections: accepted: 192.168.10.21::49904
SConnection: Client needs protocol version 3.8
SConnection: Client requests security type VncAuth(2)
imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: yes
Is Qt supported: no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS:
IMSETTINGS_DISABLE_DESKTOP_CHECK:
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-26CuODYmbt,guid=9f7b68384e29c365cdf25a9949a7e9a0
GTK_IM_MODULE:
QT_IM_MODULE:
XMODIFIERS: @im=imsettings
IMSETTINGS_MODULE: none

Failed to get a session bus.
Xlib: extension "RANDR" missing on display ":1.0".

(imsettings-xim:5607): GXIM-WARNING **: Unable to establish a D-Bus session bus:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..
Xlib: extension "RANDR" missing on display ":1.0".
/root
/etc/X11/xinit/xinitrc: line 34: syntax error near unexpected token `fi'
/etc/X11/xinit/xinitrc: line 34: `fi'

(imsettings-xim:5607): IMSettings-CRITICAL **: imsettings_request_new: assertion `connection != NULL' failed

(imsettings-xim:5607): IMSettings-CRITICAL **: imsettings_request_set_locale: assertion `IMSETTINGS_IS_REQUEST (imsettings)' failed

(imsettings-xim:5607): IMSettings-CRITICAL **: imsettings_request_get_current_user_im: assertion `IMSETTINGS_IS_REQUEST (imsettings)' failed
No default IM is available.

Mon Mar 2 10:45:45 2009
VNCSConnST: Server default pixel format depth 16 (16bpp) little-endian rgb565
VNCSConnST: Client pixel format depth 8 (8bpp) rgb max 3,3,3 shift 4,2,0



Here is my xinitrc file:
#!/bin/sh
# Copyright (C) 1999 - 2005 Red Hat, Inc. All rights reserved. This
# copyrighted material is made available to anyone wishing to use, modify,
# copy, or redistribute it subject to the terms and conditions of the
# GNU General Public License version 2.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#
# Authors:
# Mike A. Harris <mharris@redhat.com>

# Mandatorily source xinitrc-common, which is common code shared between the
# Xsession and xinitrc scripts which has been factored out to avoid duplication
. /etc/X11/xinit/xinitrc-common

# The user may have their own clients they want to run. If they don't,
# fall back to system defaults.
echo $HOME
if [ -f $HOME/.Xclients ]; then
exec $CK_XINIT_SESSION $SSH_AGENT $HOME/.Xclients || \
exec $CK_XINIT_SESSION $SSH_AGENT $HOME/.Xclients
elif [ -f /etc/X11/xinit/Xclients ]; then
exec $CK_XINIT_SESSION $SSH_AGENT /etc/X11/xinit/Xclients || \
exec $CK_XINIT_SESSION $SSH_AGENT /etc/X11/xinit/Xclients
else
# Failsafe settings. Although we should never get here
# (we provide fallbacks in Xclients as well) it can't hurt.
[ -x /usr/bin/xsetroot ] && /usr/bin/xsetroot -solid '#222E45'
[ -x /usr/bin/xclock ] && /usr/bin/xclock -geometry 100x100-5+5 &
[ -x /usr/bin/xterm ] && xterm -geometry 80x50-50+150 &
[ -x /usr/bin/twm ] && /usr/bin/twm
fi


I'm still fairly new to Linux, any guidance would be greatly appreciated - thanks.

Last edited by robtarr; 03-03-2009 at 08:58 AM. Reason: forgot to add error message
 
Old 03-03-2009, 01:11 PM   #2
T74marcell
Member
 
Registered: Mar 2009
Posts: 102

Rep: Reputation: 18
http://bobpeers.com/linux/vnc.php has a fine tutorial for VNC on Fedora 10.
In a nutshell:
You must open port 5900 (and upwards) on the server's firewall, where port 5900 would be display :1, port 5901 would be display :2, etc. The tutorial actually disagrees with me on this part (so far I always used VNC without the specific Fedora GUI tools), as it claims that port 5900 goes with display :1, but my Fedora's have a GUO login interface that uses display :0 already. Anyway, this is something that you can work out on your system.
Also edit /etc/sysconfig/vncservers as root and create the intended settings for the VNC session, otherwise you will end up with somw ancient window manager like twm (all grey).
If you launch a GUI login for some user on the server, and start a vncserver session within that account (choose an unused display number), then your remote access will bring up exactly that running GUI login session.

----------
T74marcell

Arch Linux

Last edited by T74marcell; 03-14-2009 at 12:40 AM.
 
Old 03-03-2009, 01:21 PM   #3
robtarr
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Original Poster
Rep: Reputation: 0
The necessary ports (5900 and 5901) are currently open. I can get a connection. But cannot do anything with the connection. I'm logged in and using gnome, but when I connect I get no usable interface.
 
Old 03-03-2009, 02:02 PM   #4
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Hi, This likely because vnc is not correctly configured on the server you are connecting into. For the user you are connecting into as check the configuration of the ~/.vnc/xstartup file. It likely has not been configured to start gnome or kde.

Add the following as the last line of the file to load gnome and try restarting the VNC session and reconnecting.

gnome-session &
 
Old 04-16-2009, 11:01 AM   #5
GLS
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
Hi,

I have exactly the same problem.

If someone have a solution...

Best regards.
 
Old 07-03-2009, 05:42 PM   #6
srv0
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
Here's what worked for me:

Seen this on a few distro's... what it's sometimes turned out to be is an issue with an environment variable causing gnome to not start correctly from vncserver.

Try unsetting DBUS_SESSION_MANAGER_ADDRESS before starting vncserver.
 
  


Reply

Tags
vnc, xinitrc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC connection to SUSE Linux 10 from a Windows XP VNC Viewer determin2excel Linux - Software 13 10-03-2007 09:38 AM
VNC - Connection refused silkyd Linux - Networking 12 03-29-2006 08:09 AM
vnc connection config spedsta Linux - Networking 2 03-31-2005 02:29 AM
VNC connection issues... Joshoowa Linux - Networking 2 02-05-2005 07:07 AM
Previously working vnc... no longer working marsonist Linux - Networking 1 01-21-2004 07:34 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration