LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-06-2005, 09:18 PM   #1
rafiqul
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Rep: Reputation: 15
VNC Client at XP / Server at Fedora Core 4 install question


Hi,

I have VNC Server installed at my FC4 machine. When I do "yum list installed vnc" it shows both vnc.i386, and vnc-server.i386 installed. Also when I type at the command prompt "vn+tab" it shows I have following file:
vncconfig
vncconfig.py
vncpasswd
vncserver
vncviewer

I also installed vnc client at my laptop (running on Windows XP professional), when I run the client it asks me to type VNC server information using "host:display" format - I dont know whats that mean. but I tried to use the IP address of my machine where FC 4 running (VNC server), but its says login failed.

I am able to ping to my FC4 machine from my laptop, also I am able to telnet, ftp etc...
Also, I ran vncserver - its created couple of files such as :
Created default startup script in /root/.vnc/xstartup
starting application specifid in /root/.vnc/xstartup
logfile /root/.vnc/local.localdomain:1.log

Can anyone help me how to get around this problem ? Do I have to setup anything on the server, or client side ? Please note VNC server is on my FC4 machine, and VNC client is on my laptop (XP).

Thanks for your help.

Last edited by rafiqul; 12-06-2005 at 09:41 PM.
 
Old 12-06-2005, 10:06 PM   #2
rafiqul
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Original Poster
Rep: Reputation: 15
I just tried re-running my vncserver as follows:

vncserver:2 (i.e. Display 2)

And in the client I typed my server IP:2, it connected to my FC4 server just fine. I only see a blank desktop and the terminal that is opened at my desktop.

Can you guys help me how to get to view the full desktop ?

Thanks
 
Old 12-06-2005, 10:56 PM   #3
tsphan
Member
 
Registered: Jan 2005
Location: Clackamas, Oregon, US
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
what you want is to load up the main desktop of your current X session, known as IP:0.

This can be done by running x0vncserver each time X loads.

Or add it into your x11 configuration file, my preference.

add a vnc module load in your X config:
Code:
Section "Module"
        Load  "vnc"
EndSection
then, in the screen section, add:

Code:
Section "Screen"
        Option "passwordFile" "/link/to/password/file/passwd"
You can make a passwd file by running vncpasswd, whoever you runned the file as, it'll be saved into their home directory under .vnc/passwd


This will allow the X session to load up each time with a vnc server built-in. Or, just stick with the x0vncserver
 
Old 12-11-2005, 08:42 PM   #4
rafiqul
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Original Poster
Rep: Reputation: 15
Created a passwd file by running vncpasswd, and add code about "module" and "Sreen" section above, (passwd file path I added "/root/.vnc/passwd") in the /etc/X11/xorg.conf

And finally ran the vncserver again...tried to connect from my laptop, and seeing the same thing..a blank desktop.

Did I have to run any services ? Or x0vncserver ? If so, can you please be a little detail about it ? Is anything that I doing anything wrong ?

Awaits your response...

Last edited by rafiqul; 12-11-2005 at 08:57 PM.
 
Old 12-11-2005, 10:09 PM   #5
tsphan
Member
 
Registered: Jan 2005
Location: Clackamas, Oregon, US
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
when you tried connecting, did you type in IPAddress:0 , with the :0?
you shouldn't have the run vncserver, it'll be automatically loaded with the X server
 
Old 12-12-2005, 01:50 PM   #6
rafiqul
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Original Poster
Rep: Reputation: 15
No. I tried running server first, by typing vncserver, and then I see a text message like vncserver:2, or sometimes vncserver:3. Depending on what I see, I type at the vncviewer "IP:2", or "IP:3", and then I connect.
 
Old 12-12-2005, 03:30 PM   #7
poochdog
Member
 
Registered: Jul 2004
Location: United Kingdom
Distribution: Fedora Core 9
Posts: 141

Rep: Reputation: 15
Hi I beleive this guide will help you, it contains information on editing the file which will show the full desktop. I beleive this information can be found on page two towards the bottom of the page. The link is http://www.notgotaclue.co.uk/art-winandlin.htm
 
Old 12-13-2005, 12:19 AM   #8
tsphan
Member
 
Registered: Jan 2005
Location: Clackamas, Oregon, US
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
vncserver runs another X session on :1 :2 and :3, depending on how you run it.

While editing the X11 configuration will allow you to connect to the current X session, aka, :0
try to connect to :0
 
Old 12-23-2005, 12:01 PM   #9
rafiqul
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Original Poster
Rep: Reputation: 15
Excellent !!! Its just working great. The link above was realy helpful - thank you guys for your help.
 
Old 12-24-2005, 09:58 PM   #10
001010
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
I am sort of in the same situation... However I am able to get connected through VNC, however on FC4 I get this message asking me to Accept or Decline the incoming connection. I have not been able to find a way to auto-accept the connection since it prompts me for my passwd anyways. Any hints?
 
Old 01-15-2006, 11:33 AM   #11
rmfought
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
tsphan -

Will this support only one user at a time? Can you use the Option "passwordFile" more than once?
 
Old 01-15-2006, 06:34 PM   #12
tsphan
Member
 
Registered: Jan 2005
Location: Clackamas, Oregon, US
Distribution: Slackware 10.2
Posts: 154

Rep: Reputation: 30
i've never checked to see if someone could vnc twice to a computer before... i would think that if it works on other scenarios, it'll probably work on this one.

as for the passwordFile thing, i don't think it's possible and i also don't see what the point of it would be
 
Old 01-16-2006, 12:44 PM   #13
poochdog
Member
 
Registered: Jul 2004
Location: United Kingdom
Distribution: Fedora Core 9
Posts: 141

Rep: Reputation: 15
Hi there,

You can have multiple instances of VNC sessions, if you want to do this however, then I would recommend FREENX this link here has a couple of tutorials, one for freenx and one for VNC.

It will help you get started with this.
 
Old 01-17-2006, 07:37 AM   #14
rmfought
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
That's all I'm looking for, multiple users accessing the box via VNC simultaneously.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP server install in Fedora Core 4 rafiqul Linux - Newbie 5 12-06-2005 08:30 PM
Fedora Core 1 VNC Server Problems alannerd Linux - Networking 2 07-09-2005 05:17 AM
Vnc Server Strange Behavior In Fedora Core 3 kasra Fedora 3 06-26-2005 06:11 AM
VNC Server setup for Fedora Core 3 HELP!!! PLZ bkz81 Linux - Networking 7 06-09-2005 03:49 PM
Fedora Core 3 PC , how to be connected as client to windows server 2003 domain omaramir Linux - Networking 4 02-03-2005 02:28 AM


All times are GMT -5. The time now is 07:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration