LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-05-2013, 12:26 PM   #1
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Rep: Reputation: 0
VNC access problem - please advise


I just got account on a university cluster. The head node is CentOS58. I can access my account over SSH without problems. I also can access my Gnome desktop on the cluster over VNC, but only from home SciLInux58 box. From my office, however, I can only access my account over SSH to get basic CLI, either from RHEL58 box or from Mac terminal. Attempts to get Gnome desktop using the same procedure as from home fail with timeout error, no matter what platforms I use - RHEL58 (VNCViewer), Mac (bulit-in VNC), or Windows (PuTTY + VNCViewer). I guess it has something to do with the corporate network in my organization. Windows and Mac receive their addresses from DHCP, but RHEL58 box has a static internal address.
Unfortunately, cluster administration is not of much help as I am outsider, neither is our IT as they have no Linux expertise. I guess If I tell them what needs to be done admninistratively they could help. Please advise what steps I can take to get this resolved.
 
Old 03-05-2013, 12:33 PM   #2
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,797
Blog Entries: 4

Rep: Reputation: 285Reputation: 285Reputation: 285
I guess, your office network do not allow GUI based or X-applications to run in it's environment.

So just a hit, but can you once invoke following cmds from your office environment:
Code:
~$ xhost +<university_hostname_fqdn>
Or simply,
~$ xhost +
Also in your VNC viewer, under Options > Setting > check IdleTimeout option and set it to 3600 seconds.
 
Old 03-05-2013, 03:04 PM   #3
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Kubuntu
Posts: 1,190

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
xhost is for XDMCP connections, it has no influence to VNC. Can you explain in more details, which box is where and what IP it have? What command are you using to connect by VNC and how you start VNC server and it configuration? Check from office with command
Code:
traceroute -T -p 5901 your_vnc_server_ip
where packets are filtered (on your corporate router or at destination). Change 5901 port to that you use on server.
 
Old 03-05-2013, 08:31 PM   #4
samBl
Member
 
Registered: May 2006
Posts: 31

Rep: Reputation: 1
You could try to run the vnc traffic though an ssh tunnel. The vncviewer command makes this easy.
vncviewer -via larry@Remote_server localhost:1
 
Old 03-05-2013, 09:09 PM   #5
Jman-NZ
LQ Newbie
 
Registered: Mar 2013
Posts: 9

Rep: Reputation: Disabled
From your office RHEL58 computer, ssh to the university cluster with this command:
ssh -L 6001:127.0.0.1:5901 <uni cluster ip>
I just chose port 6001 randomly...use whatever unused port you like. Also change 5901 to whatever your VNC port is (5901 is usually the default first VNC port used)
Once you have established your ssh session, go back to your RHEL58 computer and type:
vncviewer localhost:6001
You should now be able to login via VNC as long as those ports aren't blocked by a firewall.
 
Old 03-07-2013, 08:03 AM   #6
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Original Poster
Rep: Reputation: 0
Nope, normal ways what should work do not work from the office, this is puzzling. From home , using SciLinux58, I can use three methods and all work fine. Once I launch vncserver on the cluster at port 5906:

Code:
ssh -L 5906:localhost:5906 <myacct@cluster.edu>
<login to cluster acct>
Code:
SciLinux58$ vncviewer [localhost] :6
or even simpler launching VNCViewer GUI client and entering ':6' into the address window.

Or without prior ssh:
Code:
SciLinux$ vncviewer -via <myacct@cluster.edu> :6
which opens VNCViewer login dialog allowing me enter acct password and connect.

Nothing of the above works from the office. The outcome is the same - "Connection timeout" as if the address of local machine cannot be found or wrong. Or else.

I try to poke network traffic as recommended, may be I get some insights.
 
Old 03-07-2013, 10:49 AM   #7
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Original Poster
Rep: Reputation: 0
Traceroute just gives me a bunch of addresses and times are between 4 and 9 ms. 30 hops, 40 byte packs, all seem completed fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vnc access divyashree Linux - Newbie 1 12-16-2010 03:52 AM
xdmcp gdm vnc remote access on Fedora 9 login problem JSLayton Linux - Software 1 09-23-2008 02:53 PM
rhel4 vnc problem, where to configure GUI vnc server? hocheetiong Linux - Newbie 1 10-24-2007 06:05 AM
windows vnc client and linux vnc server problem tungaw2001 Linux - Software 8 06-17-2006 12:06 AM
Need advise installing VNC. ckr Mandriva 1 09-30-2005 04:44 PM


All times are GMT -5. The time now is 11:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration