LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   VNC access problem - please advise (http://www.linuxquestions.org/questions/linux-newbie-8/vnc-access-problem-please-advise-4175452816/)

yaximik 03-05-2013 01:26 PM

VNC access problem - please advise
 
I just got account on a university cluster. The head node is CentOS58. I can access my account over SSH without problems. I also can access my Gnome desktop on the cluster over VNC, but only from home SciLInux58 box. From my office, however, I can only access my account over SSH to get basic CLI, either from RHEL58 box or from Mac terminal. Attempts to get Gnome desktop using the same procedure as from home fail with timeout error, no matter what platforms I use - RHEL58 (VNCViewer), Mac (bulit-in VNC), or Windows (PuTTY + VNCViewer). I guess it has something to do with the corporate network in my organization. Windows and Mac receive their addresses from DHCP, but RHEL58 box has a static internal address.
Unfortunately, cluster administration is not of much help as I am outsider, neither is our IT as they have no Linux expertise. I guess If I tell them what needs to be done admninistratively they could help. Please advise what steps I can take to get this resolved.

shivaa 03-05-2013 01:33 PM

I guess, your office network do not allow GUI based or X-applications to run in it's environment.

So just a hit, but can you once invoke following cmds from your office environment:
Code:

~$ xhost +<university_hostname_fqdn>
Or simply,
~$ xhost +

Also in your VNC viewer, under Options > Setting > check IdleTimeout option and set it to 3600 seconds.

eSelix 03-05-2013 04:04 PM

xhost is for XDMCP connections, it has no influence to VNC. Can you explain in more details, which box is where and what IP it have? What command are you using to connect by VNC and how you start VNC server and it configuration? Check from office with command
Code:

traceroute -T -p 5901 your_vnc_server_ip
where packets are filtered (on your corporate router or at destination). Change 5901 port to that you use on server.

samBl 03-05-2013 09:31 PM

You could try to run the vnc traffic though an ssh tunnel. The vncviewer command makes this easy.
vncviewer -via larry@Remote_server localhost:1

Jman-NZ 03-05-2013 10:09 PM

From your office RHEL58 computer, ssh to the university cluster with this command:
ssh -L 6001:127.0.0.1:5901 <uni cluster ip>
I just chose port 6001 randomly...use whatever unused port you like. Also change 5901 to whatever your VNC port is (5901 is usually the default first VNC port used)
Once you have established your ssh session, go back to your RHEL58 computer and type:
vncviewer localhost:6001
You should now be able to login via VNC as long as those ports aren't blocked by a firewall.

yaximik 03-07-2013 09:03 AM

Nope, normal ways what should work do not work from the office, this is puzzling. From home , using SciLinux58, I can use three methods and all work fine. Once I launch vncserver on the cluster at port 5906:

Code:

ssh -L 5906:localhost:5906 <myacct@cluster.edu>
<login to cluster acct>
Code:

SciLinux58$ vncviewer [localhost] :6
or even simpler launching VNCViewer GUI client and entering ':6' into the address window.

Or without prior ssh:
Code:

SciLinux$ vncviewer -via <myacct@cluster.edu> :6
which opens VNCViewer login dialog allowing me enter acct password and connect.

Nothing of the above works from the office. The outcome is the same - "Connection timeout" as if the address of local machine cannot be found or wrong. Or else.

I try to poke network traffic as recommended, may be I get some insights.

yaximik 03-07-2013 11:49 AM

Traceroute just gives me a bunch of addresses and times are between 4 and 9 ms. 30 hops, 40 byte packs, all seem completed fine.


All times are GMT -5. The time now is 07:17 PM.