LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2009, 08:38 AM   #1
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Rep: Reputation: 16
Unhappy vmware on linux


hi,


I am here again with a problem donot have any idea i wanted to install vmware on RHEL 5

Now see what i get

[root@localhost vmware-server-distrib]# ./vmware-install.pl
A previous installation of VMware software has been detected.

Failure

Execution aborted.


i did tried to instal it but failed as there as an error so what can i do now
 
Old 07-19-2009, 11:20 AM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Well, obviously you'd uninstall the previous instance first(vmware-uninstall.pl).
 
Old 07-19-2009, 02:41 PM   #3
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Original Poster
Rep: Reputation: 16
Unhappy

Quote:
Originally Posted by jay73 View Post
Well, obviously you'd uninstall the previous instance first(vmware-uninstall.pl).
this is what i get any way i can get it uninstalled


[root@localhost bin]# ll
total 2080
-r-xr-xr-x 1 working working 6160 May 10 2008 vmnet-bridge
-r-xr-xr-x 1 working working 110872 May 10 2008 vmnet-dhcpd
-r-xr-xr-x 1 working working 119076 May 10 2008 vmnet-natd
-r-xr-xr-x 1 working working 5192 May 10 2008 vmnet-netifup
-r-xr-xr-x 1 working working 8172 May 10 2008 vmnet-sniffer
-rwxr-xr-x 1 working working 4946 May 10 2008 vmrun
-r-xr-xr-x 1 working working 11456 May 10 2008 vm-support
-r-xr-xr-x 1 working working 4570 May 10 2008 vmware
-r-xr-xr-x 1 working working 73092 May 10 2008 vmware-authtrusted
-r-xr-xr-x 1 working working 23333 May 10 2008 vmware-cmd
-r-xr-xr-x 1 working working 290800 May 10 2008 vmware-config.pl
-r-xr-xr-x 1 working working 490464 May 10 2008 vmware-loop
-r-xr-xr-x 1 working working 25488 May 10 2008 vmware-mount.pl
-r-xr-xr-x 1 working working 10852 May 10 2008 vmware-ping
-r-xr-xr-x 1 working working 99602 May 10 2008 vmware-uninstall.pl
-r-xr-xr-x 1 working working 718200 May 10 2008 vmware-vdiskmanager
[root@localhost bin]# ./vm
vmnet-bridge vmnet-natd vmnet-sniffer vm-support vmware-authtrusted vmware-config.pl vmware-mount.pl vmware-uninstall.pl
vmnet-dhcpd vmnet-netifup vmrun vmware vmware-cmd vmware-loop vmware-ping vmware-vdiskmanager
[root@localhost bin]# ./vmware-c
vmware-cmd vmware-config.pl
[root@localhost bin]# ./vmware-config.pl
Unable to find the answer LIBDIR in the installer database
(/etc/vmware/locations). You may want to re-install VMware Server.

Execution aborted.

[root@localhost bin]# ./vmware-uninstall.pl
Uninstalling the tar installation of VMware Server.

Unable to find the answer INITSCRIPTSDIR in the installer database
(/etc/vmware/locations). You may want to re-install VMware Server.

Execution aborted.

[root@localhost bin]# cat /etc/vmware/locations
directory /etc/vmware
file /etc/vmware/locations
answer BINDIR /vmware/home/bin
directory /vmware/home/bin
 
Old 07-19-2009, 03:17 PM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I have just checked my own installation; those variables should really be there:

Quote:
devbox@Selena:~$ cat /etc/vmware/locations | grep LIBDIR
answer LIBDIR /opt/vmware/lib/vmware
devbox@Selena:~$ cat /etc/vmware/locations | grep INIT
answer INITDIR /etc
answer INITSCRIPTSDIR /etc/init.d
Have you checked whether your locations file exists at all and, if it does, whether it contains anything at all?
 
Old 07-19-2009, 03:53 PM   #5
adityasharma
Member
 
Registered: Jun 2009
Location: Noida
Distribution: RHEL 5
Posts: 39

Original Poster
Rep: Reputation: 16
Smile

Quote:
Originally Posted by jay73 View Post
I have just checked my own installation; those variables should really be there:



Have you checked whether your locations file exists at all and, if it does, whether it contains anything at all?
well u did hit the nail on the head
just checked it /etc/vmware/location file was there

adn it was currpted so i have to move it and then ran install and its working though in the installation its not informed to have xinetd configured so just working to get the RPMS

thanks a bunch
 
  


Reply

Tags
rhel, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuration to access internet from vmware(host=winXP, guest on vmware=linux-5) afz_linux Linux - Newbie 3 12-30-2008 01:20 AM
vmware server install error, The VMware VmPerl Scripting API was not installed. fakie_flip Linux - Software 4 12-28-2008 05:49 AM
vmware virtual machine slow in vmware client, faster viewer available? purplesocrates Linux - General 1 06-17-2008 11:40 AM
Install FC4 w/ Vmware, right of the Harddrive (vmware aceses ISO of HD, no CDs) colinstu Linux - General 1 02-24-2006 09:15 PM
Debug Linux kernel in vmware (two machines in vmware)?? cyu021 Programming 0 03-30-2005 08:46 PM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration