LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Closed Thread
 
Search this Thread
Old 07-01-2003, 02:51 AM   #1
amkhullar
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Question VMWARE 4.0 and REDHAT 9 (n/w and display problem)


Hi All,
I have VMWARE Workstation 4.0.0 Build 4460 installed on W2k Prof , i have installed Redhat Linux 9.0 in it, all the installation went fine during the setup it asked me for my Monitor and Display Card and as I could find the exact matched in its database I choosed Intel i815 VGA and Samtron 55V model, after that it asked me for the networj card settings which i left as it is and made the selection of NAT . Now whne the machine boots it says the eth0 is down , link failed cable not connectd and when it tries to start the Xwindows ( I choosed X windows and Gnome during the setup) it shows an empty blue screen with 2 options Yes and No. If I select Yes it goes blank and after sometimes it comes back again to the Same screen , when I press No it takes me to the Root and asks me to Login. What could be the problem in it , do i need to run the setup again and choose the Vesa Gneric drives and Unknown monitor for it to work, coz during the setup it was running the windows in it , everything mouse etc was wrking and now none is wrking. Plz help.

Regards
AK

amkhullar@yahoo.com
 
Old 07-01-2003, 04:15 AM   #2
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
According to the VMware web page VMware does not yet support Red Hat 9. That may or may not explain the problem you are having. VMware does support Red Hat 8 and Red Hat 7.3 but not Red Hat 9. I recently sent VMware an e-mail asking them when they would support Red Hat 9. Here is part of what they said:

"There is a possibility that Red Hat 9 will be supported as a host in a
future release. Sorry we can't give you a concrete answer about when."

Below is a link to a VMware web page that lists which operating systems are supported as hosts and as guests:

http://www.vmware.com/products/desktop/ws_specs.html
 
Old 07-01-2003, 01:48 PM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
amkhullar, don't specify your video card and monitor in Red Hat when installing as a guest in VMWARE. VMWARE is a virtual machine this means most devices are run at low-level but not all. Your serial, parallel, CD-ROM and CPU instructions are run at low level. Graphics, NIC, USB, and sound is run by high-level or using VMWARE drivers. Read the instructions on VMWARE site on how to install LINUX as a guest. To get NIC card working make sure you give permissions to VMWARE in Windows 2000.

Read
http://www.vmware.com/support/guestn...0.html#1086695
Its for Redhat 8.0 but it should help you install it properly in VMWARE.

Rick422, amkhullar is asking how to install Red hat 9 in VMWARE not installing VMWARE in Red hat 9. To install VMWARE in Red hat 9, you need to compile two files into modules. Then tell VMWARE to use those modules.
 
Old 07-14-2003, 08:39 AM   #4
mozonash
LQ Newbie
 
Registered: Jul 2003
Location: Edina MN
Distribution: RH 9
Posts: 3

Rep: Reputation: 0
I have a similar issue with networking. I can set up a static IP address, and eth0 works fine, but if I set things to DHCP, I get the "link failed" message as the poster above did for NAT. I'm not sure what the issue is; things are configured to find the DHCP server automatically, just as they are on my Win2k host.

On the other hand, the GUI seems to work fine, with the RH standard Gnome desktop coming up normally (installed the VMWare tools as directed and then did startx).
 
Old 07-14-2003, 01:46 PM   #5
dcruz
LQ Newbie
 
Registered: Jul 2003
Location: sunrise, fla
Posts: 23

Rep: Reputation: 15
http://www.vmware.com/support/kb/end...YWdlPTE*&p_li=

To work around this problem, become root (su -) and use a text editor to edit the following files in the guest operating system:
/etc/sysconfig/network-scripts/ifcfg-eth[n]
/etc/sysconfig/networking/devices/ifcfg-eth[n]

Also, if it exists, edit the file
/etc/sysconfig/networking/profiles/default/ifcfg-eth0

The third file is updated any time you run redhat-config-network and make changes in the Network Configuration panel.

In all cases, [n] is the number of the Ethernet adapter -- for example, eth0.

In each of the files, add the following section:

check_link_down () {
return 1;
}

Then run the command ifup eth[n] (where [n] is the number of the Ethernet adapter) or restart the guest operating system.
 
Old 07-14-2003, 04:25 PM   #6
mozonash
LQ Newbie
 
Registered: Jul 2003
Location: Edina MN
Distribution: RH 9
Posts: 3

Rep: Reputation: 0
Followed the procedure in dcruz's message, and it looks like RH 9 is happily using DHCP now. Thanks!
 
Old 07-14-2003, 04:37 PM   #7
dcruz
LQ Newbie
 
Registered: Jul 2003
Location: sunrise, fla
Posts: 23

Rep: Reputation: 15
went through the same problem myself. It took me a couple days to finally find an article that addressed the issue correctly.

Im a newbie too but Im happy to contribute to the forum!
 
Old 07-19-2003, 04:25 PM   #8
zi0oo
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Unhappy Where are the C header files?

I am trying to install RedHat 9.0 with VMware 4.0 as well. I would like to know if someone would like to share a basic tutorial. The step I'm stuck on is compiling VMware tools. I have installed the appropriate c compliers to achieve my goal. But in the process of compiling after you are prompted to re-compile. I am stuck at the point where you are asked "What is the location of the directory of the C header files that match your running kernel". I simply cannot find this directory </usr/src/linux/include>. Can anyone help me. Please advise.
 
Old 07-19-2003, 04:51 PM   #9
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
you will need to download the src rpm (just search for it on google or try the redhat site)

just download the src rpm and then get into terminal and type

su
(password)
rpm -ihv nameofthefile.rpm

then you should see a bunch of (####) and a percentage, just wait until two lines get through and then try installing vmtools again

question for u tho, how did u begin the vmtools install?
 
Old 07-19-2003, 08:13 PM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
You need the kernel source code. The kernel source should be located on the CD. Then go into /usr/src and make a symbolic link to the kernel source code directory. Name the symbolic link as linux. If you don't know how to make a symbolic link type man ln. Also install the compiler. Either gcc 2.95 or gcc 3.2. I don't have any trouble with version 3.2 of gcc compiler.

There are two ways to install VMware tools.
1) After guest OS has finished booting, in VMWARE's menu bar click on File -> Install VMWARE tools. Wait patiently.

2) Before you power on the guest OS, add a CD-ROM drive with an ISO image. Find the ISO file under VMWARE's directory. The file maybe under ISOIMAGES. Then power on the guest OS. Either mount the CD-ROM drive or access the CD-ROM drive and read the instructions for your guest OS. Then run the installation.

The second way always works, but the first way sometimes takes several minutes to respond.

IMO, VMWARE is best to run on LINUX instead of Windows. Windows consumes tons of resources that VMWARE needs. I suggest you get atleast 1 gigabyte of memory because Windows hogs resources like a pig.
 
Old 07-20-2009, 09:21 PM   #11
lordofall20
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Rep: Reputation: 0
Lightbulb Possibly the fix to your issue

I have installed Redhat 9 many times on VM Console. I have discovered that you should not tamper with the setting and just simply click next, because the default selection is the only selection that will work properly. I had this same problem with a keyboard, because it was either I selected PS2 keyboard or USB keyboard and it was the other, so my keyboard didn't work and I couldn't finish the installation. I HOPE THIS HELPS!!!
 
Old 07-21-2009, 03:08 AM   #12
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,964
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Good grief my friend ... why did you dig THAT 6 year old
corpse of a thread up for? VMWare 4 is as dead as RedHat 9.

Next time you're looking for a thread to post to could
you please check its date?


Thanks,
Tink
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing RedHat 7.3 using VMware 4.0 on Windows XP rajm438 Linux - Software 3 04-26-2004 10:21 PM
vmware 4.0 having RedHat 7.3 booting problem from CD rajm438 Linux - Software 0 04-25-2004 02:13 PM
Network problem In Redhat 9 in VMware aero Linux - Distributions 1 06-05-2003 07:10 AM
Big Problem installing VMware on RedHat 7.3 mtcald01 Linux - Software 2 01-31-2003 09:47 AM
RedHat 7.1 Display Problem todd2000 Linux - Distributions 1 08-27-2001 07:35 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration