LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2010, 09:05 AM   #1
sumanch
LQ Newbie
 
Registered: Jan 2010
Posts: 24

Rep: Reputation: 16
VM question


Hi ,
I have installed a VMware server in my Laptop. There I have created a VM . I have installed centOS on that VM . I want to access internet from that VM . While creating the VM I have created a network adapter in bridged mode . I am connectig to internet using a modem and my Laptop gets ip address using DHCP . What all changes I need to make to access internet from the VM .

regards
Suman
 
Old 02-10-2010, 11:35 AM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Arch/Slackware/Knoppix
Posts: 1,761
Blog Entries: 14

Rep: Reputation: 267Reputation: 267Reputation: 267
What you did should've accomplished what you wanted. What kind of errors are you getting?
 
Old 02-11-2010, 11:14 AM   #3
sumanch
LQ Newbie
 
Registered: Jan 2010
Posts: 24

Original Poster
Rep: Reputation: 16
I am able to access the internet . I want to install a web server on that VM . How do I access that server from outside world ? Do I need to use the ip of my Laptop . How do I accomplish that .

regards
Suman
 
Old 02-12-2010, 08:57 AM   #4
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Arch/Slackware/Knoppix
Posts: 1,761
Blog Entries: 14

Rep: Reputation: 267Reputation: 267Reputation: 267
When you set up the VM, it'll have it's own IP; you should use that. Just think of the VM as another machine on your home network.
 
Old 02-12-2010, 09:10 AM   #5
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
Sumanch..I tried it last Friday and it worked fine.
All you need to select NAT instead of Bridge.
This can be accomplished through iptables rule.
Just Google it with NAT + Vmware + Internet..You gonna find lots of setup
If you couldnt find, ping me back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
basic html question - download link to files on my webpage question Davno Linux - Server 5 12-25-2009 08:24 AM
linux distro question & mysql install question natalie.aloi Linux - Newbie 5 07-19-2009 09:28 PM
Question, Apples Contribution to Open Source + MacOs file structure question Higgy3k Other *NIX 5 07-25-2005 05:23 AM
Not your regular GRUB question - just a short question for a fried MBR!! ziphem Linux - General 3 01-31-2005 02:51 PM
login prompt question & kde scheme question JustinCoyan Slackware 2 06-09-2004 03:02 PM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration