LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2007, 10:54 AM   #1
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Rep: Reputation: 16
Angry vlc yum install failure


okay first off i've read all the threads i can find about my situation to try and avoid this post but i can't figure it out on my own...

trying to install VLC via yum install on FC4

i went to the vlc website, which told me i needed to make some repo's and i copy/pasted straight from this link:

http://www.videolan.org/vlc/download-fedora.html

from there i did this:

Quote:
[root@localhost yum.repos.d]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
vlc-contrib 100% |=========================| 718 B 00:00
vlc-devel 100% |=========================| 718 B 00:00
vlc 100% |=========================| 718 B 00:00
updates 100% |=========================| 1.2 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
vlc-source 100% |=========================| 718 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Error: Error: requested datatype primary not available
so am i leaving something out or did i do something wrong when i created the files from the vlc website? so far linux is really good at makin me feel like a noob.
 
Old 07-19-2007, 11:21 AM   #2
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
well i just found out i'm running FC6 rather than FC4, i'm still getting the install error though...

Quote:
[root@localhost /]# yum install vlc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
core 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
vlc-source 100% |=========================| 718 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 62 kB 00:02
freshrpms : ################################################## 168/168
Error: Error: requested datatype primary not available
[root@localhost /]#
also i'm getting this error anytime i try to yum install anything

linux will be the death of me =/

Last edited by alabamaman; 07-19-2007 at 11:53 AM.
 
Old 07-19-2007, 01:11 PM   #3
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 23 Fedora 22
Posts: 244

Rep: Reputation: 37
If you still have the Livna repo enabled for FC4 you will have to disable/remove them from "etc/yum/yum.repos.d" then install the correct livna repo for FC6:
Code:
# rpm -ivh http://rpm.livna.org/livna-release-6.rpm
the:
Code:
# yum install vlc vlc-devel libdvdcss libdvdcss-devel
 
Old 07-19-2007, 01:24 PM   #4
RoughEdge
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Slackware 12
Posts: 67

Rep: Reputation: 15
I would try removing yum then re-installing it. Then install the livna repo and use that to get vlc. In my experience with Fedora 7, it was called

Code:
yum install videolan-client
 
Old 07-19-2007, 01:26 PM   #5
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Ryptyde
If you still have the Livna repo enabled for FC4 you will have to disable/remove them from "etc/yum/yum.repos.d" then install the correct livna repo for FC6:
Code:
# rpm -ivh http://rpm.livna.org/livna-release-6.rpm
the:
Code:
# yum install vlc vlc-devel libdvdcss libdvdcss-devel
thx for the suggestion only its not a problem with the livna (at least i assume) because when i copied that code it told me i already has livna6 installed. i think the problem is of the same nature, but with the freshrpms. do you happen to have a link for the update of that one? or perhaps you could tell me how to find it on my own? (whenever i go to freshrpms.net it just gives a list of specific programs and what not)

Code:
[root@dustyfedora yum.repos.d]# rpm -ivh http://rpm.livna.org/livna-release-6.rpm
Retrieving http://rpm.livna.org/livna-release-6.rpm
warning: /var/tmp/rpm-xfer.NzFLZA: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing...                ########################################### [100%]
        package livna-release-6-1 is already installed
[root@dustyfedora yum.repos.d]# yum install vlc vlc-devel libdvdcss libdvdcss-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna                     100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
core                      100% |=========================| 1.1 kB    00:00     
freshrpms                 100% |=========================| 2.1 kB    00:00     
vlc-source                100% |=========================|  718 B    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Error: Error: requested datatype primary not available
asdf!!
 
Old 07-19-2007, 02:24 PM   #6
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by RoughEdge
I would try removing yum then re-installing it. Then install the livna repo and use that to get vlc. In my experience with Fedora 7, it was called

Code:
yum install videolan-client
well i gave that one a shot, and ty for the suggestion but i came back to the same stop sign. hopefully i'm not the only one who feels like a drunk teenager walking around the block all night trying to find his front door, only to walk face first into a big stop sign each time he makes it around. it seems like this shouldn't be a big deal...i've searched all over the place and nobody seems to have any suggestions other than reboot...which i've done. bleh. guess its time to tinker.
 
Old 07-19-2007, 02:32 PM   #7
RoughEdge
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Slackware 12
Posts: 67

Rep: Reputation: 15
try removing the freshrpms repo from the yum repos. It may have a problem with the livna and freshrpms when they may both have the same package. Other than that I'm clueless :x

Chris
 
Old 07-19-2007, 02:56 PM   #8
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by RoughEdge
try removing the freshrpms repo from the yum repos. It may have a problem with the livna and freshrpms when they may both have the same package. Other than that I'm clueless :x

Chris

yeah see that's what i'm thinking too...only i don't know how to do that =/ anybody wanna give me a hand?
 
Old 07-19-2007, 03:22 PM   #9
RoughEdge
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Slackware 12
Posts: 67

Rep: Reputation: 15
I used Fedora for a while but can't remember the exact file, its something like

Code:
vim /etc/yum.repos.d
or
vim /etc/yum.repos
You could always
Code:
su
 
updatedb
locate yum.repo
Let me know how that works out.
 
Old 07-19-2007, 03:32 PM   #10
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
Angry

okay i started with this:

Code:
[root@dustyfedora remoteadmin]# updatedb
[root@dustyfedora remoteadmin]# locate yum.repo
/etc/yum.repos.d
/etc/yum.repos.d/.yum.repos.d.swp
/etc/yum.repos.d/fedora-core.repo
/etc/yum.repos.d/fedora-development.repo
/etc/yum.repos.d/fedora-extras-development.repo
/etc/yum.repos.d/fedora-extras.repo
/etc/yum.repos.d/fedora-legacy.repo
/etc/yum.repos.d/fedora-updates-testing.repo
/etc/yum.repos.d/fedora-updates.repo
/etc/yum.repos.d/livna-devel.repo
/etc/yum.repos.d/livna-testing.repo
/etc/yum.repos.d/livna.repo
/etc/yum.repos.d/vlc-source.repo
/etc/yum.repos.d/vlc-source.repo~
but, HELLO STOP SIGN!

Code:
[root@dustyfedora remoteadmin]# yum update yum
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Error: Error: requested datatype primary not available
[root@dustyfedora remoteadmin]#
???
 
Old 07-19-2007, 03:46 PM   #11
RoughEdge
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Slackware 12
Posts: 67

Rep: Reputation: 15
The one you want to edit is /etc/yum.repos.d it's a directory and you will see the freshrpms in there, just
Code:
 rm -rf freshrpmsfilename
Also, if you are having problems still, could you post your /etc/yum.conf may help

Cheers
 
Old 07-19-2007, 05:33 PM   #12
alabamaman
Member
 
Registered: Jul 2007
Location: linux-noobville.d/dfw texas
Distribution: grub multi-booter
Posts: 102

Original Poster
Rep: Reputation: 16
Thumbs up

so i figured it out...i had some vlc-xxx whatever rpms in there? i guess from something i tried before and forgot about, but i deleted them and got it installed just fine...how if only i could actually install ANYTHING without a hangup. linux and i have such a roller coaster relationship.


thx for the help guys
 
Old 07-19-2007, 08:31 PM   #13
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 23 Fedora 22
Posts: 244

Rep: Reputation: 37
Wasn't able to get back sooner but RoughEdge gave good advice about only using one 3rd party repo as mixing them will lead to breakage and an eventual reinstall.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update failure?? tommy12 Linux - Software 3 03-24-2007 02:44 AM
fc5: yum update causes failure pcandpc Fedora 3 05-07-2006 01:01 AM
yum update failure! hueofwind Linux - General 3 11-02-2005 11:41 PM
yum problem while installing vlc in RedHat FC4 g_srinivas Linux - Software 1 07-20-2005 11:18 PM
yum update failure?? winchester169 Linux - Software 0 09-17-2004 02:41 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration