LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2013, 04:31 AM   #1
marcelp1
LQ Newbie
 
Registered: Nov 2010
Distribution: Debian
Posts: 29

Rep: Reputation: 1
VLC - Unable to correct problems, you have held broken packages.


I had some problems with the VLC installed via apt-get install vlc
so looked at the http://www.videolan.org/vlc/download-debian.html
to install VLC from wheezy-backports.

So I have first removed current version:

Commandline: apt-get --purge remove vlc
Purge: vlc:i386 (2.0.6-dmo1)



then autoremove not needed packages as recommended by the system:

Commandline: apt-get autoremove
Remove: libva-x11-1:i386 (1.0.15-4), libxcb-keysyms1:i386 (0.3.9-1), libsvga1:i386 (1.4.3-33), libtar0:i386 (1.2.16-1), libwebp2:i386 (0.1.3-3+nmu1), python-central:i386 (0.6.17), libxcb-randr0:i386
(1.8.1-2+deb7u1), libxcb-composite0:i386 (1.8.1-2+deb7u1), vlc-plugin-notify:i386 (2.0.6-dmo1), vlc-plugin-pulse:i386 (2.0.6-dmo1), libsdl-image1.2:i386 (1.2.12-2)




then added following to my sources.list

sudo nano /etc/apt/sources.list

## VLC Wheezy-Backports
deb http://ftp.uk.debian.org/debian/ wheezy-backports main


and run sudo apt-get update && sudo apt-get upgrade


now, when I want to install vlc from backports with command I get this:

sudo apt-get -t wheezy-backports install vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.0.3-5) but 1:2.0.6-dmo1 is to be installed
Recommends: vlc-plugin-notify (= 2.0.3-5) but it is not going to be installed
Recommends: vlc-plugin-pulse (= 2.0.3-5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.




it is same for normal install as well:

sudo apt-get install vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.0.3-5) but 1:2.0.6-dmo1 is to be installed
Recommends: vlc-plugin-notify (= 2.0.3-5) but it is not going to be installed
Recommends: vlc-plugin-pulse (= 2.0.3-5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.




I have found this command in here:
http://askubuntu.com/questions/33223...n-dependencies

sudo apt-cache policy vlc-data vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse
vlc-data:
Installed: 1:2.0.6-dmo1
Candidate: 1:2.0.6-dmo1
Version table:
*** 1:2.0.6-dmo1 0
100 /var/lib/dpkg/status
2.0.3-5 0
500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
vlc:
Installed: (none)
Candidate: 2.0.3-5
Version table:
2.0.3-5 0
500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
vlc-nox:
Installed: 1:2.0.6-dmo1
Candidate: 1:2.0.6-dmo1
Version table:
*** 1:2.0.6-dmo1 0
100 /var/lib/dpkg/status
2.0.3-5 0
500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
vlc-plugin-notify:
Installed: (none)
Candidate: 2.0.3-5
Version table:
2.0.3-5 0
500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
vlc-plugin-pulse:
Installed: (none)
Candidate: 2.0.3-5
Version table:
2.0.3-5 0
500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages



but sudo apt-get update && sudo apt-get upgrade does not solve the problem
as I still get the same message.

Last edited by marcelp1; 10-03-2013 at 04:52 AM. Reason: Amended title
 
Old 10-03-2013, 05:44 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
sudo apt-get dist-upgrade
would take care of held packages
 
1 members found this post helpful.
Old 10-04-2013, 04:22 AM   #3
marcelp1
LQ Newbie
 
Registered: Nov 2010
Distribution: Debian
Posts: 29

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by EDDY1 View Post
would take care of held packages
I have found that that basically it was saying that there was still packages on the system, so

sudo apt-get remove --purge vlc*
and
sudo apt-get remove --purge vlc-data
removed the following and I was able to install VLC from backports:

Purge: krusader:i386 (2.3.0~beta1-1+wheezy3), phonon:i386 (4.6.0.0-3), libkonq5abi1:i386 (4.8.4-2), libvlc5:i386 (2.0.6-dmo1), phonon-backend-vlc:i386 (0.6.0-1), vlc-nox:i386 (2.0.6-dmo1), libkonq-common:i386 (4.8.4-2), kde-runtime:i386 (4.8.4-2), vlc-data:i386 (2.0.6-dmo1), libvlccore5:i386 (2.0.6-dmo1)


so when removing vlc I should have run following:
sudo apt-get remove --purge vlc
sudo apt-get remove --purge vlc*
sudo apt-get remove --purge vlc-data
sudo apt-get autoremove
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i cant install vlc charlesips Linux - Software 2 10-03-2009 07:35 AM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 11:48 PM
install vlc... din Slackware 2 03-28-2008 01:44 AM
VLC install... Poolen Linux - Software 1 09-23-2005 08:20 AM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration