LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2014, 01:05 PM   #1
qweyu
LQ Newbie
 
Registered: Jan 2012
Location: Kampala - Uganda
Distribution: Slackware 14.1
Posts: 21

Rep: Reputation: Disabled
vlc installation problem


Hi pple,

Am using slackware 14.0 and i have downloaded the source files fro m SlackBuilds.org however when i run the script (vlc.SlackBuilds) it throws an error like this;

Quote:
checking for LUA... no
configure: WARNING: No package 'lua5.2' found, trying lua 5.1 instead
checking for LUA... no
configure: WARNING: No package 'lua5.1' found, trying lua >= 5.1 instead
checking for LUA... no
configure: WARNING: No package 'lua' found, trying manual detection instead
checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking lauxlib.h usability... no
checking lauxlib.h presence... no
checking for lauxlib.h... no
checking lualib.h usability... no
checking lualib.h presence... no
checking for lualib.h... no
checking for luaL_newstate in -llua5.2 ... no
checking for luaL_newstate in -llua5.1 ... no
checking for luaL_newstate in -llua51 ... no
checking for luaL_newstate in -llua ... no
configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error.
i know i have to change something in this script but i do not know how.
can anybody help me
 
Old 03-31-2014, 01:10 PM   #2
cin_
Member
 
Registered: Dec 2010
Posts: 277

Rep: Reputation: 24
plugin scripting

lua is a scripting language often used for plugin extensions, also the error tells of some vlc features that you will be unable to use without lua on your system:
rc :: http://www.videolan.org/doc/play-how....html#id591054
telnet :: http://www.videolan.org/doc/streamin...o/en/ch05.html
http :: http://www.videolan.org/doc/play-how....html#id590873

if you are fine without these service modules andor the capability to extend vlc with lua plugins you can run the ./configure with the --disable-lua flag

Code:
# ./configure --disable-lua
...
# make
another option would be to install lua on your box

http://slackbuilds.org/repository/14.1/development/lua/

and see if the error persists

Last edited by cin_; 03-31-2014 at 01:22 PM. Reason: gramm`err
 
1 members found this post helpful.
Old 07-02-2014, 01:16 PM   #3
mrohit2011
LQ Newbie
 
Registered: Jul 2014
Posts: 3

Rep: Reputation: Disabled
Hello Cin,
I am too facing the same problem over here,

configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error.

But now i have installed lua 5.2.0 .... then also i have same error.

I also tried the other way round i.e. by using --disable-lua...
But now i have following error:

configure: error: Could not find libmad on your system: you may get it from Alternatively you can use --disable-mad to disable the mad plugin.

Experts ..Please help me..... I am unable to solve this error from my system.....!!!
 
Old 07-02-2014, 01:41 PM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Either get lua from SlackBuilds, then run your VLC SlackBuild again. Or get a ready made package from Alien Bob:
http://www.slackware.com/~alien/slackbuilds/vlc/
 
Old 07-02-2014, 11:12 PM   #5
mrohit2011
LQ Newbie
 
Registered: Jul 2014
Posts: 3

Rep: Reputation: Disabled
hello brian,
I am using ubuntu 12.0LTS .......
So will this package work for me........
 
Old 07-03-2014, 05:23 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Quote:
Originally Posted by mrohit2011 View Post
hello brian,
I am using ubuntu 12.0LTS .......
So will this package work for me........
No, that advice only applies if you're using Slackware.
 
Old 07-03-2014, 06:36 AM   #7
mrohit2011
LQ Newbie
 
Registered: Jul 2014
Posts: 3

Rep: Reputation: Disabled
kkk...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in vlc installation karthickk02 Linux - Newbie 4 10-04-2010 06:42 AM
Dependencies problem in vlc installation crahuldba@gmail.com Linux - Newbie 3 09-30-2010 09:47 PM
vlc installation problem ritam_bkp Linux - Newbie 6 01-04-2009 12:54 PM
VLC installation problem in fedora sayantanhore Linux - Newbie 6 11-22-2008 12:14 AM
0.8.6a vlc source installation problem shady_Dev Linux - Software 3 12-25-2007 01:06 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration