LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2007, 08:34 PM   #1
tferero
Member
 
Registered: Sep 2007
Location: Near the Canadian border
Distribution: kubuntu 8.04 Hardy Heron
Posts: 48

Rep: Reputation: 16
virus found!


I just ran Aegis and it found virus in several dll files in the crossover office folder - I downloaded this from the crossover website. What should I do with these - delete or quarantine? Will this cause problems to things not running right? This is what Aegis reported:

medcat.dll >> w32/magistr.a@MM
msgr2en.dll >>w32/magistr.a@MM
msjro.dll >> w32/magistr.a@MM

I am surprised to see this as I assumed Crossover would have clean installs
 
Old 09-25-2007, 04:37 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Did you mail the crossover site and ask them?
 
Old 09-25-2007, 04:49 AM   #3
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
check those dll's here: http://www.virustotal.com/

Most probably this is false alarm caused by aegis, which does not give reliable results.
 
Old 09-25-2007, 05:43 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You can always get a second opinion by installing, say, f-prot.
 
Old 09-25-2007, 08:55 AM   #5
tferero
Member
 
Registered: Sep 2007
Location: Near the Canadian border
Distribution: kubuntu 8.04 Hardy Heron
Posts: 48

Original Poster
Rep: Reputation: 16
Thanks!

Thanks everyone for the replies...

Crossover's website had a searchable database of questions/problems, and it would seem that there are a number of false positive readings with various windows based viruses. I didn't find an answer to this one specifically, but I am reasonably assured that its nothing to worry about.

Almatic, thanks for the website - this is a great tool! I am still trying to locate the actuall dll files - when I run find files in kubuntu, it doesn't give me the full path, so I am wondering if they are in a hidden folder somewhere... will work on that later when I get home from work.

Jay73, I tried downloading f-prot (both in Adept and from the website) but the installation failed. From the website I downloaded the .deb version, but I got error messages in the install. Are there known dependencies that I should look for? As a newbie, I still have trouble with installs.

Thanks...
 
Old 09-25-2007, 09:21 AM   #6
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Quote:
Jay73, I tried downloading f-prot (both in Adept and from the website) but the installation failed. From the website I downloaded the .deb version, but I got error messages in the install. Are there known dependencies that I should look for? As a newbie, I still have trouble with installs.
Adept should satisfy the dependencies for you, assuming the packages are in the repositories listed in your /etc/apt/sources.list.

1. try to install f-prot again. Write down error messages relating to failed depencencies.

2. www.google.com/linux to search for those depencent packages.

3. add the locations of those packages to your sources.list, then try again to install f-prot.
 
Old 09-25-2007, 09:25 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Quote:
Originally Posted by tferero View Post
...I am still trying to locate the actuall dll files - when I run find files in kubuntu, it doesn't give me the full path...
Try the command "locate". Maybe the command "updatedb" issued once before the "locate" is necessary. And as always there are the man pages for more information .
 
Old 09-25-2007, 08:53 PM   #8
tferero
Member
 
Registered: Sep 2007
Location: Near the Canadian border
Distribution: kubuntu 8.04 Hardy Heron
Posts: 48

Original Poster
Rep: Reputation: 16
Follow up on f-prot

Just as a follow-up, I tried reinstalling f-prot, and what a problem that was! The install failed (froze up) midstream and I had to close adept. What a problem that created! Adept refused to run, and when it did open (after a reboot) it said that I had read only rights because another process was using the packager. To make a really long story short, I finally realized that the only fix (after trying lots of other things found on various boards) was to uninstall the programs at the command line.

What turned out to be an easy fix took me forever to arrive at. At various points I got adept to run (I still don't exactly know how). When I tried to install something else as a test, I realized that adept tried to finish any broken downloads with the next download. It was essentially stuck on trying to grab the f-prot file every time. I could not find a way to tell it to give up on this file.

For anybody a similar situation, the command was simple:
sudo dpkg -r filename. For other newbies, keep in mind that this command line is for kubuntu with kde. Others are probably different.

I have no idea why f-prot would not install properly - I definitely have run the update manager often enough to ensure current info. Based on some of the error messages, it seemed like the ftp address it was pointing to was incorrect.

If anyone has encountered this and has something to offer, I would be grateful, because I really wanted to try this program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I found a virus on the bit torrents for 10.1 cereal83 Slackware 17 12-16-2006 06:07 PM
Klamav - virus found - Zip.ExceededFilesLimit rrsc16954 Mandriva 7 01-16-2006 07:53 PM
Mysql Server ...virus Attack Found ! my-unix-dream Linux - Newbie 9 05-15-2005 12:35 PM
Boot virus or Anti-Virus? AVG Free Anti-Virus Software problems SparceMatrix Linux - Security 9 08-02-2004 03:35 PM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration