LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-14-2009, 05:15 AM   #1
:::
Member
 
Registered: Aug 2009
Distribution: slackware 12.2
Posts: 51

Rep: Reputation: 17
vim delayed on startup


problem: vim takes a long time on startup (~ 5+ sec)

# system info
system: 2.6.27.7-smp
distro: slackware 12.2

# vim info (i don't use gvim)
version: 7.2.18
bindir: /usr/bin

# window manager might be part of the problem
wm: wmii 3.1

# description:
i'd like to launch vim directly and not by opening an
Xterm and typing vim. so i used:
Code:
$ xterm -e /usr/bin/vim
in a startup script. it took ages for vim to start (even
Emacs is faster ). i tried the -X option.
Code:
$ xterm -e /usr/bin/vim -X //and
$ xterm -e "/usr/bin/vim -X"
no luck. starting vim in an open xterm is no problem and
it starts almost immediately. anybody know why and how to
work around?

# additional info:
the Xterm i use is customized through .Xdefaults. the relevant
lines are:
Code:
xterm*Scrollbar:   off
xterm*font: -xos4-terminus-medium-*-*-*-14-*-*-*-*-*-*-*
xterm*background: rgb:00/22/33
xterm*foreground: honeydew
xterm*cursorBlink: true
xterm*cursorColor: DarkGoldenRod1
 
Old 08-14-2009, 11:28 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hi,

and welcome to LQ!

I haven't come across this myself, but what I'd do if I
found myself in that situation is to run vim under strace
with timing information enabled.

Code:
strace -o vim_startup -tvfF xterm -e /usr/bin/vim
After it pops up, quit out and analyse the file vim_startup
to see where it spent how much time.



Cheers,
Tink
 
Old 08-15-2009, 06:04 AM   #3
:::
Member
 
Registered: Aug 2009
Distribution: slackware 12.2
Posts: 51

Original Poster
Rep: Reputation: 17
Thanks for the advice Tinkster,

the problem has somehow disappeared. it must have been a temporary setting which i wasn't aware of. :::
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Faster gnome session startup by delayed programs start catkin Programming 2 06-21-2010 08:19 AM
Faster gnome session startup by delayed programs start catkin Linux - Desktop 0 07-06-2009 01:21 PM
Java startup is delayed for minutes Q.. Linux - Software 8 06-12-2008 08:37 PM
delayed program startup GT_Onizuka Linux - Newbie 1 09-10-2003 06:54 AM


All times are GMT -5. The time now is 10:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration