LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2004, 03:33 PM   #1
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 343

Rep: Reputation: 31
vim 6.2 & set nocp


I just updated to vim 6.2

I faced the problem with "set nocp"
i created the file
/root/.vimrc
with "set nocp" inside
Now i can move inside files with cursors but i cant use "delete" and "backspace"

my questions:
1) what can i do so i can use backspace & delete?
2) how can i make all these changes permanent for all users?

thx
 
Old 03-28-2004, 04:41 PM   #2
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
1) I'm not certain....perhaps using map or map! will do it...or it may be a TERM-specific thing.
2) global settings are in /etc/vimrc
 
Old 04-06-2004, 05:21 PM   #3
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 343

Original Poster
Rep: Reputation: 31
So i return
Still i haven't found a solution to the problem

I am using Debian 3.0r2 , vim 6.2
Backspace and delete half function! what i mean:
they can delete only what i have typed and not the text that already exists in the file!!
"set nocp" doesn't fix the problem
Any ideas?
If there are no ideas where can i find an old version of vim?
 
Old 04-06-2004, 05:52 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
If backspace is bugging you, add the lines:
set backspace=2
set nocompatible
to the .vimrc file
 
Old 04-07-2004, 12:58 AM   #5
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 343

Original Poster
Rep: Reputation: 31
i disabled this line:
"set backspace=indent,eol,start " more powerful backspacing
and i add this:
set backspace=2

set nocompatible already exist
restart vim
same problem

Is any way to get sure that the configuration file that vim uses is "/etc/vim/vimrc" and not an other file?

Last edited by JJX; 04-07-2004 at 12:59 AM.
 
Old 04-07-2004, 06:53 AM   #6
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by JJX
i disabled this line:
"set backspace=indent,eol,start " more powerful backspacing
and i add this:
set backspace=2

set nocompatible already exist
restart vim
same problem

Is any way to get sure that the configuration file that vim uses is "/etc/vim/vimrc" and not an other file?
Put it in the .vimrc (the local one in your home directory - it starts with a dot and so is hidden).
I know this works, it's how I got mine to behave properly.
 
Old 04-08-2004, 07:34 AM   #7
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 343

Original Poster
Rep: Reputation: 31
"set backspace=2" in ~/.vimrc worked
thx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible problem with VISUAL=vi (vim & bash) redthor Linux - Newbie 2 04-26-2005 07:19 AM
vim & aspell configuration edM Slackware 4 03-29-2005 01:50 PM
VI & VIM are borked! d33pdream Linux - Software 4 11-15-2004 03:57 AM
XFCE 4.0.1 & vim fr0zen Linux - Software 2 12-11-2003 03:23 PM
VI & VIM dont behave phoeniXflame Linux - Software 2 07-02-2003 12:40 PM


All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration