LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2008, 11:35 PM   #1
bogdannedelcov
LQ Newbie
 
Registered: Feb 2008
Location: US
Posts: 4

Rep: Reputation: 0
Video Driver problem


Hi all, I hope u guys can help. I have installed FC7 on a laptop hard drive via USB (if you are asking why it is because the laptop does not support boot from usb and my dvd drive is broken). I used my desktop to install it, it boots on my laptop but X window will not start...after playing with xorg.conf I managed to get it into the point where it says no driver found. Can anyone tell me what I can do next. The video card is GMA900 from intel.
thx.
 
Old 02-17-2008, 01:52 AM   #2
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
IIRC you should use the i810 driver for that chipset. You could try just using vesa if that doesn't work.
 
Old 02-17-2008, 11:46 AM   #3
bogdannedelcov
LQ Newbie
 
Registered: Feb 2008
Location: US
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by General Failure View Post
IIRC you should use the i810 driver for that chipset. You could try just using vesa if that doesn't work.
Thx...It works with vesa...the only problem is that my laptop display has a native resolution of 1366x768...is it possible to change the resolution for vesa to this...or does anyone know where I can find the drivers for my video card for FC7...
 
Old 02-17-2008, 12:32 PM   #4
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
You can try the "intel" driver as well.

You're not likely to get very good resolution with the vesa driver. It may help if you post your xorg.conf.
 
Old 02-17-2008, 04:59 PM   #5
bogdannedelcov
LQ Newbie
 
Registered: Feb 2008
Location: US
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by masonm View Post
You can try the "intel" driver as well.

You're not likely to get very good resolution with the vesa driver. It may help if you post your xorg.conf.
Thanks "intel" works...there are two more issues I have encountered first when I start x windows the resolution is smaller than the one supported and I need to change it and restart x windows. the second issue (being a new to this) I have a problem with starting x windows automatically. Usually for a desktop this starts automatically but in my case I have to log in in console mode sand then startx.

here is my xorg.conf

"
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Intel Corporation Intel Default Card"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Intel Corporation Intel Default Card"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
"

thanks for all your help guys.
 
Old 02-17-2008, 05:24 PM   #6
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
Glad the intel driver worked for you.

Setting the default runlevel is normally handled in /etc/inittab. Edit the file for the runlevel you want, in this case the one for X11. That would be runlevel 4 in Slack, not sure what it is in FC, but in the file there should be some comments to describe them.
 
Old 02-17-2008, 06:26 PM   #7
bogdannedelcov
LQ Newbie
 
Registered: Feb 2008
Location: US
Posts: 4

Original Poster
Rep: Reputation: 0
Talking

Quote:
Originally Posted by masonm View Post
Glad the intel driver worked for you.

Setting the default runlevel is normally handled in /etc/inittab. Edit the file for the runlevel you want, in this case the one for X11. That would be runlevel 4 in Slack, not sure what it is in FC, but in the file there should be some comments to describe them.
thanks a lot that was the thing that solved it... in FC7 it is runlevel5 but as you said there were comments to guide me....
 
Old 02-17-2008, 06:38 PM   #8
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
You're welcome. Glad I could help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
video driver problem alan_daniel Linux - Laptop and Netbook 1 08-29-2005 11:15 AM
Video Driver Problem? Scyth Fedora 7 03-07-2005 01:31 AM
Video Driver Poblems with Red Hat 8.0 (trident video driver) AstroJim Linux - Newbie 1 05-20-2004 03:25 PM
problem with video driver a33patel Linux - Hardware 1 03-18-2004 02:08 AM
I think it's a video driver problem... bkeating Linux - Software 3 09-04-2003 02:30 PM


All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration