LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-07-2008, 04:16 PM   #1
Schulzy190
LQ Newbie
 
Registered: Jun 2006
Posts: 8

Rep: Reputation: 0
video card on mobo not working correctly


i have recently bought a computer and i have installed fedora 9 on it...video worked fine for the install but now when i boot up i have video until fedora is running then i have resolution problems. i have managed to get video on my gaming monitor but they are horrible. i have a asus p5n-mx mobo. please give me some ideas i have no idea what to do to fix this thanks in advance
 
Old 06-07-2008, 04:59 PM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Looks like a nice board.
Fedora may have configured itself to use the generic vesa driver for graphics. It appears you have integrated Nvidia graphics.
Try booting into single user mode, (not sure how with your current distribution's version) and edit the /etc/X11/xorg.conf file to use the generic Nvidia driver (nv). An example of the section to edit follows:
Code:
Section "Device"
    Identifier  "Generic video"
    Driver      "nv"
EndSection
For full features including 3D capabilities you should look at installing the proprietary Nvidia drivers/modules. Although I have not tried Fedora 8 or 9, with Fedora 7 it is recommended to setup the livna repository and install it with yum.
This mjm individual usually gives the best advice for setting up Fedora.
 
Old 06-07-2008, 05:19 PM   #3
Schulzy190
LQ Newbie
 
Registered: Jun 2006
Posts: 8

Original Poster
Rep: Reputation: 0
i checked the file and it says the following
Code:
Section "Device"
     Identifier "Videocard0"
     Driver     "vesa"
End Section
should i change it to what has previously been posted?

thanks
 
Old 06-07-2008, 05:40 PM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by Schulzy190 View Post
i checked the file and it says the following
Code:
Section "Device"
     Identifier "Videocard0"
     Driver     "vesa"
End Section
should i change it to what has previously been posted?

thanks
If you want to get the best performance you should use nvidia instead of vesa or nv, as said above. I don't know how to install the propietary nvidia driver in fedora, but the previous poster gave you some hinst above.

Once you install the nvidia (not "nv", but "nvidia") driver correctly, you should addapt your xorg.conf like this:

Code:
Section "Device"
     Identifier "Videocard0"
     Driver     "nvidia"
     Option "HWcursor" "true"
     Option "RenderAccel" "true"
     Option "AllowGLXWithComposite" "true"
End Section
There are more options but with those you should be able to use any modern desktop without problems. Again, those extra options are just for the nvidia driver. They don't work with vesa or nv.
 
Old 06-07-2008, 05:50 PM   #5
Schulzy190
LQ Newbie
 
Registered: Jun 2006
Posts: 8

Original Poster
Rep: Reputation: 0
i am having touble installing the driver...i am new to linux so bare with me here
 
Old 06-08-2008, 03:50 PM   #6
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Try changing out "vesa" for "nv". This will get you some graphics and start enjoying your new Linux installation. You can then tinker with the proprietary driver later at your own pace to get better graphics, at least you'll be able to use firefox to refer to web pages like the one I provided a link for to help you.
You need to edit the file as root.
When you boot up in single user mode or in a command line only environment, make sure you are root and issue this command to open the file in a editor: vim /etc/X11/xorg.conf, using the arrow keys scroll down to that section, using backspace to erase vesa, then insert nv in it's place. Then hit all together these three keys: Ctrl, Alt, semicolon, you should now have a semicolon appear at the bottom left of the screen, type: wq! to write the file, quit now.
Now try a reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys wpc54G card not working correctly jeffnvabeach Linux - Wireless Networking 6 02-01-2008 12:27 PM
Monitor / Video Card not detected correctly in Ubuntu 7.04 PlaneCharlie Linux - Hardware 1 08-29-2007 02:13 PM
sound not working in SUSE 10.2 although sound card correctly configured mhardwick Linux - Software 4 03-05-2007 03:13 PM
Video Card won't work correctly galliar SUSE / openSUSE 2 09-28-2006 06:53 PM
3D Video Card it's working? Gerardoj Linux - Hardware 6 11-30-2004 11:17 AM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration