LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2004, 03:50 AM   #1
antjessopuk
LQ Newbie
 
Registered: Oct 2003
Location: Derbyshire, UK
Distribution: Mandrake 10.0 CE
Posts: 14

Rep: Reputation: 0
Angry via combo driver


Hi guys,

I have recently installed Mandrake 10.0 CE. Everything seems to be working fine except for the flippin' sound. To rectify the issue I downloaded the viaudiocombo driver from 'via arena'. I followed the instructions but recieved the following...

root@localhost Documents]# rpm --rebuild viaudiocombo-2.3-1.src.rpm
Installing viaudiocombo-2.3-1.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.42030
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd /usr/src/RPM/BUILD
+ rm -rf viaudiocombo-2.3
+ /usr/bin/gzip -dc /usr/src/RPM/SOURCES/viaudiocombo-2.3.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd viaudiocombo-2.3
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.42030
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.3
+ ./install.sh
Could not find Linux directory, please link it with /usr/src/linux
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.60929
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.3
+ rm -rf /usr/src/RPM/BUILD/viaudiocombo-root
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.6.3-4mdk/kernel/drivers/sound
+ install viasound /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d/viasound
++ uname -r
+ install -m 644 viaudiocombo.o /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.6.3-4mdk/kernel/drivers/sound/viaudiocombo.o
install: cannot stat `viaudiocombo.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.60929 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.60929 (%install)
[root@localhost Documents]#

I am using a ECS K7VMM2 motherboard with onboard sound.
I have installed all of the developement section from the CDs.

Any ideas folks? The rest of the system is running wonderfully, i'm only using WinXP for playing music now!!!

Cheers

Ant
 
Old 05-20-2004, 04:31 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Quote:

Could not find Linux directory, please link it with /usr/src/linux

you need to install kernel source
 
Old 05-20-2004, 04:47 AM   #3
antjessopuk
LQ Newbie
 
Registered: Oct 2003
Location: Derbyshire, UK
Distribution: Mandrake 10.0 CE
Posts: 14

Original Poster
Rep: Reputation: 0
How do I do that, is there a Mandrake RPM?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Driver for UC-Logic keyboard and tablet combo eclair Mandriva 0 11-01-2004 06:27 AM
Combo Question bkerensa Linux - Security 1 06-04-2004 02:01 PM
VIA Combo Driver antjessopuk Linux - Hardware 0 05-19-2004 05:47 PM
combo drive h1tman Linux - Hardware 11 10-01-2003 07:36 PM
Tulip driver and Linksys Combo Card Catt Linux - Software 1 05-22-2001 12:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration