LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2003, 01:29 AM   #1
digitized_funk
Member
 
Registered: Sep 2002
Location: Australia
Distribution: Suse 8.0
Posts: 50

Rep: Reputation: 15
vfat partition - write permission for users group


hello I am trying to automount my shared partition, I cannot get write permission set for the users group. I can however write to the disk from su.

I read somewhere to assign gid=100 would fix it at mount time, but it still doesn't seem to work. Can someone check my /etc/fstab entry please, I am such a newb:

/dev/hda2 /mnt/D vfat gid=100,user,auto 0

thanks for your help

Rich.
 
Old 03-17-2003, 01:37 AM   #2
mayankjohri
Member
 
Registered: Mar 2002
Location: INDIA
Distribution: Mandrake Linux 9.2, Knoppix 3.0
Posts: 158

Rep: Reputation: 30
search this forum i have already given the answer....
 
Old 03-17-2003, 02:00 AM   #3
mayankjohri
Member
 
Registered: Mar 2002
Location: INDIA
Distribution: Mandrake Linux 9.2, Knoppix 3.0
Posts: 158

Rep: Reputation: 30
try this also

http://www.linuxquestions.org/questi...ite+permission
 
Old 03-17-2003, 02:49 AM   #4
digitized_funk
Member
 
Registered: Sep 2002
Location: Australia
Distribution: Suse 8.0
Posts: 50

Original Poster
Rep: Reputation: 15
great thanks, so basically I just have to set UMASK=000 instead of using gid. I will try it when I boot to linux again, I am now having trouble with my modem connection, linux is really hard to get running.

thanks again.
 
Old 03-17-2003, 03:22 AM   #5
mayankjohri
Member
 
Registered: Mar 2002
Location: INDIA
Distribution: Mandrake Linux 9.2, Knoppix 3.0
Posts: 158

Rep: Reputation: 30
YES/NO.
YES: - Its really hard to drive a car the first time. but tricycle its easy
NO :- to drive a car for long is easy. but tricycle its hard.
and for the modem. use kppp and just change the modem device and query it. if it fails then try with another modem device setting of Kppp. short cut.
if your modem is connected to first serial port them the device is /dev/ttyS0
and so on..
 
Old 03-17-2003, 03:56 AM   #6
digitized_funk
Member
 
Registered: Sep 2002
Location: Australia
Distribution: Suse 8.0
Posts: 50

Original Poster
Rep: Reputation: 15
thanks, the modem is configured okay, the problem is that it won't stay connected, it drops the line between 2 - 30 minutes usually closer to 2. I have a post up in the hardware forum. I wasn't sure to look at wvdial.conf, something to do with pppd or my hsf conexant driver.

I'd just used wvdialconf to setup my wvdial.conf, have not done anything past the defaults for pppd and used hsfconfig tool to auto configure the modem. I'm pretty hopeless and rely on these auto tools quite heavily

thanks for help.
 
Old 03-19-2003, 08:13 AM   #7
digitized_funk
Member
 
Registered: Sep 2002
Location: Australia
Distribution: Suse 8.0
Posts: 50

Original Poster
Rep: Reputation: 15
well I finally have got round to trying to update my fstab and remounting my drive. It is still not working even with the UMASK option my user account still doesn't write to disk, can someone please just tell me what is wrong with the following line:

/dev/hda2 /mnt/D vfat auto,UMASK=000 0 0

thanks very much.
 
Old 03-19-2003, 08:24 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
not sure if umask is case sensitive, may well be,make it lower. when it is mounted check that the permissions are on an "ls"
 
Old 03-19-2003, 08:30 AM   #9
digitized_funk
Member
 
Registered: Sep 2002
Location: Australia
Distribution: Suse 8.0
Posts: 50

Original Poster
Rep: Reputation: 15
great thanks a lot! it worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vfat sambar write permission problem melinda_sayang Linux - Networking 1 10-22-2005 01:48 PM
Can't get write permission to vfat Chomper Linux - General 9 01-13-2005 12:38 AM
permission for vfat partition kringla Linux - General 3 08-22-2004 06:43 PM
Can't write to vfat partition as user sigma957 Slackware 6 07-29-2004 09:58 AM
giving users and group permission on proftp kafnir Linux - Networking 1 06-07-2004 09:38 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration