LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2003, 09:57 AM   #1
weiss
LQ Newbie
 
Registered: Jul 2003
Location: St.Petersburg
Distribution: Mandrake 10.1
Posts: 18

Rep: Reputation: 0
Question vfat ownership


I have a vfat partition and it is mounted at boot time, it is set to supermount (Mandrake 9.1). I log on under my account (not root!), however, the owner of all files on the vfat partition is still root and it is impossible to change the ownership with 'su' and 'chown' - it says permission denied.

My goal is to have the vfat partition mounted at boot time and have myself (not root) be the owner of all files there. Is it possible? If so, what should I do to achieve it. Thanks!
 
Old 09-24-2003, 10:00 AM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
you'll have to add an extra option in the /etc/fstab file for the entry to mount the fat drive...
both options below will work, you only need to use one of them, but remember the UID option is only going to specify one user, and the umask is for all if you have multiple users....
umask=000
and.
UID=XXX where XXX is the user ID of the user that wants access (in this case you )
 
Old 09-24-2003, 10:16 AM   #3
weiss
LQ Newbie
 
Registered: Jul 2003
Location: St.Petersburg
Distribution: Mandrake 10.1
Posts: 18

Original Poster
Rep: Reputation: 0
Hmm, as long as I remember "umask 0 0 0" is already there (i can't check it now unfortunately since it is on my PC at home). But I will check it this evening!
 
Old 09-24-2003, 10:30 AM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well maybe if you tried to do it before and you actually typed 'umask 0 0 0' then thats probably why its not working....it is umask=000, all as one string..
but like you said, just check it out when you get home..
 
Old 09-24-2003, 10:59 AM   #5
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
It's umask=0 (there doesn't have to be 3 zeroes). The umask=0 0 0 you saw is umask=0 with two other zeroes that have nothing to do with it. The umask=0 will set all permissions on the drive to rwxrwxrwx.
 
Old 09-24-2003, 01:23 PM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
vfat doesn't support ownerships, therefore whoever mounted the partition owns everything.
You'll have to add "users,noauto" option to the fstab, then mount it yourself with some kind of script after you login.
 
Old 09-24-2003, 03:25 PM   #7
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
negative...if he automounts at bootup it with the proper options anyone can access it
 
Old 09-24-2003, 03:29 PM   #8
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Anyone can access it, but it's still owned by root.
 
Old 09-25-2003, 03:30 AM   #9
weiss
LQ Newbie
 
Registered: Jul 2003
Location: St.Petersburg
Distribution: Mandrake 10.1
Posts: 18

Original Poster
Rep: Reputation: 0
Well, I have checked it yesterday. By default it was

/dev/hda5 /data vfat iocharset=utf8,umask=0 0 0

i made it first like

/dev/hda5 /data vfat iocharset=utf8,defaults,umask=000 0 0

and it did not work, any ideas why ?

then I made it like

/dev/hda5 /data vfat iocharset=utf8,umask=000,defaults,uid=501 0 0

and only then it worked

Again, the problem was not in accessing vfat, the problem was with the ownership of the files like aaa said.

But why can it not be done in such a way that the files on vfat are owned by the user who logs on ?

Anyways, thank you everybody for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ownership Shifty02 Mandriva 2 05-21-2005 04:38 PM
Changing ownership of vfat mount maamold Linux - Software 2 02-25-2005 03:27 AM
ownership true_atlantis Linux - Newbie 1 10-28-2003 11:19 AM
copy files from vfat to vfat from linux? purpleburple Linux - General 2 12-11-2002 04:24 PM
ownership modding bkeating Linux - Newbie 2 07-04-2002 04:19 AM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration