LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2006, 08:01 AM   #1
branston
LQ Newbie
 
Registered: Jun 2006
Posts: 3

Rep: Reputation: 0
Very Very Slow


As newbie as you can get. First install of Linux because I am sick of ms windows.

I have installed Suse 9.3 on a PC with Celeron D315 1gb of ram and a 300gb hard drive but it is unbelievably slow. Opening the novell/suse home page with Firefox (or any other page) takes 1 minute. Back page and forward is quick. Other points worth mentioning

Konqueror and epiphany are similarly bad

Suse 10.1 and RedHat 5 are also bad

Starting Gnome Terminal took 5 seconds which seems very slow for the type of application it is

I ran top and cpu usage ranges from 2% doing nothing to 6% when starting Firefox (falls quickly back to 2%)

I have an identical box running windows 2000 and browser page display takes around 1 second so I know my internet connection is fine.

I did run bonnie but have no idea if the answers were good or bad. One thing that looked odd was a message that saying 'you may have 988 mb ram but test with only 100mb data'

Given my scant knowledge I am looking for a route or things to try to help me find the problem. Don't assume any knowledge on my part. I have none as yet.

TIA
 
Old 06-01-2006, 09:56 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Opening web pages should have nothing to do with the system speed or available resources, or very little at least. Make sure you are not using a proxy that could slow the speed down. You can test the speed of your connection (just to make sure it's not that) by running ping in the terminal:

Code:
ping google.com
and after a moment press ctrl-c to terminate it. you get the ping times (milliseconds if I remember correctly) from which you'll see if it's your internet connection or the browser application that's slowing down. And what's the frequency of your cpu, "D315" doesn't tell me much. If you're unsure, you can run

Code:
cat /proc/cpuinfo
but bear in mind that if your kernel is able to change the clock rate of your cpu at runtime, the Mhz you get is much smaller than the top speed of the processor (it's slowed down when you don't use the cpu so it consumes less power, and raised when you need it).

One more thing to understand is that KDE and Gnome, the desktop environments people usually use, are big and heavy, and even a powerful computer may seem slow using them, depending on how much eye-candy and nice effects you use. For speed you better use some lighter things..
 
Old 06-01-2006, 02:49 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
One thing that can slow down web pages is the DNS search order. Check your /etc/resolv.conf file.
 
Old 06-01-2006, 06:50 PM   #4
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Quote:
"D315" doesn't tell me much
No but after recently being CPU shopping, I can narrow it down to one of the new Celerons Should be enough to push a desktop along without too much trouble anyway.
 
Old 06-02-2006, 05:28 AM   #5
branston
LQ Newbie
 
Registered: Jun 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks guys, a bit more info below

Yes the processor is one of the new celerons 2.26 ghz

Ping is 20-30 milliseconds

The resolv.conf file simply says my vigor (adsl router) is the nameserver but name resolution is near instant if I ping a www site I have not accessed before.

No proxy being used

I am using Gnome but the whole installation (other than choosing Gnome instead of KDE) is set to the default suggested by the suse installer

The odd thing is when I opened the resolv.conf file which is a tiny text file, it takes 10 seconds to open. Which can't be right.
 
Old 06-02-2006, 05:37 AM   #6
dubz_444
Member
 
Registered: Mar 2006
Location: South Africa
Distribution: Arch Linux
Posts: 43

Rep: Reputation: 15
what filesystem are you using?


p.s. KDE and GNOME are RAM whores
 
Old 06-02-2006, 06:02 AM   #7
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
> The odd thing is when I opened the resolv.conf file which is a tiny text file, it takes 10 seconds to open. Which can't be right.

I suspect the HDD controller is not recognized correctly. I'd build my own kernel if I had such a problem.
 
Old 06-02-2006, 06:26 PM   #8
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
Definately sounds like it may be a read/write problem.

BTW, if you use ping -c 3 www.google.com you won't have to hit ctl+c to stop it.
 
Old 06-06-2006, 02:59 PM   #9
branston
LQ Newbie
 
Registered: Jun 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for your posts, I thought it might be something to do with the hard drive so as I had bought 2 I tried the second drive. I also looked at a few sites and found one instance where the drive had a problem with its a mode of operation (I didn't understand) but that was in Windows anyway. I have also tried the drives on a windows box and they are fine. The final thing I tried was putting suse 10 onto a PIII box with 512 mb ram and a 40gb hard drive. It was slow but interestingly suse version 8 was twice as quick (But still too slow). I am thoroughly confused and because I have a pressing project will have to resort to windows for a while longer.

I am convinced it is a drive problem so will keep this box on linux to return to after I have sorted my project. Kernal building is definately beyond me but I will read up on filesystem options.

Thanks for your suggestions. I shall return.
 
Old 06-07-2006, 06:39 AM   #10
mekump
LQ Newbie
 
Registered: Feb 2006
Distribution: CentOS-4
Posts: 19

Rep: Reputation: 0
Hello,

If you suspect drive performance, you should be able to check it with the hdparm command (# hdparm -t /dev/???). Check the manpage for info on how to run.

Mike
 
Old 06-07-2006, 07:22 AM   #11
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
20ms ping is fine, your network is most likely okay. the speed problems of opening a terminal, etc. would have nothing to do with your network.

i also suspect it's an IDE problem, your HD is probably not optimized in the right mode. # hdparm -Tt /dev/hda will run the benchmark (for your master hard drive, i.e., /dev/hda, change to /dev/hdb for slave, etc.), or you can just look at the output of # hdparm /dev/hda to see if DMA is on and what the other settings are (if it's on, it will say 1, and 0 for off).

if it's off, an # hdparm -d1 -c3 -m16 /dev/hda is usually safe for most hard drives, but you can just use the -d1 option if you want (read man hdparm). it seems kind of strange that suse wouldn't enable that by default, but maybe they just wanted things to be safe for all hard drives? or you may need to rebuild your kernel to enable DMA (or switch distros ).

if that is indeed the problem, you'll have to put the command in a startup script somewhere to have it enabled automatically at boot. otherwise it will get reset everytime to its default mode, which apparently is off.

Last edited by slackhack; 06-07-2006 at 07:23 AM.
 
Old 06-07-2006, 07:52 AM   #12
worzel68
Member
 
Registered: May 2006
Location: Sydney
Distribution: FC5, FC3, AIX, System V,
Posts: 50

Rep: Reputation: 15
I had the same problem and it could be solved by macemoneta's suggestion of running cron/prelink. Check out his post. For me, I left my machine for a day & it was much faster when I turned it on. cron has programs & scripts that run automatically at various intervals, perhaps this is what happened on my machine.
 
Old 06-07-2006, 08:20 AM   #13
dickgregory
Member
 
Registered: Oct 2002
Location: Houston
Distribution: Arch, PCLinuxOS, Mint
Posts: 257

Rep: Reputation: 34
Stick to what you are already familiar with to do a pressing project, even if it is Windows. Linux will take some time to get familiar with, and it will be a lot more fun if you can learn it without deadlines. I suspect a lot of Linux-haters got that way because of this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow performance!!! System using a lot of Physical Memory SLOW HELP! badgerbox76 Linux - Newbie 31 07-19-2007 10:23 AM
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 12:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 01:55 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 07:19 PM


All times are GMT -5. The time now is 11:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration