LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2012, 10:34 PM   #1
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Rep: Reputation: 2
Question vBox


The software manager says that vBox is installed. I checked the entire list of available applications and it is not there. It also isn't where the Ubuntu wiki on vBox said it would be. Z/Z
 
Old 01-27-2012, 01:37 AM   #2
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Did you tried?
Code:
$dpkg -l | grep -i vbox
and
Code:
$whereis vBox
Regards
 
Old 01-27-2012, 01:38 AM   #3
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Can you run it from the commandline?
Code:
$ which virtualbox
Show it is installed? If not, does
Code:
# updatedb && locate *virtualbox*
Show a bunch of files related to virtualbox?

Virtualbox needs a kernel module to be built, which in some distro's has to be done independently of the installation.
Code:
$ lsmod | grep vbox
Should show 3 modules as being loaded..
 
Old 01-27-2012, 02:36 AM   #4
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Question

@ukiuki: The command <$dpkg -l | grep -i vbox> gives the response of <-l: command not found> removing the dollar sign at the front of the command gives no response

@fukawi1: The command <$ which virtualbox> gives the response of <$: command not found> removing the dollar sign at the front of the command gives no response

The command <# updatedb && locate *virtualbox*> does not provoke a response on the command line

The command <lsmod | grep vbox> does nothing and putting the dollar sign at the front gives the same <$: command not found> message.

I am trying to set up a vbox in an Ubuntu-based variant that is so sugared up I no longer have teeth... not authorize a nuclear strike. No idea why I am going to the command line to run an application that the system says is already installed. This is a very common task attempted by just about anybody that uses Linux to access windows without having to reboot their computer. I also do not know instictively if commands need to be elevated to sudo or root. Z/Z
 
Old 01-27-2012, 02:45 AM   #5
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Ok, it is common to use $ and # symbols to indicate running a command as a user, and as root (sudo) respectively. As these are usually the terminating symbols of the prompt you see at the command line.
So in short, if it says "$ somecommand" you run can run it as a user. If it says "# somecommand" you would need to run it as root, or sudo, but you dont include the $ or # in the command itself.

It looks as though virtualbox isn't installed.

Unfortunately, i dont know anything about the GUI based package manager, so I can only help with the command line. If you would rather wait for assistance with the GUI, ignore me :P

Code:
# apt-get install virtualbox-ose
Should install it.

Can you post a link to the guide you have been following?
 
1 members found this post helpful.
Old 01-27-2012, 03:10 AM   #6
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Thumbs up I need your help!!! :)

I wasn't trying to snub anybody. Some guy posted one of those "Let me google that for you" responses to a question I obviously could not find with the aid of the cult of Google... so I was a little on edge, people really should look into the origin of the word sabotage more often ( Star Trek VI: The Undiscovered Country... just because its sci-fi doesn't mean it can't be educational )

The guide I was following is at https://help.ubuntu.com/community/VirtualBox/FirstVM .

I'll try apt-get and see how it goes. I'll post the results in a few minutes. Z/Z
 
Old 01-27-2012, 03:12 AM   #7
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Reading package lists... Done
Building dependency tree
Reading state information... Done
virtualbox-ose is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded. Z/Z
 
Old 01-27-2012, 03:43 AM   #8
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Ok, so its installed.
I don't know ubuntu well, especially the new unity interface. Does it have the ability to search the menu's? Try searching for "virtual" it is possible it has put the menu short cut somewhere other than the default.

https://help.ubuntu.com/community/VirtualBox
The above link suggests the menu entry could be under Applications > System Tools > VirtualBox. Although this conflicts with the documentation in the guide you provided, it could differ between ubuntu releases.
 
1 members found this post helpful.
Old 01-27-2012, 03:54 AM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Try to open main menu or alacarte to add to menu
 
1 members found this post helpful.
Old 01-27-2012, 04:25 AM   #10
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
The executable name is VirtualBox

For Linux, command/filename/directories are case-sensitive, and Oracle decided to use capitals...

The package does not add a menu item to the GNOME/KDE menu that I've ever seen. Anyway, open a terminal and type "VirtualBox" (without the quotes) when the command line window appears. You should get the typical VirtualBox application window.
 
1 members found this post helpful.
Old 01-27-2012, 04:30 AM   #11
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Quote:
Originally Posted by Dark_Helmet View Post
The executable name is VirtualBox

For Linux, command/filename/directories are case-sensitive, and Oracle decided to use capitals...
Code:
~/tmp $ which virtualbox
/usr/bin/virtualbox
Not the case with my Debian Squeeze install. But a valid point none the less.
 
1 members found this post helpful.
Old 01-27-2012, 04:33 AM   #12
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Interesting. On my Ubuntu server 10.04, the command is VirtualBox. I've typed it many, many times.

I should also say that I'm not 100% sure that I got the package from the repos or directly from Oracle. So that could also explain the naming discrepancy and lack of a menu entry.

EDIT:
Just checked my sources.list. My machine pulls from:
Code:
deb http://download.virtualbox.org/virtualbox/debian lucid contrib non-free
I think that package source was given as part of Oracle's instructions on their website. It's been a long time since I messed with setting it up.

Hopefully, this doesn't cause confusion.

Last edited by Dark_Helmet; 01-27-2012 at 04:37 AM.
 
1 members found this post helpful.
Old 01-27-2012, 04:39 AM   #13
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
The package does not add a menu item to the GNOME/KDE menu that I've ever seen. Anyway, open a terminal and type "VirtualBox" (without the quotes) when the command line window appears. You should get the typical VirtualBox application window.
In debian with gnome2 there was an icon & was listed in menu under "Other"
Another place to check is the filemanager under /usr/share/applications double-click on icon it'll open.
 
1 members found this post helpful.
Old 01-27-2012, 04:49 AM   #14
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Yeah, there should be a menu item for the OSE version. Now that I'm thinking about it again, I installed the OSE version in the past, but later replaced it with the non-OSE version.

Anyways, I'll zip my lip and be quiet! Carry on
 
1 members found this post helpful.
Old 01-27-2012, 05:57 AM   #15
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
So is typing "virtualbox" or "VirtualBox" into the command line going to work? I have already checked every item listed in the gnome interface and they are listed alphabetically so I am fairly certain it is not listed... lots of healing potions, tents and masamunes but no virtualbox. Z/Z
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] vbox 4.0.2 - guest sabayon5.4 on win7 - mnt local gentoo from vbox sabayon? shinystuffrox Linux - Virtualization and Cloud 1 03-04-2011 02:10 AM
Runing VBox TheSappy Slackware 8 09-13-2010 12:38 AM
VBox in Slackware 13.1 gregkedro Linux - Virtualization and Cloud 5 08-05-2010 09:26 AM
[SOLVED] VBox-NS_ERROR_FAILURE th1bill Linux - Software 3 07-25-2010 06:47 AM
Upgrading VBox 2.0.2 on Fedora 9 to VBox 2.0.6 fcquayso Linux - Newbie 2 12-10-2008 05:44 PM


All times are GMT -5. The time now is 10:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration