LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1) (http://www.linuxquestions.org/questions/linux-newbie-8/usr-lib-libstdc-so-6-version-%60glibcxx_3-4-9-not-found-required-by-example1-604625/)

babu198649 12-05-2007 04:14 AM

/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1)
 
hi
i have installed a new set of c++ library files and when i compiled its fine but when i started to link it i get following messages

Code:

./example1: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1)

i have given command ls -l and found the result as

Code:

lrwxrwxrwx    1 root  root          18 Jul  2 11:29 libstdc++.so.6 -> libstdc++.so.6.0.3
-rwxr-xr-x    1 root  root      804288 Jul 25  2005 libstdc++.so.6.0.3

so there is a link b/w libstdc++.so.6 -> libstdc++.so.6.0.3 but no link from libstdc++.so.6.0.3

so do i have to create a link ,if so how to that. i have searched google but not found any solutions that suits my problem.

thank u

ph73nt 12-05-2007 09:12 AM

The output looks suspiciously like it's not happy with the installed GLIBC. What version of GLIBC are you running?

babu198649 12-06-2007 04:44 AM

what is the command find the version

i tried GLIBC -v but it had not worked

ph73nt 12-06-2007 10:55 AM

Assuming you are using RPM. I would issue rpm -q glibc if that returns nothing try rpm -qa |grep glibc

babu198649 12-07-2007 12:06 AM

thank u for following my post.

both the commands worked

user@localhost:~$ rpm -q glibc
glibc-2.6-3
glibc-2.6-3



user@localhost:~$ rpm -qa |grep glibc
glibc-common-2.6-3
glibc-devel-2.6-3
glibc-2.6-3
glibc-headers-2.6-3
glibc-2.6-3
glibc-devel-2.6-3

ph73nt 12-10-2007 08:24 AM

So it looks like your libstdc++ is expecting an older version of GLIBC. Most people experience the problem of having something too old, not too new ;)

Did you install the c++ libraries manually or via your distribution's GUI installer? what about rpm -qa |grep libstdc++. Does this give you a version?

If I am right and your libstdc++ is newer than your GLIBC and you definately need a newer version of the libstdc++ I'm not sure what to suggest. In my experience GLIBC isn't something you can easily update or upgrade as a lot of your RPMs will be built aginst this GLIBC. New GLIBC usually means new version of your distro. You could try googling it, of course.

If you are a newbie interested in how a linux distibution is assembled then it's worth looking at www.linuxfromscratch.org They detail how to build you own linux distribution. It's worth having a go at to learn how linux works but you wouldn't get a very useful installation without an awful lot of work.

babu198649 12-12-2007 04:33 AM

hi ph73nt:)

Quote:

what about rpm -qa |grep libstdc++. Does this give you a version?

yes

[bharani@localhost ~]$ rpm -qa |grep glibc
glibc-utils-2.3.4-2.13
glibc-kernheaders-2.4-9.1.98.EL
glibc-2.3.4-2.13
glibc-devel-2.3.4-2.13
compat-glibc-headers-2.3.2-95.30
glibc-common-2.3.4-2.13
glibc-headers-2.3.4-2.13
compat-glibc-2.3.2-95.30
glibc-profile-2.3.4-2.13



Quote:

Did you install the c++ libraries manually or via your distribution's GUI installer?

> cd /
> tar xjf sourceryvsipl++-1.3-serial-builtin-x86_64-sse2.tar.bz2



i placed the tar file in root directory and perfomed the above command


one thing i did not mentioned is that i have updated the gcc compiler(4.2.2)

ph73nt 12-12-2007 10:30 AM

I seem to have mis-read part of your replies. Your system expects GLIBC-3.4.9 and you have GLIBC-2.6.3 which is is older than the sytem expects not what I said, which was that it was older. Anyway the outcome is similar; GLIBC is difficult to update. There's probably another thread about that somewhere.

As for the libraries I've only manually installed libraries when following linuxfromscratch (but I normally just use RPM). Have you done ldconfig from the command line? Check out LFS to see what it says about libraries. Otherwise that's the end of my knowledge on this subject.

babu198649 12-13-2007 08:24 AM

hi ph73nt;)
thanks for u r time

just have a last try.

i have googled and found a similar thread but i cant understand (may be u can)since its about debian.
here is the link
http://www.nabble.com/Debian-Etch-Pa...o13389761.html
please have a single try.

ph73nt 12-13-2007 09:24 AM

What distibution are you using?

babu198649 12-18-2007 03:02 AM

[bharani@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.9-22.ELsmp #1 SMP Mon Sep 19 18:32:14 EDT 2005 i686 i686 i386 GNU/Linux

ph73nt 12-21-2007 08:22 AM

Perhaps I should have read the original post better. GLIBC is not the same as GLIBCXX. You need GLIBCXX version 3.4.9 or newer.

GLIBCXX is provided by libstdc++ so it looks as if we have identified the out of date package.

rpm.pbone.net is a good place to search for rpms. Search for libstdc++ for you distribution and click on it to inspect the package contents. It will tell you which versions of GLIBCXX are proveded. It's worth noting that there are sometimes newer versions of rpms on this site than on your distros package repositories. If you find the glibcxx you're looking for then download the rpm and install it.

debiprasad 06-04-2009 03:17 AM

DebiPrasad
 
I got same type of error during installation of VLC media player in SuSE 10.2 Desktop. I resolved it by following the below steps:

vlc-wrapper -v or vlc -v (showing the following error)
main libvlc warning: cannot load module '/usr/lib/vlc/gui/libskins2_plugin.so' (/usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.9' not found by /usr/lib/vlc/gui/libskins2_plugin.so)

Solution: I download the rpm llvm-gcc-c++-2.5-0.pm.2 from rpm.pbhone.net site and installed it and then:

I got the solution by adding entries in /etc/ld.so.conf
# vi /etc/ld.so.conf
add the following line:
/usr/lib/llvm-gcc/lib
# ldconfig

debiprasad 06-04-2009 08:57 AM

debiprasad
 
Have Fun
Quote:

Originally Posted by debiprasad (Post 3562598)
I got same type of error during installation of VLC media player in SuSE 10.2 Desktop. I resolved it by following the below steps:

Error:
vlc-wrapper -v or vlc -v (showing the following error when runnign from system user)
main libvlc warning: cannot load module '/usr/lib/vlc/gui/libskins2_plugin.so' (/usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.9' not found by /usr/lib/vlc/gui/libskins2_plugin.so)

Solution: I download the rpm llvm-gcc-c++-2.5-0.pm.2 from rpm.pbhone.net site and installed it and then:

Login as root

# vi /etc/ld.so.conf.d/vlc.conf (create a file)

add the following line in vlc.conf:
/usr/lib/llvm-gcc/lib

when I checked in /usr/lib I found something like this:
libstdc++.so.6 -> libstdc++.so.6.0.8 (It's a symbolic link)

then I did:
cp /usr/lib/llvm-gcc/lib/libstdc++.so.6.0.9 /usr/lib
rm -f /usr/lib/libstdc++.so.6
ln -s /usr/lib/libstdc++.so.6.0.9 /usr/lib/libstdc++.so.6

run the following command to update your modification:
# ldconfig

Hope this will help you...


hartings 06-23-2009 03:47 PM

Similar problem, but not the same....
 
Hi,

I run CentOS 5.3 (RHEL5.3) which has package libstdc++-4.1.2-44.el5.i386.rpm installed which provides:

libstdc++
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++.so.6(GLIBCXX_3.4.4)
libstdc++.so.6(GLIBCXX_3.4.5)
libstdc++.so.6(GLIBCXX_3.4.6)
libstdc++.so.6(GLIBCXX_3.4.7)
libstdc++.so.6(GLIBCXX_3.4.8)
libstdc++

but NOT libstdc++.so.6(GLIBCXX_3.4.9) which I need for an application I want to install.

The newer version of libstdc++, used by fedora10 is libstdc++-4.3.2-7.i386.rpm, which provides the same, plus libstdc++.so.6(GLIBCXX_3.4.9) which I need!!

Could I install this rpm without risks?

Appreciate your comments!


All times are GMT -5. The time now is 08:53 PM.