/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1)
i have installed a new set of c++ library files and when i compiled its fine but when i started to link it i get following messages
i have given command ls -l and found the result as
so do i have to create a link ,if so how to that. i have searched google but not found any solutions that suits my problem.
The output looks suspiciously like it's not happy with the installed GLIBC. What version of GLIBC are you running?
what is the command find the version
i tried GLIBC -v but it had not worked
Assuming you are using RPM. I would issue rpm -q glibc if that returns nothing try rpm -qa |grep glibc
thank u for following my post.
both the commands worked
user@localhost:~$ rpm -q glibc
user@localhost:~$ rpm -qa |grep glibc
So it looks like your libstdc++ is expecting an older version of GLIBC. Most people experience the problem of having something too old, not too new ;)
Did you install the c++ libraries manually or via your distribution's GUI installer? what about rpm -qa |grep libstdc++. Does this give you a version?
If I am right and your libstdc++ is newer than your GLIBC and you definately need a newer version of the libstdc++ I'm not sure what to suggest. In my experience GLIBC isn't something you can easily update or upgrade as a lot of your RPMs will be built aginst this GLIBC. New GLIBC usually means new version of your distro. You could try googling it, of course.
If you are a newbie interested in how a linux distibution is assembled then it's worth looking at www.linuxfromscratch.org They detail how to build you own linux distribution. It's worth having a go at to learn how linux works but you wouldn't get a very useful installation without an awful lot of work.
[bharani@localhost ~]$ rpm -qa |grep glibc
> cd /
> tar xjf sourceryvsipl++-1.3-serial-builtin-x86_64-sse2.tar.bz2
i placed the tar file in root directory and perfomed the above command
one thing i did not mentioned is that i have updated the gcc compiler(4.2.2)
I seem to have mis-read part of your replies. Your system expects GLIBC-3.4.9 and you have GLIBC-2.6.3 which is is older than the sytem expects not what I said, which was that it was older. Anyway the outcome is similar; GLIBC is difficult to update. There's probably another thread about that somewhere.
As for the libraries I've only manually installed libraries when following linuxfromscratch (but I normally just use RPM). Have you done ldconfig from the command line? Check out LFS to see what it says about libraries. Otherwise that's the end of my knowledge on this subject.
thanks for u r time
just have a last try.
i have googled and found a similar thread but i cant understand (may be u can)since its about debian.
here is the link
please have a single try.
What distibution are you using?
[bharani@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.9-22.ELsmp #1 SMP Mon Sep 19 18:32:14 EDT 2005 i686 i686 i386 GNU/Linux
Perhaps I should have read the original post better. GLIBC is not the same as GLIBCXX. You need GLIBCXX version 3.4.9 or newer.
GLIBCXX is provided by libstdc++ so it looks as if we have identified the out of date package.
rpm.pbone.net is a good place to search for rpms. Search for libstdc++ for you distribution and click on it to inspect the package contents. It will tell you which versions of GLIBCXX are proveded. It's worth noting that there are sometimes newer versions of rpms on this site than on your distros package repositories. If you find the glibcxx you're looking for then download the rpm and install it.
I got same type of error during installation of VLC media player in SuSE 10.2 Desktop. I resolved it by following the below steps:
vlc-wrapper -v or vlc -v (showing the following error)
main libvlc warning: cannot load module '/usr/lib/vlc/gui/libskins2_plugin.so' (/usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.9' not found by /usr/lib/vlc/gui/libskins2_plugin.so)
Solution: I download the rpm llvm-gcc-c++-2.5-0.pm.2 from rpm.pbhone.net site and installed it and then:
I got the solution by adding entries in /etc/ld.so.conf
# vi /etc/ld.so.conf
add the following line:
Similar problem, but not the same....
I run CentOS 5.3 (RHEL5.3) which has package libstdc++-4.1.2-44.el5.i386.rpm installed which provides:
but NOT libstdc++.so.6(GLIBCXX_3.4.9) which I need for an application I want to install.
The newer version of libstdc++, used by fedora10 is libstdc++-4.3.2-7.i386.rpm, which provides the same, plus libstdc++.so.6(GLIBCXX_3.4.9) which I need!!
Could I install this rpm without risks?
Appreciate your comments!
|All times are GMT -5. The time now is 10:09 AM.|