LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-03-2013, 01:55 PM   #1
Alpha90
Member
 
Registered: Jul 2012
Posts: 47

Rep: Reputation: Disabled
Using noauto option for filesystem in fstab yet the filesystem mounts on boot


The last two entries in my fstab define my optical disc drives and for some reason they are mounting at boot time when I defined in my fstab the noauto option
These are my entries:
Code:
#Entry for HD-DVD / Bluray / DVD Drive:
/dev/sr0                                        /media/cdrom0   udf,iso9660     noauto,user,rw  0       0
#Entry for Bluray / DVD Drive:
/dev/sr1                                        /media/cdrom1   udf,iso9660     noauto,user,rw  0       0
I do not understand why my CD's mount at boot (I have a windows partition for windows video games that do not play well with wine and its just easier to leave the discs in when I am into a game.) Also i do not want to disable my Optical Disc drives as I do use them with my linux system.

I am looking to find a way to keep them from not mounting at boot i assumed this would work and for awhile it did but different CD / DVD's produce different results. I do not know if udev is over riding my fstab options or if there is some problem i had not even considered but i could use some advice on how to fix my problem.
 
Old 01-04-2013, 07:12 AM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Which window manager are you running? .. Gnome will automount cd's irrespective of what you put in /etc/fstab.
 
Old 01-04-2013, 02:10 PM   #3
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 2,329

Rep: Reputation: 593Reputation: 593Reputation: 593Reputation: 593Reputation: 593Reputation: 593
You have a structure error there:

Code:
/dev/sr0     /media/cdrom0   udf,iso9660     noauto,user,rw  0       0
You can have one of udf or iso9660, but not both. I believe what is happening is that the options (noauto,user,rw) are being ignored and treated as the fifth field (and being 0).

Normally you would not have this in the /etc/fstab anyway. This is usually handled by the udev service as the contents of a CD/DVD can be things other than udf or iso9660.

On second thought, it shouldn't be doing anything during boot... The error should prevent it from mounting.

I would guess udev is actually mounting it.

Last edited by jpollard; 01-04-2013 at 02:13 PM.
 
Old 01-05-2013, 04:19 AM   #4
Alpha90
Member
 
Registered: Jul 2012
Posts: 47

Original Poster
Rep: Reputation: Disabled
The fs type was auto generated by one of the gnome applets that deals with mounting.. I just modified the options manually.. Is there a beginners manual to udev ? I've tried to read online docs and they kinda confused me.
 
Old 01-05-2013, 11:58 AM   #5
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 2,329

Rep: Reputation: 593Reputation: 593Reputation: 593Reputation: 593Reputation: 593Reputation: 593
they confuse everybody. Unfortunately, I don't know of any introduction to udev. It seems to get broken every 6 months (or less) for one thing or another.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS mounts read-only filesystem only Quip11 Linux - Networking 1 10-30-2011 01:45 PM
Fix filesystem mounts that are missing the nosuid option where they should have it. gs2045 Linux - Newbie 2 04-03-2011 10:44 AM
boot.localfs will check fs with noauto option set in /etc/fstab tkmbe Suse/Novell 1 03-06-2011 02:38 PM
Root Filesystem (/) Mounts as Read-only emkelly Red Hat 2 12-09-2009 03:08 PM
Filesystem root ( / ) mounts read only at boot, can't re mount RW TheMusicGuy Debian 10 07-25-2006 07:14 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration