LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2005, 11:24 AM   #1
ozymandias
Member
 
Registered: Aug 2005
Location: West Midlands, UK
Posts: 61

Rep: Reputation: 15
Using loopback interface...


I am trying to set up an Imap server, using dovecot - as described for newbies here
http://www.debian-administration.org/articles/275

Having gone through all the steps, I try to connect on the loopback interface using:

mutt -f imap://myname@localhost/Mail

..but get the message: Could not connect to localhost. Connection refused

I suspect I have disabled something simple during a recent security crusade after setting up ssh access from work to home. Pinging localhost works fine. What have I done !!
 
Old 10-28-2005, 11:44 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you probably don't have anything listen on the imap port internally. is dovecot running? is it explicitly set to respond to eth0 only?
 
Old 10-28-2005, 02:37 PM   #3
ozymandias
Member
 
Registered: Aug 2005
Location: West Midlands, UK
Posts: 61

Original Poster
Rep: Reputation: 15
Hmm,

Dovecot is definitely running, and I have tried binding the imap listening to 'localhost', '127.0.0.1' and * (for all IPV4 addresses) in dovecot.conf

No joy!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Truecrypt problem. No available loopback interface white scorpion Linux - Security 4 11-28-2005 08:33 AM
Loopback Interface in a router theneb Linux - Networking 1 01-16-2005 03:03 AM
Localhost - loopback interface mask change the_reen Linux - Networking 1 07-21-2004 10:42 AM
error on boot up: Bringing up loopback interface glorygirl Linux - Networking 2 01-18-2004 11:11 PM
Bringing up loopback interface pollycat Linux - Networking 49 09-07-2003 03:07 PM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration