LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2010, 02:51 AM   #16
f14f21_2
LQ Newbie
 
Registered: Oct 2010
Posts: 19

Rep: Reputation: 1

Quote:
Originally Posted by mahu_mahu View Post
Also,


After giving us the output of dmesg | tail,
Could you change it to
PIDFILE=/var/run/pppoe-adsl2.pid
and run /sbin/ifup ppp1 ?
nope, that's system job to change contents of /var/run . don't mess with them
could you give output dmesg | tail after getting error
 
Old 11-10-2010, 04:01 AM   #17
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Oh, i just want monstruo to edit his /etc/sysconfig/network-scripts/ifcfg-ppp1 .
In unix word ,
Code:
sed 's/pppoe-adsl/pppoe-adsl2/' /etc/sysconfig/network-scripts/ifcfg-ppp1 > tmpfile
mv tmpfile /etc/sysconfig/network-scripts/ifcfg-ppp1
so that another process can have its own pid file under /var/run.

Anyway , I'm also waiting monstruo to give us the output.
 
Old 11-10-2010, 04:21 AM   #18
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
first run
#ifconfig ppp1
to get error as you expect
then
#dmesg | tail
give us output
[root@localhost home]# ifconfig ppp1
ppp1: error fetching interface information: Device not found
[root@localhost home]# dmesg | tail
xenbr0: port 1(vif0.0) entering forwarding state
ADDRCONF(NETDEV_UP): peth0: link is not ready
e1000e: peth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
peth0: 10/100 speed: disabling TSO
ADDRCONF(NETDEV_CHANGE): peth0: link becomes ready
device peth0 entered promiscuous mode
xenbr0: topology change detected, propagating
xenbr0: port 2(peth0) entering forwarding state
virbr0: no IPv6 routers present
eth0: no IPv6 routers present
 
Old 11-10-2010, 04:26 AM   #19
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
OMFG!!! it's connecteeeeeeeeeeeeed!!!!!!!!!!!!! AAaAaaaaaAAaaAAaAAaaaa!
i'm so happy! amazing!

ppp0 Link encap:Point-to-Point Protocol
inet addr:85.204.205.163 P-t-P:10.0.0.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:3138831 errors:0 dropped:0 overruns:0 frame:0
TX packets:2685912 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:203251427 (193.8 MiB) TX bytes:482874005 (460.5 MiB)

ppp1 Link encap:Point-to-Point Protocol
inet addr:85.204.205.97 P-t-P:10.0.0.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:56 errors:0 dropped:0 overruns:0 frame:0
TX packets:6327 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:8337 (8.1 KiB) TX bytes:1092697 (1.0 MiB)



ppp1 is uuuup!!!


i did what mahu_mahu said:

Quote:
sed 's/pppoe-adsl/pppoe-adsl2/' /etc/sysconfig/network-scripts/ifcfg-ppp1 > tmpfile
mv tmpfile /etc/sysconfig/network-scripts/ifcfg-ppp1
what is sed command doing? what these commands did after all? :-?

thank you so much f14f21_2 and mahu_mahu. Now i have to route connections through new ip. Any suggestions? Any examples? some lines in iptables maybe?

Last edited by monstruo; 11-10-2010 at 04:36 AM.
 
Old 11-10-2010, 05:26 AM   #20
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Quote:
what is sed command doing? what these commands did after all? :-?
"sed 's/....... > tempfile " means edit the content of ifcfg-ppp1 and save it to a file named tempfile.
"mv tempfile ......" means move tempfile under /etc/sysconfig/network-scripts and rename it to ifcfg-ppp1 ( if ifcfg-ppp1 already exists , then overwitten).

try
man sed
man mv
read http://www.ibm.com/developerworks/li...ry/l-sed1.html
man bash and search for 'Redirecting output'
to understand what those mean.

And i think you should create a new thread about routing and iptables . i know nothing about them at all.

Good luck!!!

p.s. you didn't have to buy another NIC , i think.

Last edited by mahu_mahu; 11-10-2010 at 05:36 AM. Reason: want to add p.s.
 
Old 11-10-2010, 05:46 AM   #21
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
yes, i think i'll do another topic about routing.
anyway i've succeded to route the second server that uses same port as the first server and it worked, i also connected form outside to the server and works great. i was able to set in the start file of the second server, the ip address and port.

about the NIC's i was using a dedicated NIC and i enabled the onboard nic and also i installed a 3rd nic =)) that i was using on the old server. and now i have 3 nics.

anyway, my problem was solved, many many many thanks to mahu_mahu and f14f21_2, you are great guys and it was very kind of you to help me.

cheers.

SOLVED!
 
Old 11-10-2010, 07:59 AM   #22
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Quote:
about the NIC's i was using a dedicated NIC and i enabled the onboard nic and also i installed a 3rd nic =)) that i was using on the old server. and now i have 3 nics.
FYI, i mean only 1 NIC will work for those connections.
 
Old 12-24-2010, 10:05 AM   #23
lrios
Member
 
Registered: Mar 2008
Location: Arg
Distribution: Cent0S
Posts: 48

Rep: Reputation: 15
Quote:
Originally Posted by monstruo View Post
Hi, f14f21_2, thank you for reply,

The first ppp0 is for my cs1.6 server that uses port 27015, and the ppp1 is for my second cs1.6 server that needs a different ip address to use same port 27015
maybe you need add an alias eth0 and eth0:1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual DSL accounts... PPPoE Config? arfon Slackware 2 03-20-2009 01:23 PM
[ubuntu] pppoeconf for multiple pppoe ISP accounts ddastoor Linux - Software 0 03-05-2009 10:49 AM
Can't connect to the internet no eth0 interface. okos Linux - Software 2 05-15-2008 05:11 PM
two pppoe to the same isp marianop Linux - Networking 7 12-05-2004 04:07 AM
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 11:05 AM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration