LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2010, 07:53 AM   #1
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Rep: Reputation: 0
Using 2 PPPOE accounts same ISP connect through same interface eth0


Hello everybody,

I'm using CENTOS 5.5 and I want to connect to internet using 2 pppoe accounts same ISP and i have a sigle NIC eth0.

I used adsl-setup to create pppoe connections, 1 is ppp0 and second is ppp1. When i use /sbin/ifup ppp0 it works, i can use the internet, but when i try to use /sbin/ifup ppp1 while ppp0 is connected, nothing happens, i did ifconfig and there is only ppp0 showing.

I'm a BIG NEWBIE of linux, i need to know step by step how to make this work, i heard something about a virtual network... but nothing clear.

Thank you in advance,
Ionut
---------------------
Romania/Bucharest

Last edited by monstruo; 11-06-2010 at 07:54 AM.
 
Old 11-06-2010, 03:34 PM   #2
f14f21_2
LQ Newbie
 
Registered: Oct 2010
Posts: 19

Rep: Reputation: 1
hi
two ppoe ? the first one is for the internet and the second one is for ?
 
Old 11-06-2010, 05:16 PM   #3
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Hi, f14f21_2, thank you for reply,

The first ppp0 is for my cs1.6 server that uses port 27015, and the ppp1 is for my second cs1.6 server that needs a different ip address to use same port 27015
 
Old 11-07-2010, 06:11 AM   #4
f14f21_2
LQ Newbie
 
Registered: Oct 2010
Posts: 19

Rep: Reputation: 1
whatever you want to do is very odd
you have two servers and both of them listen to port 27015.
but you want make two connection in one phone line ?
could you give me more information about your network. specially your network topology and what are you going to accomplish ?
when you have one phone line you can have just one pppoe connection.
did ISP told you that you can have two pppoe connection in the same line ?
 
Old 11-07-2010, 08:52 AM   #5
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
My ISP told me that it is possible.

I did some changes meanwhile, i've added another NIC with same ISP connection. I configured again adsl-setup ppp1 to eth1 (the new NIC) and I typed /sbin/ifup ppp1 and if i use ifconfig ppp1 says that ppp1: error fetching interface information: Device not found
 
Old 11-08-2010, 01:08 AM   #6
f14f21_2
LQ Newbie
 
Registered: Oct 2010
Posts: 19

Rep: Reputation: 1
#lspci
what is output ?
 
Old 11-08-2010, 02:03 AM   #7
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:03.0 Communication controller: Intel Corporation 82G33/G31/P35/P31 Express MEI Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
03:00.0 Ethernet controller: Intel Corporation 82572EI Gigabit Ethernet Controller (Copper) (rev 06)
04:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6101 single-port PATA133 interface (rev b2)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
 
Old 11-08-2010, 08:05 AM   #8
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Just I'm curious, but

#ls /etc/sysconfig/network-scripts/ifcfg-ppp*
#ls /etc/ppp/

What are the outputs of those commands?
 
Old 11-08-2010, 10:24 AM   #9
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
/etc/sysconfig/network-scripts/ifcfg-ppp0
/etc/sysconfig/network-scripts/ifcfg-ppp0.bak
/etc/sysconfig/network-scripts/ifcfg-ppp1
/etc/sysconfig/network-scripts/ifcfg-ppp1.bak
/etc/sysconfig/network-scripts/ifcfg-ppp2


chap-secrets ip-down ipv6-up pppoe-server-options
chap-secrets.bak ip-down.ipv6to4 options resolv.conf
firewall-masq ip-up pap-secrets
firewall-standalone ip-up.ipv6to4 pap-secrets.bak
ioptions ipv6-down peers
 
Old 11-08-2010, 08:30 PM   #10
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Don't you invoke these two commands
adsl-start /etc/sysconfig/network-scripts/ifcfg-ppp0
adsl-start /etc/sysconfig/network-scripts/ifcfg-ppp1
to connect to internet in centos?
 
Old 11-09-2010, 01:54 AM   #11
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
[root@localhost home]# adsl-start /etc/sysconfig/network-scripts/ifcfg-ppp1
[root@localhost home]# ifconfig ppp1
ppp1: error fetching interface information: Device not found




i think is the same like using /sbin/ifup ppp1

Last edited by monstruo; 11-09-2010 at 01:55 AM.
 
Old 11-09-2010, 05:57 AM   #12
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
-What does your syslog say when you get this error?
-Make sure you have 2 ids and 2 passwords in
/etc/ppp/chap-secrets and /etc/ppp/pap-secrets
-What is the content of your /etc/sysconfig/network-scripts/ifcfg-ppp1?(you should change your account (and provider name?))
 
Old 11-09-2010, 03:15 PM   #13
monstruo
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
-Make sure you have 2 ids and 2 passwords in
/etc/ppp/chap-secrets and /etc/ppp/pap-secrets
i have 2 ids and 2 passwords, both of the are unique and correct typed.

Quote:
-What is the content of your /etc/sysconfig/network-scripts/ifcfg-ppp1?(you should change your account (and provider name?))
USERCTL=no
BOOTPROTO=dialup
NAME=DSLppp1
DEVICE=ppp1
TYPE=xDSL
ONBOOT=yes
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=60
DEFROUTE=yes
SYNCHRONOUS=no
ETH=eth1
PROVIDER=DSLppp1
USER=anin3352
PEERDNS=yes
DEMAND=no


Quote:
-What does your syslog say when you get this error?
i don't know where to find that syslog file...

Last edited by monstruo; 11-09-2010 at 03:18 PM.
 
Old 11-09-2010, 03:46 PM   #14
f14f21_2
LQ Newbie
 
Registered: Oct 2010
Posts: 19

Rep: Reputation: 1
Quote:
i don't know where to find that syslog file...
first run
#ifconfig ppp1
to get error as you expect
then
#dmesg | tail
give us output
 
Old 11-09-2010, 06:53 PM   #15
mahu_mahu
Member
 
Registered: Dec 2007
Location: Japan
Distribution: Debian
Posts: 42

Rep: Reputation: 3
Also,
Quote:
PIDFILE=/var/run/pppoe-adsl.pid
After giving us the output of dmesg | tail,
Could you change it to
PIDFILE=/var/run/pppoe-adsl2.pid
and run /sbin/ifup ppp1 ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual DSL accounts... PPPoE Config? arfon Slackware 2 03-20-2009 01:23 PM
[ubuntu] pppoeconf for multiple pppoe ISP accounts ddastoor Linux - Software 0 03-05-2009 10:49 AM
Can't connect to the internet no eth0 interface. okos Linux - Software 2 05-15-2008 05:11 PM
two pppoe to the same isp marianop Linux - Networking 7 12-05-2004 04:07 AM
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 11:05 AM


All times are GMT -5. The time now is 12:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration