LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-30-2005, 02:54 PM   #1
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Rep: Reputation: 0
Question Users Locked Out, Gdm Gone Beserk,14 hours @ work. No Solution yet.


To Anyone Who might be of assistance:

Before I begin I would like to .

(1) Declare that I understand that no, one member of the Free linux comunity, has the obligation to answer to anyones request for aid unless they so desire, or are being paid

(2) Declare that It is understood that anyone who does provide aid, does it mainly for the benefit of the
community as a whole.

(3) Declare that I not only understand, but also support, the idea, that ANYONE no matter how high up in the food chain, is OBLIGATED to do their homework before requesting free assistance from anyone else.

Having said all that I will describe my dillema, and the attempted solutions.

I was experiencing problems initiating the X server. The problems started happening right after I attempted to login to root using GNOME and halted the system when GNOME froze logging in to root. Right Now the computer starts up fine and goes right into text mode asking for my login, but when I logged in as root and 'startx' I got this message:
--------Log File: "/var/log/Xorg.0.log
Using config file: "/etc/ X11/xorg.conf"
using vt 7
(EE) Failed to load module "/usr/X!!R6/lib/modules/extensions/libglx.a" (once-on
ly module, 136033803)
Could not init font path element unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

Please consult the The X.Org Foundation support
at [wiki.X..Org]
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati
on.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
[root@localhost ~]#------

so I entered the "cat /var/log/Xorg.0.log" command, (unfortunately the first part was cut off but this is the part it
scrolled down to):

-------(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) Mouse1" ps2EnableDataReporting: succeeded
Could not init font path element unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

Please consult the The X.Org Foundation support
at [wiki.X..Org]
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati
on.

(II) I810(0): xf86UnbindGARTMemory: unbind key 0
(II) I810(0): xf86UnbindGARTMemory: unbind key 1
(II) I810(0): xf86UnbindGARTMemory: unbind key 2
[root@localhost ~]#------


The next thing I did was on run the "xf86config" command, which allowed me to write a configuration file sufficient to let me log into KDE -root using "startx" , However when I attempted to run gdm I received the following message:

Server Authorization directory (daemon/ServAuthDir) is set to /var/lib/gdm but this
does not exist. Please correct gdm configuration /etc/X11/gdm/gdm.conf and re-
start again

gdm_config_parse: Authdir /var/lib/gdm does not exist. Aborting
-------

Not only that but when I tried logging in as a user other than root I recieved the following message:

localhost login: admin
Password:
Last login: Mon Aug 29 20:57:46 on tty2
-bash: /etc/profile: permission denied
-bash-3.00$
-----------

so I changed permissions of "/etc/profile.d" (since I found no "/etc/profile") to enable everyone to read and modify etc. "( root already had permissions to do so) but that didnt help
I uninstalled and reinstalled gdm= still no changes
I looked at gdm.conf which does indeed contain a reference to /var/lib/gdm, in turn the folder /var/lib/gdm contains :1.Xauth , :1.Xservers , core.6069 , core.6664 , .fonts.cache-1 , .cookie
The file “:1.Xauth” is a JPEG 2000 Image that contains within the GNU GENERAL PUBLIC LICENSE
The file “:1.Xservers” contains: :1 local /usr/X11R6/bin/X :1 -audit 0 -deferglyphs 16
Im not quite sure what the core files contain and I was afraid to open them
The file .fonts.cache-1 contains:
"/usr/X11R6/lib/X11/fonts/encodings/large 0 1124769710 " .dir"
"/usr/X11R6/lib/X11/fonts/encodings/ 0 1124769710 " .dir"
"/usr/X11R6/lib/X11/fonts/ukr 0 1124770001 " .dir"
And lastly, the file .cookie contains: 1f19ae950eec7b434be5843d8dad682c

To tell you the truth I coudnt see why on earth gdm shoudnt be working, so I figured that the problem
was something internal and might be solved by restoring the computer using a backup from a week
before when the computer was running fine.

After I restored the computer using drakbackup, EVERYthing that I just stated about gdm still holds true.
The ONLY thing I see different is that, now when I sign in with a name other than root I receive this:

localhost login: admin
Password:
Last login: Mon Aug 29 22:40:02 on tty2
-bash: vt-is-UTF8: command not found
/bin/unicode_start: line4: kbd_mode: command not found
/bin/unicode_start: line4: kbd_mode: command not found
-bash: dircolors: command not found
-bash: locale: -bash: command not found
-bash: tty: command not found
-bash: tty: command not found
-bash: head: command not found
[admin@localhost ~]$

(by the way, I just checked, and found all the above commands in "/usr/bin" not only that,
but I also checked and found that the permissions for all the above files are set to allow
anyone to read or execute them.
line 4 of "/bin/unicode_start" is: "kbd_mode -u" )

Running the above commands in root, result in:
vt-is-UTF8:
(this command is weird-sometimes it does this::) "Single-byte char mode." (and other times it just presses 1 key over and over ie::) 00000000000000000000000000000000000000000000000000 00000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000
0000000000000000000(....etc etc , until I hit ctrl-c, and somewhere before it does that or in the middle of doing that it gives the error message: "is_in_UTF8_mode: Input/output error" )
kbd_mode:
The keyboard is in raw (scancode) mode
dircolors:
LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33: so=01;35:bd=40;33;01:cd=40;33;01.........(theres a bunch more like that, but it ends with)....*.ogg=01;35:*.mp3=01;35:*.wav=01;35:':
export LS_COLORS
locale:
LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
tty: /dev/pts/0
head:

(it just gives a big empty space that grows everytime I hit enter, and wont revert to the prompt until I hit ctrl-c)

[admin@localhost ~]$ startx
-bash: startx: command not found
[admin@localhost ~]$

AS opposed to before the restoration (when I would receive this):

localhost login: admin
Password:
Last login: Mon Aug 29 20:57:46 on tty2
-bash: /etc/profile: permission denied
-bash-3.00$

as I started up the computer I received the following notification:
Starting Postfix [Failed]
as I shut down I received the following notification:
Shuting down X font server [Failed]

AFTER seeing all this I figured that perhaps if I deleted and reinsated all the users, I might be able to login as a user other then root, but alas, woe is to me... There were no changes and I got the same results as before.

In the Meantime ---Ive discovered that although I can log in using kdm instead of gdm, Even kdm will not allow me to login using the "admin" username or any username other than root. Despite that I am still researching and experimenting (sometimes fatally, sometimes not) ---but in my heart, I am Hoping.....
that someone will come to my aid, and together we may be able to overcome an obstacle that has been set in the path of the Linux User.

Please do not ask me to reinstall my OS (unless it is inevitable)

It is specifically, "to avoid," having to face that...that..truly.. heart rending- mind twisting -teeth grinding (I need not go on) task, "that" I was more then open to the idea of installing Linux (a supposedly "WONDERFULLY stable" OS) which it really has been....

up until now.

Summary of problems:
(1) Impossible to login with any user other then root
(2) cannot get gdm to start although I can get GNOME to start using kdm.

The Latest Devolopment:
I am currently working on getting a copy of the "/var/log/messages" and "/var/log/boot.log" files, Im assuming that theyll be helpful.

PS. Ive learned that it was an extremely DUMB thing to attempt to Login to ROOT using a DM but is it really
possible that it caused this much harm?? anyways regardless of what caused this seemingly HUGE mess, I
plan to clean it up.

PPS. TO ALL THOSE WHO WISH TO TELL ME TO RTFM: Ive done, and continue to do that, and its quite
possible that I will still be doing that for the next 2 and a half years from now, if the entire linux community refuses to heed my plea. O ya, almost forgot. RTFMing is not the only thing Ive been doing.

IF YOU ARE SOMEONE WHO TELLS OTHERS TO RTFM, 'ONLY' IF THEY ARE 'Good For Nothing' LAZY BUMS then please forgive me If I have insulted you, Some ppl really could use a good session of RTFMing
(I just feel that having done alot I am not one of em, even though I still continue to RTFM- and I woudnt mind if someone directly pointed me to a specific...helpful Manual)

Sincerely,
Joseph
 
Old 08-30-2005, 03:46 PM   #2
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
It sounds to me like a path has been knocked off or something,
try "echo $PATH"? mine says:
Code:
tuttle@shangrila:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/opt/www/htdig/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/share/texmf/bin:.
Also, have you checked ldconfig? mine says:
Code:
tuttle@shangrila:/etc$ more /etc/ld.so.conf
/usr/local/lib
/usr/X11R6/lib
/usr/i486-slackware-linux/lib
/opt/kde/lib
 
Old 08-30-2005, 04:20 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
This web page has some information on that error message.
http://www.faqs.org/docs/Linux-HOWTO/XDMCP-HOWTO.html

Also, in rpmdrake, do a search for "fixed". I think you may have torked a font or path that xfs uses. Reinstalling the rpm package that contains the font may fix it. I don't remember the package name however, but it might be one of the base xorg packages.
 
Old 08-30-2005, 04:49 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Re: Users Locked Out, Gdm Gone Beserk,14 hours @ work. No Solution yet.

Quote:
Originally posted by fragmented_user
--------Log File: "/var/log/Xorg.0.log
Using config file: "/etc/ X11/xorg.conf"
using vt 7
(EE) Failed to load module "/usr/X!!R6/lib/modules/extensions/libglx.a" (once-on
ly module, 136033803)
Could not init font path element unix/:-1, removing from list!
That's definitely font server (you later show a message that it failed to stop). Try to start it manually (xfs service). If it doesn't start, there should be more in /var/log/messages. It may be a lock file not deleted.

Glx error is not dangerous. It should work without it.

Quote:
Server Authorization directory (daemon/ServAuthDir) is set to /var/lib/gdm but this
does not exist. Please correct gdm configuration /etc/X11/gdm/gdm.conf and re-
start again
Look for /var/lib/gdm permissions (that's probably related to all your permission problems). I have:
Code:
drwxrwx--T   2 root  gdm    184 2005-08-30 22:29 gdm
And files inside (I actually use GDM):
[code]
-rw-r----- 1 root root 45 2005-08-30 22:29 :0.Xauth
-rw-r--r-- 1 root root 38 2005-08-30 22:29 :0.Xservers[/quote]
But it's ok to have no files inside at this time.

Quote:
I looked at gdm.conf which does indeed contain a reference to /var/lib/gdm, in turn the folder /var/lib/gdm contains :1.Xauth , :1.Xservers , core.6069 , core.6664 , .fonts.cache-1 , .cookie
The file “:1.Xauth” is a JPEG 2000 Image that contains within the GNU GENERAL PUBLIC LICENSE
The file “:1.Xservers” contains: :1 local /usr/X11R6/bin/X :1 -audit 0 -deferglyphs 16
Im not quite sure what the core files contain and I was afraid to open them
Core files are are created when program crashes. They keep info about the situation just before crash. Useful for developers, not useful for end-user. Can be also quite big. Delete everything in that dir after checking that GDM is stopped.

BTW How much free space do you have on / ? If not much (core files can tak many megs of space), remove not needed files (in /var, /tmp etc).

You restored it from backup. It looks it's configuration (temp files etc). Or lack of space. Removing everything from /var/lib/gdm may help.

Quote:
PS. Ive learned that it was an extremely DUMB thing to attempt to Login to ROOT using a DM but is it really
possible that it caused this much harm?? anyways regardless of what caused this seemingly HUGE mess, I
plan to clean it up.
I think that it was crash that caused all this, not you beeing root. The sad thing is that crash that heppens to root is much more painful. More files can be overwritten etc.
 
Old 08-30-2005, 09:38 PM   #5
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
To All:

If this is the first time you are reading this thread and have not yet provided feedback, feel
free to look over the original problem, and the tried solutions, and offer a solution or advice
of your own.

To all those who provided such prompt responses, Thank You.
-----------------------
To:tuttle

"echo $PATH" returned:
/sbin: usr/sbin: /bin: /usr/bin: usr/X11R6/bin: usr/local/bin: /usr/local/sbin: usr/java
jre1.5.0_04/bin

"/etc$ more /etc/ld.so.conf" returned:" -bash: /etc$: No such file or directory"

folder "/etc/ld.so.conf.d" is empty

contents of file "/etc/ld.so.conf"

include ld.so.conf
/usr/X11R6/lib
/usr/lib/qt3/lib
/usr/lib/wine
/usr/local/lib

(I just added) /usr/local/lib

--------------------
To: jschiwal

As of yet I have failed to find a reference to the error I received in the link you provided,
although the site in itself is extremely useful. I continue to look for any references to my
problem, hopefully I will find it soon.

the only file I found that seemed to be related to both "fonts" and "fixed" was: a2ps
although there were other packages such as "xorg-x11-75dpi-fonts" and "xorg-x11-xfs"
both of which would require me to uninstall a nice amount of other packages (if I were to
uninstall these packages) because of dependencies.
----------------------
To:Mara

According to "Mandrake control center" which I am running in gnome, the xfs service is configured
to start at boot and is up and running (perhaps one problem has been unknowningly solved ??)

I set all the permisions of /var/lib/gdm and all the file contained within, to allow Anyone to read
modify or execute them (regardless if it was neccessary) and despite all that, I still get the same
gdm error message.

Quote:
"Delete everything in that dir after checking that GDM is stopped."
unfortunately I never did get GDM to start again after the crash, but anyways I deleted everything
in the gdm file (after making a complete backup) and attempted to start gdm, but again received the
same error message as before.

I have a little over 5Gig of free space and could easily free 5GBs more if I had to.

Quote:
"The sad thing is that crash that heppens to root is much more painful. More files can be
overwritten etc"
Thank you for understanding what Im going through.
---------------------

Sincerely,
Joseph

Quote:
Summary of problems:
(1) Impossible to login with any user other then root
(2) cannot get gdm to start although I can get GNOME to start using kdm.

Last edited by fragmented_user; 08-30-2005 at 09:51 PM.
 
Old 08-31-2005, 05:54 AM   #6
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Quote:
Originally posted by fragmented_user

-----------------------
To:tuttle

"echo $PATH" returned:
/sbin: usr/sbin: /bin: /usr/bin: usr/X11R6/bin: usr/local/bin: /usr/local/sbin: usr/java
jre1.5.0_04/bin

"/etc$ more /etc/ld.so.conf" returned:" -bash: /etc$: No such file or directory"

--------------------
Hi again, when I said
Code:
tuttle@shangrila:/etc$ more /etc/ld.so.conf
I meant
Code:
more /etc/ld.so.conf
the rest of it is what I see on my command line if I am in the /etc directory!! You got it in the end anyway

As for the things which normal users can't use, /etc/profile has caused me no end of problems on a sparc (different I know) so here is the contents of my /etc/profile for you.
Code:
tuttle@shangrila:~$ more /etc/profile
# /etc/profile: This file contains system-wide defaults used by
# all Bourne (and related) shells.

# Set the values for some environment variables:
export MINICOM="-c on"
export MANPATH=/usr/local/man:/usr/man:/usr/X11R6/man
export HOSTNAME="`cat /etc/HOSTNAME`"
export LESSOPEN="|lesspipe.sh %s"
export LESS="-M"

# If the user doesn't have a .inputrc, use the one in /etc.
if [ ! -r "$HOME/.inputrc" ]; then
  export INPUTRC=/etc/inputrc
fi

# Set the default system $PATH:
PATH="/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games"

# For root users, ensure that /usr/local/sbin, /usr/sbin, and /sbin are in
# the $PATH.  Some means of connection don't add these by default (sshd comes
# to mind).
if [ "`id -u`" = "0" ]; then
  echo $PATH | grep /usr/local/sbin 1> /dev/null 2> /dev/null
  if [ ! $? = 0 ]; then
    PATH=/usr/local/sbin:/usr/sbin:/sbin:$PATH
  fi
fi

# I had problems using 'eval tset' instead of 'TERM=', but you might want to
# try it anyway. I think with the right /etc/termcap it would work great.
# eval `tset -sQ "$TERM"`
if [ "$TERM" = "" -o "$TERM" = "unknown" ]; then
 TERM=linux
fi

# Set ksh93 visual editing mode:
if [ "$SHELL" = "/bin/ksh" ]; then
  VISUAL=emacs
#  VISUAL=gmacs
#  VISUAL=vi
fi

# Set a default shell prompt:
#PS1='`hostname`:`pwd`# '
if [ "$SHELL" = "/bin/pdksh" ]; then
 PS1='! $ '
elif [ "$SHELL" = "/bin/ksh" ]; then
 PS1='! ${PWD/#$HOME/~}$ '
elif [ "$SHELL" = "/bin/zsh" ]; then
 PS1='%n@%m:%~%# '
elif [ "$SHELL" = "/bin/ash" ]; then
 PS1='$ '
else
 PS1='\u@\h:\w\$ '
fi
PS2='> '
export PATH DISPLAY LESS TERM PS1 PS2

# Default umask.  A umask of 022 prevents new files from being created group
# and world writable.
umask 022

# Set up the LS_COLORS and LS_OPTIONS environment variables for color ls:
if [ "$SHELL" = "/bin/zsh" ]; then
 eval `dircolors -z`
elif [ "$SHELL" = "/bin/ash" ]; then
 eval `dircolors -s`
else
 eval `dircolors -b`
fi

# Notify user of incoming mail.  This can be overridden in the user's
# local startup file (~/.bash.login or whatever, depending on the shell)
if [ -x /usr/bin/biff ]; then
 biff y
fi

# Append any additional sh scripts found in /etc/profile.d/:
for profile_script in /etc/profile.d/*.sh ; do
  if [ -x $profile_script ]; then
    . $profile_script
  fi
done
unset profile_script

# For non-root users, add the current directory to the search path:
if [ ! "`id -u`" = "0" ]; then
 PATH="$PATH:."
fi
I could not find the package to which it belongs so I assume it is created during install somehow. I hope this is of some use to you.
 
Old 08-31-2005, 09:04 AM   #7
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
To:tuttle

Being a Newbie and all I could shrug off the fact that I misinterpeted

tuttle@shangrila:/etc$ more /etc/ld.so.conf

and quite easily get away with it. However, since I personally find a misinterpretation
such as this one, so utterly dumb and inexusable, Ill simply say, that the misinterpretation
should give you some idea of how exhausted I was at the time I ran the command.

Moving on, I must say that Its going to take me some time to make sense out of the code
you so kindly posted. That of course is no fault of your own, but is completely mine (shouldve-
paid attention in those coding classes--dam* )

While I do that, (make sense out of the code) I thought that if I posted the contents of my
/etc/profile it might speed things up a bit (not that Im hurrying anyone) as it is possible that
their is an easily identifiable error in my file, that I by myself, would not be able to spot for
several months.
Right now I only went so far, as to subsitute your /etc/profile for mine,
which didnt work, I got the same errors as when I used my own /etc.profile
plus others.


Code:
# /etc/profile -*- Mode: shell-script -*- 
# (c) MandrakeSoft, Chmouel Boudjnah <chmouel@mandrakesoft.com>

loginsh=1

# Users generally won't see annoyng core files
[ "$UID" = "0" ] && ulimit -S -c 1000000 > /dev/null 2>&1

if ! echo ${PATH} |grep -q /usr/X11R6/bin ; then
    PATH="$PATH:/usr/X11R6/bin"
fi

if [ "$UID" -ge 500 ] && ! echo ${PATH} |grep -q /usr/games ; then
    PATH=$PATH:/usr/games
fi

umask 022

USER=`id -un`
LOGNAME=$USER
MAIL="/var/spool/mail/$USER"
HISTCONTROL=ignoredups
HOSTNAME=`/bin/hostname`
HISTSIZE=1000

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then
    INPUTRC=/etc/inputrc
fi

# some old programs still use it (eg: "man"), and it is also
# required for level1 compliance for LI18NUX2000
NLSPATH=/usr/share/locale/%l/%N

export PATH PS1 USER LOGNAME MAIL HOSTNAME INPUTRC NLSPATH
export HISTCONTROL HISTSIZE 
for i in /etc/profile.d/*.sh ; do
	if [ -x $i ]; then
		. $i
	fi
done

unset i
Sincerely,
Joseph

Last edited by fragmented_user; 08-31-2005 at 09:30 AM.
 
Old 08-31-2005, 09:38 AM   #8
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
I quite understand, I don't consider myself a coder or anywhere near a guru either.
I was under the impression "/etc/profile" didn't exist on your system, but upon re-reading your original post:
Quote:
so I changed permissions of "/etc/profile.d" (since I found no "/etc/profile") to enable everyone to read and modify etc. "( root already had permissions to do so) but that didnt help
I notice that it says "permission denied" and not "no such file". I think your "/etc/profile" seems ok, it's more a case of privilege problems for normal users and/or the X server, hence it can't find or access crucial system files.
Check that the permissions for "/etc/profile" are 644 (rw-r--r--).
I don't think there is a problem with X or gdm, but I can't offer much more help on the way profiles are handled, sorry. Try the command "export" as root then compare it the same thing when run as a normal user, the output is a list of all your environment variables.
One piece of software that handles security is "pam", I'm not sure if mandriva uses "pam" but I can point you to its config files:
/etc/pam.d (directory)
/etc/security (directory)
if they exist you may want to check what "pam" is doing as it can dynamically modify the permissions of files for each logged in user and other clever stuff.

Last edited by Tuttle; 08-31-2005 at 09:39 AM.
 
Old 08-31-2005, 11:52 AM   #9
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
Please pardon me for telling you that there was no /etc/profile file, when I simply overlooked it,
(Im getting used to the idea that the nautilus filebrowser only lists fles after it lists all folders first)

now about the export command, the command returned:
in root:

Code:
declare -x BROWSER="/usr/bin/www-browser"
declare -x COLORTERM="gnome-terminal"
declare -x DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-6NL6GDFqj4"
declare -x DBUS_SESSION_BUS_PID="27037"
declare -x DESKTOP_SESSION="02GNOME"
declare -x DESKTOP_STARTUP_ID=""
declare -x DISPLAY=":0.0"
declare -x DM_CONTROL="/var/run/xdmctl"
declare -x ENV="/root/.bashrc"
declare -x GCONF_TMPDIR="/tmp"
declare -x GNOME_DESKTOP_SESSION_ID="Default"
declare -x GNOME_DISABLE_CRASH_DIALOG="1"
declare -x GNOME_KEYRING_SOCKET="/root/tmp/keyring-FLqVCn/socket"
declare -x GTK_RC_FILES="/etc/gtk/gtkrc:/root/.gtkrc-1.2-gnome2"
declare -x G_FILENAME_ENCODING="@locale"
declare -x HISTCONTROL="ignoredups"
declare -x HISTSIZE="1000"
declare -x HOME="/root"
declare -x HOSTNAME="localhost"
declare -x INPUTRC="/etc/inputrc"
declare -x JAVA_HOME="/usr/java/jre1.5.0_04/bin"
declare -x LANG="en_US.UTF-8"
declare -x LANGUAGE="en_US.UTF-8:en_US:en"
declare -x LC_ADDRESS="en_US.UTF-8"
declare -x LC_COLLATE="en_US.UTF-8"
declare -x LC_CTYPE="en_US.UTF-8"
declare -x LC_IDENTIFICATION="en_US.UTF-8"
declare -x LC_MEASUREMENT="en_US.UTF-8"
declare -x LC_MESSAGES="en_US.UTF-8"
declare -x LC_MONETARY="en_US.UTF-8"
declare -x LC_NAME="en_US.UTF-8"
declare -x LC_NUMERIC="en_US.UTF-8"
declare -x LC_PAPER="en_US.UTF-8"
declare -x LC_SOURCED="1"
declare -x LC_TELEPHONE="en_US.UTF-8"
declare -x LC_TIME="en_US.UTF-8"
declare -x LESS="-MM"
declare -x LESSKEY="/etc/.less"
declare -x LESSOPEN="|/usr/bin/lesspipe.sh %s"
declare -x LOGNAME="root"
declare -x LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40 ;
33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;
32:*.exe =01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.
csh=01;32:*.tar=01; 1:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:
*.zip=01;31:*.z=01;31:*. Z=01;31:*.gz=01;31:*.bz2=01;31:
*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01; 31:*.jpg=01;35:
*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35: 
*.tif=01;35:"
declare -x MAIL="/var/spool/mail/root"
declare -x NLSPATH="/usr/share/locale/%l/%N"
declare -x OLDPWD
declare -x PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/
bin:/usr/local/sbin:/usr/java/jre1.5.0_04/bin:"
declare -x PWD="/root"
declare -x PYTHONSTARTUP="/etc/pythonrc.py"
declare -x QTDIR="/usr/lib/qt3/"
declare -x SCREENDIR="/root/tmp"
declare -x SECURE_LEVEL="2"
declare -x SESSION_MANAGER="local/localhost:/tmp/.ICE-unix/26962"
declare -x SHELL="/bin/bash"
declare -x SHLVL="2"
declare -x TERM="xterm"
declare -x TMP="/root/tmp"
declare -x TMPDIR="/root/tmp"
declare -x USER="root"
declare -x USERNAME="root"
declare -x WINDOWID="54526031"
declare -x XAUTHORITY="/root/.xauthd047QC"
declare -x XDG_CONFIG_DIRS="/var/lib/menu-xdg"
declare -x XDG_DATA_DIRS="/var/lib/menu-xdg:/usr/share"
declare -x XDM_MANAGED="/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic"
declare -x XMODIFIERS="@im=none"
declare -x ftp_proxy
declare -x http_proxy
in admin (a regular user name):

theres a bunch that I missed, but in the end it scrolled down to:

Code:
declare -x LESS="-MM"
declare -x LESSKEY="/etc/.less"
declare -x LOGNAME="admin"
declare -x MAIL="/var/spool/mail/admin"
declare -x NLSPATH="/usr/share/locale/%l/%N"
declare -x OLDPWD
declare -x PATH="/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/games:/home/admin/bin"
declare -x PS1="[\\u@\\h \\W]\\\$ "
declare -x PWD="/home/admin"
declare -x PYTHONSTARTUP="/etc/pythonrc.py"
declare -x QTDIR="/usr/lib/qt3/"
declare -x SCREENDIR="/home/admin/tmp"
declare -x SECURE_LEVEL="2"
declare -x SESSION_MANAGER="local/localhost:/tmp/.ICE-unix/26962"
declare -x SHELL="/bin/bash"
declare -x SHLVL="1"
declare -x TERM="linux"
declare -x TMP="/home/admin/tmp"
declare -x TMPDIR="/home/admin/tmp"
declare -x USER="admin"
declare -x USERNAME="admin"
declare -x XDG_CONFIG_DIRS="/var/lib/menu-xdg"
declare -x XDG_DATA_DIRS="/var/lib/menu-xdg:/usr/share"
declare -x ftp_proxy
declare -x http_proxy
And lastly, yes, the files /etc/pam.d (directory) and /etc/security (directory) do exist.
Unfortunately though there were so many different files in those 2 directories, that
I will need to ask for guidance
(or on second thought I could do a google search for pam to see if anything turns up)

With Much Gratitude,
Joseph

Last edited by fragmented_user; 08-31-2005 at 02:20 PM.
 
Old 08-31-2005, 12:31 PM   #10
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
less is more, more is less! get used to a terminal man (man)!!
If I don't want the contents of a file that I am listing to run off screen I use more (or less):
Code:
export | more
the "|" means "pipe the output to" and you will have an easily readable output from "export".

edit: all puns intended

Last edited by Tuttle; 08-31-2005 at 12:32 PM.
 
Old 08-31-2005, 01:24 PM   #11
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
Talking

It had been for a while dawning upon me that it would be useful if I were to learn the console commands
But suddenly it hit me, I had better learn them good and learn em fast, if I ever want to get very far with
linux.

I am indeed a lucky man to have met such ppl who overlook my obvious ingnorance, and have the patience to guide me while I stumble along, (regardless if others besides for me are benefitting from it or not) (that is not to say that Im not making an honest effort towards solving my own problems)



And Now, for the ever evasive output (the ommited super-scrolled beginning)

[admin@localhost ~]$ export | more
declare -x GCONF_TMPDIR="/tmp"
declare -x GNOME_DISABLE_CRASH_DIALOG="1"
declare -x G_FILENAME_ENCODING="@locale"
declare -x HISTCONTROL="ignoredups"
declare -x HISTSIZE="1000"
declare -x HOME="/home/admin"
declare -x HOSTNAME="localhost"
declare -x INPUTRC="/etc/inputrc"
declare -x LANG="en_US.UTF-8"
declare -x LANGUAGE="en_US.UTF-8:en_US:en"
declare -x LC_ADDRESS="en_US.UTF-8"
declare -x LC_COLLATE="en_US.UTF-8"
declare -x LC_CTYPE="en_US.UTF-8"
declare -x LC_IDENTIFICATION="en_US.UTF-8"
declare -x LC_MEASUREMENT="en_US.UTF-8"
declare -x LC_MESSAGES="en_US.UTF-8"
declare -x LC_MONETARY="en_US.UTF-8"
declare -x LC_NAME="en_US.UTF-8"
declare -x LC_NUMERIC="en_US.UTF-8"
declare -x LC_PAPER="en_US.UTF-8"
declare -x LC_SOURCED="1"
declare -x LC_TELEPHONE="en_US.UTF-8"
declare -x LC_TIME="en_US.UTF-8"

<continued on previous post>

P.S. I appreciate your sense of humor

Sincerely,
Joseph

Last edited by fragmented_user; 09-01-2005 at 06:49 AM.
 
Old 08-31-2005, 01:50 PM   #12
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
A minor suggestion: I recently did a restore from a dump, and was unable to log in as anything but root. Solved when I discovered that the restore (actually, my response to a question asked by restore) had reset the ownership of the subdirectories of /home to root.

So, I'd suggest doing a ls -l /home to make sure that each user owns their own home directory.

I suggest this because one symptom was X couldn't start since it couldn't create its user space information files.
 
Old 08-31-2005, 02:12 PM   #13
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
To: PTrenholme

I am thankful that you took time to offer a solution. Unfortunately though it seems that I still receive the same
error messages as before even with all the permissions set correctly.

Sincerely,
Joseph
 
Old 08-31-2005, 04:26 PM   #14
fragmented_user
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu 6.10 (Edgy Eft)
Posts: 11

Original Poster
Rep: Reputation: 0
To All:

It seems that I left out what might be an important detail. That is, when I said earlier, that I originally halted the system
when GNOME froze while logging in under root, I failed to mention that I halted the system abnormally
(meaning I basically pulled the plug)

-Joseph

Last edited by fragmented_user; 08-31-2005 at 09:39 PM.
 
Old 09-01-2005, 02:22 PM   #15
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
That's an important thing. Even if it boots correctly now, use a rescue disk and check the filesystems using fsck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locked out of xebian by GDM nalmeth Debian 3 08-26-2005 10:30 PM
How to get a list of users with their password status (expired, account locked...)? ricky_ds Linux - General 6 02-28-2005 09:53 AM
how to tell what users are locked out psychobyte Linux - Security 1 06-10-2004 07:54 PM
restricting logon hours to users? FiveFlat Linux - Networking 2 01-18-2004 01:43 PM
Solution to Mdk 9.1 gdm user doesnt exist problem gn000we Mandriva 0 12-14-2003 04:08 PM


All times are GMT -5. The time now is 09:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration