LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2011, 02:36 PM   #1
johnifanx98
LQ Newbie
 
Registered: Jan 2008
Posts: 26

Rep: Reputation: 0
useradd hangs (newly installed rhel 5.2)


under root, I tried to create new user by useradd. It usually takes more than 5 minutes.

Also, su <user> also takes long time. I did not even know if it eventually went through.

This instance is installed on vmware server 2.

Last edited by johnifanx98; 01-11-2011 at 02:40 PM.
 
Old 01-11-2011, 02:51 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
With that info it's impossible to make even an educated guess. It could
be the host is CPU starved, it could be networking problems or the way
you set the guest up, ...


Have a look at the output of "strace -tVf su" ... it may tell you something
about the how and why.



Cheers,
Tink
 
Old 01-11-2011, 02:52 PM   #3
mesiol
Member
 
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137
Hi,

Somewhat rare information.

From my experience in most cases slow virtual machine have trouble with disk i/o or less memory. Check memory usage and check i/o latency using
Code:
iostat
and
Code:
vmstat
.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
without rebooting the server [ having the os RHEL 3.0 ] how to detect the newly assi linnuxanil Red Hat 2 08-09-2009 11:06 AM
Cannot boot already installed ubuntu on newly installed win xp abhi_337 Ubuntu 1 07-13-2006 04:33 AM
help with newly installed slackware 10.2!!!!! D_O_Y_L_E Slackware 4 03-17-2006 04:43 PM
useradd not found, but shadow is installed Ziax Fedora 2 10-16-2005 06:37 AM
Newly compiled 2.4.7 kernel: It just hangs after login xhorder Linux - General 3 07-22-2001 12:12 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration