LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-17-2005, 09:01 AM   #1
Riun
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
User permissions to launch X


hi all, i've installed gentoo with fluxbox and gdm to launch fluxbox. gdm works perfectly, and fluxbox too, but even tho gdm launches for root or regular user, fluxbox only launches as root, i don't understand why my regular user can't launch fluxbox .. i've tried chmod 755 for .fluxbox/startup and for gdm and a few other files i thought might be linked to the problem, but i still get the same result

any help would be really appreciated thanx =)

ah and actually i have a second problem while trying to configure my wireless card with ndiswrapper, installation of ndiswrapper and of the driver work correctly, so does the modprobing. but i can't seem to do the configuration correctly, i use an hex key. am i right to configure it with :

iwconfig wlan0 key xxxxxxxxxxxxxxxxxxxxxxxxxx

thanx for help

Riun

Last edited by Riun; 07-17-2005 at 10:27 AM.
 
Old 07-17-2005, 05:53 PM   #2
eddiebaby1023
Member
 
Registered: May 2005
Posts: 378

Rep: Reputation: 33
Can you tell us what diagnostics fluxbox produces ("doesn't work" isn't too helpful)? Do the logs have anything interesting in them about why it's not working?
 
Old 07-24-2005, 04:47 PM   #3
Riun
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Original Poster
Rep: Reputation: 0
yeah sorry bout that .. thought someone might have a similar problem ..

here are the xdm-errors logs


_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/nutshell:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.11-gentoo-r3 i686 [ELF]
Current Operating System: Linux nutshell 2.6.12-gentoo-r4 #1 SMP Sun Jul 17 11:09:43 CEST 2005 i686
Build Date: 17 July 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 17 13:46:46 2005
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(EE) Failed to load module "speedo" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Cannot open config file. Using builtin defaults
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 158 requests (151 known processed) with 0 events remaining.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Cannot open config file. Using builtin defaults
X connection to :0.0 broken (explicit kill or server shutdown).
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Cannot open config file. Using builtin defaults
X connection to :0.0 broken (explicit kill or server shutdown).
Unknown session exit code 2304 from process 14777
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/nutshell:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.11-gentoo-r3 i686 [ELF]
Current Operating System: Linux nutshell 2.6.12-gentoo-r4 #1 SMP Sun Jul 17 11:09:43 CEST 2005 i686
Build Date: 17 July 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 17 16:04:38 2005
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(EE) Failed to load module "speedo" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Cannot open config file. Using builtin defaults
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Greet cannot exec /usr/bin/wdmLogin
Greet: guarenteed_read error, UNMANAGE DISPLAY
Greet: pipe read error with /usr/bin/wdmLogin
X connection to :0.0 broken (explicit kill or server shutdown).
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/nutshell:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.11-gentoo-r3 i686 [ELF]
Current Operating System: Linux nutshell 2.6.12-gentoo-r4 #1 SMP Sun Jul 17 11:09:43 CEST 2005 i686
Build Date: 17 July 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 17 16:27:56 2005
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(EE) Failed to load module "speedo" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 4/group 1 on key <LSGT>
> Using backslash, ignoring brokenbar
> Warning: Symbol map for key <LSGT> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/local/, removing from list!
Greet cannot exec /usr/bin/wdmLogin
Greet: guarenteed_read error, UNMANAGE DISPLAY
Greet: pipe read error with /usr/bin/wdmLogin
Server crash rate too high: removing display :0


it's weird because fluxbox works as root, and gnome-light works with root or user ..

thanx for help =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't launch X-apps as super user Optimistic Debian 3 09-18-2005 01:05 PM
User Profile in use (Mozilla won't launch) raysr Mandriva 2 08-27-2005 11:10 PM
General Web question: How to have a user launch a text file alar General 2 05-19-2005 06:47 PM
How to launch a program as a defined user at startup. Linux.tar.gz Linux - Software 2 03-20-2005 12:28 PM
Can't launch X apps when 'su'd as another user davee Linux - Newbie 3 08-17-2003 12:54 PM


All times are GMT -5. The time now is 12:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration