LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2005, 09:40 AM   #1
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Rep: Reputation: 30
user+cdrom problem.


[staff@localhost staff]$ mount /mnt/cdrom/
mount: must be superuser to use mount
[staff@localhost staff]$ cat /etc/fstab
/dev/hda6 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,unhide,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,umask=0,user,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
/dev/hda8 /mnt/win_e vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
[staff@localhost staff]$ ll /dev/hdc
brw-rw-rw- 1 root root 22, 0 Mar 7 07:46 /dev/hdc
[staff@localhost staff]$


pls help me how to set a cdrom to user can able to mount it?
 
Old 08-29-2005, 09:51 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
ls -l $(which mount)
-rwsr-xr-x 1 root root 84880 Aug 18 19:44 /bin/mount

Set the permissions with "chmod 4766 /bin/mount" or whereever which mount said it was.
Or just "chmod 4766 $(which mount)"
 
Old 08-29-2005, 10:18 AM   #3
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Original Poster
Rep: Reputation: 30
[root@localhost root]# ls -l $(which mount)
-rwsrw-rw- 1 root root 95256 Jan 30 2004 /bin/mount*
[root@localhost root]# chmod 4766 /bin/mount
[root@localhost root]#

[staff@localhost staff]$ moun
mount.cifs mount.cifs3
[staff@localhost staff]$ mount.cifs
mount.cifs mount.cifs3
[staff@localhost staff]$ mount.cifs
mount.cifs mount.cifs3
[staff@localhost staff]$ mount.cifs
mount.cifs mount.cifs3
[staff@localhost staff]$ mount.cifs



there ias no mount command for user exists.
i did what u said?
what is that 4766?

should i set 777 or else?


[staff@localhost staff]$ mount /mnt/cdrom
bash: /bin/mount: Permission denied
[staff@localhost staff]$



THAT IS NOT WORKING?
 
Old 08-29-2005, 10:20 AM   #4
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Original Poster
Rep: Reputation: 30
should i reboot my computer after change the permission?
 
Old 08-29-2005, 12:46 PM   #5
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Oops, sorry. Try "chmod 4755 $(which mount)" instead.
No need to reboot.
You should also do a "chgrp cdrom /dev/hdc" or choose some other group to which your user belongs.
Might as well do the same for the mountpoint if needed "chgrp cdrom /mnt/cdrom/"
My permissions on those look like:
ls -ld /dev/hdc /cdrom
drwxrwx--- 2 root cdrom 4096 Sep 5 2004 /cdrom
brw-rw---- 1 root cdrom 22, 0 Nov 14 2003 /dev/hdc
 
Old 08-29-2005, 01:30 PM   #6
hydra7
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
Might be dangerous to change permissions on mount altogether. Just edit the line in /etc/fstab for mounting the cdrom to include root. For more info on this, man mount.
 
Old 08-29-2005, 01:32 PM   #7
hydra7
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
Might be dangerous to change permissions on mount altogether. Just edit the line in /etc/fstab that contains the mount command for cdrom to enable any user to mount the cdrom. For more info on this, man mount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM mounting problem => /dev/cdrom is not a valid block device Vizy Linux - Hardware 8 11-04-2010 04:46 PM
cdrom audio play as user lestoil Slackware 9 06-22-2005 10:08 AM
user cdrom access pmeyer Linux - Newbie 2 03-09-2004 08:58 AM
cdrom/dvd permission as user? teona Linux - Newbie 11 12-28-2003 01:44 PM
cdrom normal user access N|ghtwo|f Linux - Software 1 07-08-2003 07:05 PM


All times are GMT -5. The time now is 07:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration