LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2006, 09:44 AM   #1
windsurfer
Member
 
Registered: Mar 2006
Distribution: Ubuntu
Posts: 91

Rep: Reputation: 15
USB wireless networking


Hi
Have just installed openSuse 10 on my dell laptop, Im trying to get the wireless network to work. The usb adapter (linksys wusb54g) seems to be ok and when I do an ifconfig i get rausb0 created which has the correct IP address

what do I have to do to test it out, pinging the router does not work from the laptop and also on other pc's on the network. Turning the SuseFirewall off has no effect!

Am new to linux but have used windows for many years

Regards
 
Old 03-26-2006, 02:22 PM   #2
zaphod_es
Member
 
Registered: Jun 2003
Location: Brazil
Distribution: Ubuntu
Posts: 134

Rep: Reputation: 15
It looks as though the network card has been identified and working. You now need to configure it for your local settings: DHCP or IP address, netmask, gateway etc. You also need to setup the wireless settings, encryption, channel number etc.

I do not know Suse but I bet there is a network configuration tool which asks you all the right questions. Go through your menus and see what there is.

ZB
 
Old 03-27-2006, 03:23 PM   #3
windsurfer
Member
 
Registered: Mar 2006
Distribution: Ubuntu
Posts: 91

Original Poster
Rep: Reputation: 15
Yes I think you are right, am having a look at the control centre! What is xinetd used for? should I have it enabled?
 
Old 03-27-2006, 03:51 PM   #4
zaphod_es
Member
 
Registered: Jun 2003
Location: Brazil
Distribution: Ubuntu
Posts: 134

Rep: Reputation: 15
I would think that you do want to enable it as it handles a lot of the security settings. See http://www.xinetd.org/
 
Old 03-28-2006, 08:10 AM   #5
windsurfer
Member
 
Registered: Mar 2006
Distribution: Ubuntu
Posts: 91

Original Poster
Rep: Reputation: 15
USB wireless network

I am still having diffculty setting up my wireless PC running OpenSuse 10.1.
When I ping the addaptor IP address I get a reply, but if I ping the wireless access point I get "Destination Host Unreachable"

If a do an arp at this point then I get the following:-

Address HWaddress Iface
192.168.1.1 (incomplete) rausb

the route table is as follows (route -n)


Destination Gateway Genmask Flags Iface
192.168.1.0 0.0.0.0 255.255.255.0 U rausb0
127.0.0.0 0.0.0.0 255.0.0.0 U lo
0.0.0.0 192.168.1.1 0.0.0.0 UG rausb0


the router/gateway is 192.168.1.1
the addapter is 192.168.1.91

if I ping another PC on the 1 network I get "Destination Host Unreachable"

What am I doing wrong? What else needs seting up?

Adrian
 
Old 03-28-2006, 02:16 PM   #6
zaphod_es
Member
 
Registered: Jun 2003
Location: Brazil
Distribution: Ubuntu
Posts: 134

Rep: Reputation: 15
Can you confirm that you have:
A wireless usb adaptor rausb 192.168.1.91
A router 192.168.1.1
A wireless access point (IP not mentioned by you)

Also do you have an ethernet wired network adaptor. If so does this access the internet? If it does it rules out some firewall problems.

The fact that you can ping 192.168.1.91 shows that tcp/ip is set up properly. The result of the route -n looks OK

What about about the output from iwconfig and ipconfig?
If these look OK you need to check the wifi sttings, encryption and firewall. I would disconntect the router from the internet and turn off encryption and the firewall.

I would also look for a tool to configure the wireless settings. ESSID, key type, WEP, channels etc. You can do all this with the iwconfig command but it is hard work if you are not happy using the command line.

This link should help a lot http://wiki.suselinuxsupport.de/wikk...ConfigWifiCard. I have never used Suse and do not know much about KDE so I cannot help much with the gui stuff. If you still cannot get the network going you might get better help in the Suse or the wireless networking forums (but not both).

ZB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Wireless Networking tmckee Linux - Wireless Networking 1 12-03-2005 11:35 AM
Microsoft USB wireless networking with RedHat Indieguy Linux - Wireless Networking 3 07-10-2003 03:30 PM
Wireless Networking USB PlatinumRik Linux - Hardware 2 02-12-2003 11:41 PM
Linux with Wireless USB Networking SynchroFlash Linux - Wireless Networking 2 11-30-2002 08:53 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration