LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   USB Recognition Problem (http://www.linuxquestions.org/questions/linux-newbie-8/usb-recognition-problem-672600/)

CmK 09-26-2008 06:36 PM

USB Recognition Problem
 
I have Ubuntu Linux on a IBM think pad and when I plug in my Wester Digital Ext HDD nothing happens. I have been working on this problem for 2 days now with no luck. Here are the outputs for lsusb, dmessage | tail -n 20, and sudo fdisk -l

Does anyone know why its doing this?

lsusb

chris@chris-laptop:~$ lsusb
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

dmessage | tail -n 20
chris@chris-laptop:~$ dmesg | tail -n 20
[ 9895.790258] usb 4-4: new high speed USB device using ehci_hcd and address 44
[10949.703071] usb 4-4: new high speed USB device using ehci_hcd and address 54
[10950.227445] usb 4-4: new high speed USB device using ehci_hcd and address 58
[10951.913335] usb 4-4: new high speed USB device using ehci_hcd and address 72
[10957.955050] usb 4-4: new high speed USB device using ehci_hcd and address 112
[10962.148229] usb 4-4: new high speed USB device using ehci_hcd and address 126
[ 3868.181565] usb 4-4: new high speed USB device using ehci_hcd and address 4
[10966.132954] usb 4-4: new high speed USB device using ehci_hcd and address 10
[10967.066780] usb 4-4: new high speed USB device using ehci_hcd and address 21
[10967.271905] usb 4-4: new high speed USB device using ehci_hcd and address 22
[10967.600226] usb 4-4: new high speed USB device using ehci_hcd and address 24
[10968.180856] usb 4-4: new high speed USB device using ehci_hcd and address 29
[10969.574177] usb 4-4: new high speed USB device using ehci_hcd and address 40
[10970.376981] usb 4-4: new high speed USB device using ehci_hcd and address 47
[10971.009316] usb 4-4: new high speed USB device using ehci_hcd and address 51
[10971.689266] usb 4-4: new high speed USB device using ehci_hcd and address 56
[10972.124880] usb 4-4: new high speed USB device using ehci_hcd and address 59
[10972.940490] usb 4-4: new high speed USB device using ehci_hcd and address 65
[10973.981045] usb 4-4: new high speed USB device using ehci_hcd and address 74
[10974.260761] usb 4-4: new high speed USB device using ehci_hcd and address 76


chris@chris-laptop:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9b939b93

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9327 74919096 83 Linux
/dev/sda2 9328 9729 3229065 5 Extended
/dev/sda5 9328 9729 3229033+ 82 Linux swap / Solaris
chris@chris-laptop:~$

oskar 09-26-2008 07:19 PM

could you add the last couple of lines (whatever looks relevant) of dmesg after plugging it in?

I vaguely remember having had a similar problem... I think I had to get a new usb case for the drive.

CmK 09-26-2008 07:25 PM

here are the last few lines of dmesg after i plug in the Ext HDD

dmesg

[ 7054.457520] usb 4-4: new high speed USB device using ehci_hcd and address 103
[ 7055.439189] usb 4-4: new high speed USB device using ehci_hcd and address 124
[ 7055.739046] usb 4-4: new high speed USB device using ehci_hcd and address 125
[ 7056.505918] usb 4-4: new high speed USB device using ehci_hcd and address 3
[ 7056.787711] usb 4-4: new high speed USB device using ehci_hcd and address 4
[ 7057.087537] usb 4-4: new high speed USB device using ehci_hcd and address 5
[20005.233474] usb 4-4: new high speed USB device using ehci_hcd and address 20
[12003.733138] usb 4-4: new high speed USB device using ehci_hcd and address 43
[ 7060.286033] usb 4-4: new high speed USB device using ehci_hcd and address 46
[ 7060.908718] usb 4-4: new high speed USB device using ehci_hcd and address 49
[20014.575136] usb 4-4: new high speed USB device using ehci_hcd and address 53
chris@chris-laptop:~$


All times are GMT -5. The time now is 12:43 AM.