LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-07-2009, 05:26 AM   #1
Niraj Kulkarni
Member
 
Registered: May 2008
Posts: 47

Rep: Reputation: 15
USB pen drive not working as HIGH SPEED


Hi
I am using linux 2.4.27.
When "usb-ohci.o" comes into picture pen drive is detected.
When "ehci-hcd.o" ALSO comes into picture , pen drive is not detected.
Here is the log:
*****************************************************
ehci_hcd 00:0f.2: GetStatus port 1 status 001803 POWER sig=j CSC CONNECT
hub.c: port 1, portstatus 501, change 1, 480 Mb/s
hub.c: port 1 connection change
hub.c: port 1, portstatus 501, change 1, 480 Mb/s
ehci_hcd 00:0f.2: GetStatus port 1 status 001801 POWER sig=j CONNECT
hub.c: port 1, portstatus 501, change 0, 480 Mb/s
ehci_hcd 00:0f.2: GetStatus port 1 status 001801 POWER sig=j CONNECT
hub.c: port 1, portstatus 501, change 0, 480 Mb/s
ehci_hcd 00:0f.2: GetStatus port 1 status 001801 POWER sig=j CONNECT
hub.c: port 1, portstatus 501, change 0, 480 Mb/s
ehci_hcd 00:0f.2: GetStatus port 1 status 001801 POWER sig=j CONNECT
hub.c: port 1, portstatus 501, change 0, 480 Mb/s
ehci_hcd 00:0f.2: port 1 reset
ehci_hcd 00:0f.2: GetStatus port 1 status 001101 POWER sig=se0 RESET CONNECT
hub.c: port 1, portstatus 511, change 0, 480 Mb/s
hub.c: port 1 of hub 1 not reset yet, waiting 10ms
ehci_hcd 00:0f.2: GetStatus port 1 status 001101 POWER sig=se0 RESET CONNECT
hub.c: port 1, portstatus 511, change 0, 480 Mb/s
hub.c: port 1 of hub 1 not reset yet, waiting 10ms
ehci_hcd 00:0f.2: port 1 high speed
ehci_hcd 00:0f.2: GetStatus port 1 status 001005 POWER sig=se0 PE CONNECT
hub.c: port 1, portstatus 503, change 10, 480 Mb/s
hub.c: new USB device 00:0f.2-1, assigned address 4
ehci_hcd 00:0f.2: irq status 0002 ERR
ehci_hcd 00:0f.2: devpath 1 ep0out 3strikes
ehci_hcd 00:0f.2: dev0 ep0out qtd token 00080248 --> status -71
usb.c: USB device not accepting new address=4 (error=-71)
ehci_hcd 00:0f.2: irq status 0020 IAA
ehci_hcd 00:0f.2: free_config 1 devnum -1
ehci_hcd 00:0f.2: port 1 reset
ehci_hcd 00:0f.2: port 1 high speed
ehci_hcd 00:0f.2: GetStatus port 1 status 001005 POWER sig=se0 PE CONNECT
hub.c: port 1, portstatus 503, change 10, 480 Mb/s
hub.c: new USB device 00:0f.2-1, assigned address 5
ehci_hcd 00:0f.2: irq status 0002 ERR
ehci_hcd 00:0f.2: devpath 1 ep0out 3strikes
ehci_hcd 00:0f.2: dev0 ep0out qtd token 00080248 --> status -71
usb.c: USB device not accepting new address=5 (error=-71)
ehci_hcd 00:0f.2: irq status 0020 IAA
ehci_hcd 00:0f.2: free_config 1 devnum -1
ehci_hcd 00:0f.2: GetStatus port 2 status 001000 POWER sig=se0
hub.c: port 2, portstatus 100, change 0, 12 Mb/s


*****************************************************




Please let me know what is the solution.
I understand somehow SET_ADDRESS command is not going on the USB bus.

Niraj.
 
Old 08-07-2009, 11:23 PM   #2
wabbalee
Member
 
Registered: Oct 2006
Location: brisbane - australia
Distribution: mepis, ubuntu, zenwalk
Posts: 334

Rep: Reputation: 38
What distro and hardware are you using? Is your usb set to high speed in BIOS?

Ron
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Pen Drive not detected in Linux (suse & Ubuntu) working fine in windows XP Ayyappan Linux - Newbie 9 02-22-2012 10:43 AM
usb external HD issue: reset high speed USB device using ehci_hcd gstath Slackware 4 08-18-2010 02:35 AM
Vtec V-Drive USB 2.0 Flash Pen not working in Ubuntu 5.10 qwerty Linux - Hardware 0 02-16-2006 07:54 PM
automatic USB pen drive working fakie_flip Ubuntu 2 09-29-2005 09:29 AM
USB Mouse speed too high - SOLVED barr Linux - Newbie 0 09-09-2003 08:39 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration