LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2004, 11:34 AM   #1
DaveyB
Member
 
Registered: Aug 2004
Location: UK
Distribution: Debian
Posts: 83

Rep: Reputation: 15
USB Modem


How do you get a modem to work on USB, I have a AMBIT 351000 cable moem provided to me via NTL. I use a USB port to connect it to my computer and i want to connect to the net using it. I am running Slackware 10. Any ideas how to get it working?
 
Old 08-09-2004, 12:54 PM   #2
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Rep: Reputation: 31
slack 10 ships with kernel 2.4. you might want to recompile or go to the newest kernel (not sure if 2.4 supports usb modems).
 
Old 08-09-2004, 01:59 PM   #3
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
im using my NTLWORLD USB modem rigt now with slackware 10. works fine, however i did recompile my kernel !

boot slackware 10 without the cable modem pluged in, when its booted, plug the usb cable into the powered up modem, wait 2 seconds, then run "dmesg" in a command line window.. if the bottom line says something about USB cable modem detected, then your kernel is fine.

if it says nothing, then oprn up a command line window, then type "su -" to become root, and try to load the driver manually with the command "modprobe usbnet" if you get a "module not found error" then kernel re-compile is needed.

ohh, before you do all that,, if you are using KDE, load up the KDE info center, and look under the USB section, is your modem listed ? even if the kernel does not have the driver supported or loaded, KDE still detects the modems presence on my machine.
 
Old 08-09-2004, 02:32 PM   #4
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Rep: Reputation: 15
I used this to get my Motorola SB4200 up and running:

1. Plug the modem,
2. to know the module for the modem was loaded (probably was) type: lsmod
and near the end usbcore should present something like so:
usbcore 59308 1 [acm CDCEther usb-ohci usb-storage]
^
my module
3. type "pico /etc/rc.inet1.conf" and change the line dhcp="" to dhcp ="yes"
4. type /etc/etc/rc.inet1
5. your mac address, and ip should appear

If not, we are here to help.
 
Old 08-09-2004, 02:33 PM   #5
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Rep: Reputation: 15
I used this to get my Motorola SB4200 up and running:

1. Plug the modem,
2. to know if the module for the modem was loaded (probably was) type: lsmod
and near the end should present something like so:
usbcore 59308 1 [acm CDCEther usb-ohci usb-storage]

3. type "pico /etc/rc.inet1.conf" and change the line dhcp="" to dhcp ="yes"
4. type /etc/etc/rc.inet1
5. your mac address, and ip should appear

No kernel recompiling needed.

If not, we are here to help.

Last edited by eyeliner; 08-09-2004 at 02:35 PM.
 
Old 08-10-2004, 06:04 AM   #6
DaveyB
Member
 
Registered: Aug 2004
Location: UK
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
1 last thing ;)

Ooops

Last edited by DaveyB; 09-07-2004 at 07:17 AM.
 
Old 08-10-2004, 08:58 AM   #7
tinhat
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
kudos to eyeliner !

I was all set this morning to get my Motorola SB 4200 working with Slackware 10. I pointed my browser to Linux Questions. Entered search for "cable modems" and what do you know but there's the solution to my EXACT problem.

One thing though. I used MC to edit " /etc/rc.d/rc.inet1.conf" I couldn't find "/etc/rc/inet1.conf" .

Again many thanks eyeliner!
 
Old 08-10-2004, 09:07 AM   #8
DaveyB
Member
 
Registered: Aug 2004
Location: UK
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
Re: 1 last thing ;)

Just in case you missed it thankyou
Quote:
Originally posted by DaveyB
Thankyou all for the help so far, i have written down all the ideas you said in every eventuality. The only thing i dont know how to do is update and recompile my kernel. How would i go about this, as stated above i will be using Slackware 10. Thankyou.
 
Old 08-10-2004, 09:40 AM   #9
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Rep: Reputation: 15
Quote:
Originally posted by tinhat
kudos to eyeliner !

I was all set this morning to get my Motorola SB 4200 working with Slackware 10. I pointed my browser to Linux Questions. Entered search for "cable modems" and what do you know but there's the solution to my EXACT problem.

One thing though. I used MC to edit " /etc/rc.d/rc.inet1.conf" I couldn't find "/etc/rc/inet1.conf" .

Again many thanks eyeliner!
Yes, I've made a typo. But you managed it. That's good.
I've also added the modem to the hardware page, along with instructions to config.

I'm glad I helped you.
 
Old 08-10-2004, 02:27 PM   #10
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Rep: Reputation: 31
best instructions on compiling a kernel is here:

http://www.linuxquestions.org/questi...threadid=73436
 
Old 08-10-2004, 05:29 PM   #11
ByKtHoR
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Rep: Reputation: 0
SMlink USB Modem

Hello there, as i posted i have a SMlink usb modem on Red Hat 9 and i cannot used it, i tried every /dev/device and nothing but one said the the modem is busy. In the othr hand, i have the United Linux distribution i it works perfectly. Is there a way to configurate the modem??
 
Old 08-10-2004, 09:23 PM   #12
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Quote:
Hello there, as i posted i have a SMlink usb modem on Red Hat 9 and i cannot used it, i tried every /dev/device and nothing but one said the the modem is busy. In the othr hand, i have the United Linux distribution i it works perfectly. Is there a way to configurate the modem??
you seem horribly confused... USB modems are used as network interfaces... not /dev/ blocks !

run 'dmesg | grep eth' it should say somthing about you cable modem being asigned the name of "eth0" or if you have more than one network device "eth1 eth2 eth3 etc etc"

if dmesg does not say anything about the ethernet, then you need to load the driver with modprobe...

/dev/modem was used for pci or serial modems.
 
Old 08-11-2004, 01:57 PM   #13
eyeliner
Member
 
Registered: Aug 2004
Location: Near...
Distribution: Mandriva 2011.0
Posts: 58

Rep: Reputation: 15
It has a driver, along with instructions. Is your modem listed here?

http://www.smlink.com/main/index1.ph...19c2d73b80f524

Also, what does ifconfig report on your eth# devices?

Last edited by eyeliner; 08-11-2004 at 02:04 PM.
 
Old 08-11-2004, 02:02 PM   #14
DaveyB
Member
 
Registered: Aug 2004
Location: UK
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
I have noticed this thread gets a lot of hits since it has been closed. So i though i would tell you how i EVENTUALLY got my Ambit 351000 working properly. With help from lots of people in the forum and numerous emails i got there eventually.

I am using Slackware 10 with the 2.4.26 kernel:

Anyway here it is:
First things first we need to do this in the linux console screen so
Open the Console

Login as root so we can modify the kernel:
guest@darkstar:~$ su
Password:

Now we need to make yours USB modem look like an ether net card!
modprobe CDCEther

Asign an IP address
dchpcd

Check you have access to the internet now
ping www.google.com

if you get something like:
[B]root@darkstar:/# ping www.google.com{/B]
PING www.google.akadns.net (66.102.9.104) 56(84) bytes of data.
64 bytes from 66.102.9.104: icmp_seq=1 ttl=242 time=857 ms
64 bytes from 66.102.9.104: icmp_seq=1 ttl=242 time=856 ms

you know it's working ok, so now you just need it to automatically get an ip address and not rely on you typing it! So first we need to find which port our modems on:
root@darkstar:/# dmesg | grep eth
CDCEther.c: eth0: Ambit USB Ambit USB Cable Modem 00D059F44E0F
CDCEther.c: eth0: 000:59:F4:4E:0F
CDCEther.c: eth0: set multicast filters
Ether.c: eth0: set multicast filters
Ether.c: eth0: set multicast filters
Ether.c: eth0: set multicast filters
CDCEther.c: eth0: too many MC filters for hardware, using allmulti
CDCEther.c: eth0: too many MC filters for hardware, using allmulti

As you can see on mine its on eth0, so we now just need to edit the /etc/rc.d/rc.inet1.conf file.
So we type
pico /etc/rc.d/rc.inet1.conf

and we are presented with a screen we edit the eth0 section and ste USE_DCHP[0]="yes" then scroll to the bottom and set DEBUG_ETH_UP="yes, rmb depending on which ever setting you get from your dmesg | grep eth, depends which one you edit:

NOW reboot!

Last edited by DaveyB; 09-07-2004 at 07:16 AM.
 
Old 09-21-2004, 04:54 AM   #15
kapoo
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Rep: Reputation: 0
I also use Slackware 10.0 with kernel 2.4.26.
I try to make everything you told here.First I checked my sytem with dmesg | grep eth:
CDCEther.c: eth1 intr status -2
CDCEther.c: eth1: Askey USB Cable Modem 009096785907
CDCEther.c: eth1: 00:90:96:78:59:07
CDCEther.c: eth1: set multicast filters
Ether.c: eth1: set multicast filters
Ether.c: eth1: set multicast filters
Ether.c: eth1: set multicast filters
CDCEther.c: eth1: too many MC filters for hardware, using allmulti
CDCEther.c: eth1: too many MC filters for hardware, using allmulti

Then I try to assign ip with dhcpcd then ping www.google.com.
It waits sometime(app.30seconds)than ping:unknown host www.google.com
Also when I typr rc.inet1 on the command line it gave only MAC address.I didn't understood what is wrong.Can anyone help me...

Last edited by kapoo; 09-21-2004 at 06:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.2 detect my [B]ADSL USB-Ethernet Modem-Router [/B] as a [B]Dial up modem[/B]. myprecius Linux - Hardware 0 06-27-2005 10:21 AM
Problem with Mandrake 10.0 Community, Sagem usb modem and logitech usb mouse. al370601 Mandriva 4 04-29-2004 07:48 PM
usb modem : Can ping, but cant browse - and cant modprobe usb-uhci nmoog Linux - Newbie 8 01-08-2004 12:50 AM
USB mouse thru a USB modem & linux support zeppelin Slackware 7 07-29-2003 04:43 PM
USB cable modem kills usb keyboard sketi Linux - Hardware 1 02-22-2003 07:47 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration