LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2008, 02:44 AM   #1
guerrascience
LQ Newbie
 
Registered: Aug 2008
Posts: 13

Rep: Reputation: Disabled
USB Flash Drive to Show on Desktop!


Hi,

How do I get my usb flash drive to automatically show up on my desktop when plugged in? When it is plugged in, I can get to it by the /media folder. Also, can I do this with my iPod too?

Secondarily, I can only take files off my flash drive, I cannot add any files to it? Is it a permissions thing?

Thanks,
Guerrascience
Phoenix, Az
 
Old 08-13-2008, 02:51 AM   #2
zeeshanhayat
Member
 
Registered: Oct 2004
Distribution: Fedora, Debian, Free BSD
Posts: 71

Rep: Reputation: 15
Most Linux Distributions automatically mounts and show the USB Drive icon on your desktop (unless offcourse you are using a very old Distro).

Which Distro are you using.
 
Old 08-13-2008, 02:53 AM   #3
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 302

Rep: Reputation: 32
I am only assuming... but I think the reason you can't write to your usb device is because your fstab file lists it as RO (read only).

He could have built the distro piece by piece also. I had problems with Debian earlier because I built it from just the base system - with no window manager or X.

Could you post the results you get from:
Code:
mount
Mine looks like this:
Code:
/dev/md0 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/md2 on /home type ext3 (rw)
/dev/md1 on /var type ext3 (rw)

Last edited by checkmate3001; 08-13-2008 at 02:56 AM.
 
Old 08-13-2008, 03:09 AM   #4
zeeshanhayat
Member
 
Registered: Oct 2004
Distribution: Fedora, Debian, Free BSD
Posts: 71

Rep: Reputation: 15
Between i had this problem with a USB disk, At boot Winxp went for a checkdisk of the USB and corrected some enteries, After that my USB drive wasn't writable. I could read but not write to it. Had to format the USB disk to make it usable again
 
Old 08-13-2008, 06:34 AM   #5
guerrascience
LQ Newbie
 
Registered: Aug 2008
Posts: 13

Original Poster
Rep: Reputation: Disabled
I am using SUSE 11.0 on an IBM Thinkpad X41. When I had Mandarvia installed, the USB flash drive did show up atomatically and I could write to it. However, in SUSE 11.0 with KDE 3.5 I cannot. Weird huh?
 
Old 08-25-2008, 05:08 AM   #6
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 302

Rep: Reputation: 32
I was able to get my usb flashdrive on the desktop to show up only when it was plugged in. After it was mounted I went to my browser under media:\ and copied the icon to the desktop. It complained a little, but I think it was because I also copied the floppy drive icon and there was nothing mounted. Now it goes away when I remove the flashdrive and pops up when it's in.

Also you can modify your desktop icons in /home/<username>/.kde/share/config/kdesktoprc

look under the [media] section. It defines whether it is enabled or not and what types of media are disabled from showing.
 
Old 08-25-2008, 07:30 AM   #7
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,078

Rep: Reputation: 195Reputation: 195
What filesystem is your USB formatted as? If you do not know then when it's mounted run

Code:
$ mount
and post the output. If the drive is formatted NTFS is may be that it's being mounted with the kernel NTFS driver which only does read write, rather than the ntfs-3g driver which does read/write.
 
Old 08-25-2008, 09:56 AM   #8
Kenhelm
Member
 
Registered: Mar 2008
Location: N. W. England
Distribution: Mandriva
Posts: 333

Rep: Reputation: 141Reputation: 141
To select which device icons appear on the desktop in my KDE 3.5:
Right-click on desktop > Configure Desktop > Behaviour > Device Icons.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using a usb thumb drive or flash drive as a swap partition. stevenjoseph Linux - Hardware 8 01-16-2012 01:09 PM
fedora 7: autofs is not mounting USB flash drive or DVD ROM drive Hewson Linux - General 3 05-12-2008 09:58 AM
using Elive Gem - don't know how to show mounted USB (and other) drives on desktop bluecog6 Linux - General 0 09-16-2007 07:27 PM
cannot delete drive from root desktop - cannot mount usb flash drive - openSuSE 10.2 bluecog6 Linux - General 6 01-29-2007 04:18 PM
Why doesn't USB DVD show on desktop? Odyssey1942 Linux - Newbie 3 11-03-2006 12:08 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration