LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-12-2004, 10:34 PM   #1
darkflounder
LQ Newbie
 
Registered: Jun 2003
Distribution: None, yet
Posts: 23

Rep: Reputation: 15
USB flash drive and Fedora Core 2


256MB PNY Attache formatted in FAT16 (need to use with Windows PCs at school)
Fedora Core 2
Dell Inspiron 5100

I can mount the drive using
Code:
mount -t auto /dev/sba1 /mnt/flashdrive
but only as root, and then read-only. I've tried using some setting I've seen here in /etc/fstab, but when I run
Code:
mount -a
the flash drive doesn't mount.

I'd like the drive to automount to either the desktop or the home directory. I know it can be done (saw it working on a Mandrake installation).
 
Old 09-13-2004, 03:17 AM   #2
lou IbmiX XI
LQ Newbie
 
Registered: Mar 2004
Location: France
Posts: 13

Rep: Reputation: 0
The fstab settings must look like this:

"/dev/sda1 /mnt/flashdrive auto noauto,user,owner 0 0"

but if you want it as your /home directory you have to change the line with:

"/dev/sda1 /home auto user,owner 0 0"

i think. Sometimes, kudzu is the cause of some strange mounting problem, so if you have kudzu as an option in your fstab, you can try to delete it.
 
Old 09-13-2004, 07:47 AM   #3
darkflounder
LQ Newbie
 
Registered: Jun 2003
Distribution: None, yet
Posts: 23

Original Poster
Rep: Reputation: 15
The line in my /etc/fstab is currently
Code:
/dev/sda1 /mnt/flashdrive auto noauto,user,owner 0 0
but the drive does not mount with mount -a.

I know the drive can be seen. When I do
Code:
mount -t auto /dev/sda1 /mnt/flashdrive
I can see the contents of the drive, but cannot modify the contents as a normal user.

Any other ideas?
 
Old 09-13-2004, 12:48 PM   #4
KingofBLASH
Member
 
Registered: Sep 2003
Distribution: Just upgraded to Slackware 10.0
Posts: 91

Rep: Reputation: 15
Did you ever figure out how to make your flash drive work? I am having the same problems and found your thread while googling...

Thanks,

Dan
 
Old 09-13-2004, 01:03 PM   #5
sirclif
Member
 
Registered: Sep 2004
Location: south texas
Distribution: fedora core 3,4; gentoo
Posts: 192

Rep: Reputation: 30
whatever your fstab looks like:

/dev/sda1 /mnt/flashdrive auto noauto,user,owner 0 0

just use the mount point to mount it (/mnt/flashdrive)

$ mount /mnt/flashdrive

you can do this as a user, and have read-write permissions.
 
Old 09-14-2004, 01:50 AM   #6
lou IbmiX XI
LQ Newbie
 
Registered: Mar 2004
Location: France
Posts: 13

Rep: Reputation: 0
If the setting noauto is specified, "mount -a" won't mount your flashdrive. "mount -a" mount all devices which don't have this setting (or which have the "auto" setting specified). With the setting "owner", the user who have mount the device is the owner of it, so are you sure that you aren't root when you mount it? "user" is to permit all users to mount the device, not just root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Flash drive and the Fedora Boot image... Galaxy_Stranger Fedora 1 11-30-2005 04:28 PM
How to install usb flash in fedora core 3? mauled Linux - Hardware 2 10-06-2005 03:39 AM
Mounting usb flash disc in Fedora Core 3 suro Fedora 6 04-14-2005 06:46 AM
Booting Fedora Core 3 from USB Drive tniemeie Fedora 7 04-01-2005 03:23 PM
usb hard drive in fedora core 1? beatupbilly Fedora 5 11-17-2004 09:29 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration