LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-29-2009, 07:27 PM   #1
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Rep: Reputation: 18
USB drives are not mounting:


Hey guys,

I just started using openSUSE 11.1 with xfce and my problem is that I cannot mount my external USBs, I get the following message:

org.freedesktop.hal.storage.mount-removable auth_admin_keep_always <-- (action, result).

It seems hal does not give me permission to do this. Am I able to mount using the command line? If so, how? Thank you!
 
Old 09-29-2009, 10:55 PM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
Which file system is on the external usb's or are we talking about hardware?

Yes most usb devices can be mounted from the command line.
 
Old 09-29-2009, 11:21 PM   #3
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Original Poster
Rep: Reputation: 18
It is a fat32 file system, I just changed from arch linux and they were working just fine, but for some reason they don't want to mount.

How can I mount them with the command line?
 
Old 09-30-2009, 12:57 AM   #4
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
You might try
mount /dev/sda1 /mnt/sda1
providing /dev/sda1 exists and /mnt/sda1 exists. Unplug the USB device and plug it back in and run the following command:
dmesg | tail
and post the result.
 
Old 09-30-2009, 01:05 AM   #5
Earl Parker II
Member
 
Registered: Jan 2002
Location: Shelby, NC, US
Distribution: Slackware 12.2
Posts: 127

Rep: Reputation: 17
If you need to specify the filesystem try:

mount -t vfat /dev/sda1 /mnt/sda1
 
Old 09-30-2009, 04:17 AM   #6
Peterius
Member
 
Registered: May 2004
Distribution: Gentoo, Debian, OpenBSD, NetBSD
Posts: 157

Rep: Reputation: 16
Hal might need an entry in /etc/fstab.
 
Old 09-30-2009, 04:30 AM   #7
hans51
Member
 
Registered: Mar 2005
Location: Cambodia
Distribution: suse
Posts: 36
Blog Entries: 1

Rep: Reputation: 16
To find out which device your USB device has
use ( as root ) commandline

fdisk -l

that lists all devices, mounted and un-mounted ones

most likely your primary drive with all its partitions is
/dev/sda1
/dev/sdax ( x being the partition number )

and additional drives have OTHER ( sometimes changing ) device names like

/dev/sdb
/dev/sdc

changing because if you remove a USB device and replace it soon after, then the same device may get another device name allocated

for your auto-mounting
there is a solution ( may be others have more precise instructions ):

lets assume you have a FULL backup from that vfat USB device
then you go in

> yast2 > system > Partitioner

then a warning POP-up window appears - click YES because you have to KNOW what you do else ALL data on ALL or any partitions LOST !!


until this moment NOTHING is changed to ANY of your drives at ALL !!
now a full LIST of all devices appears
unmounted devices have an * next to the "mount" point

there you should see your vfat device ...

for any of the NOW coming changes a device NEEDS to be UNmounted first !!

you now click on your USB-VFAT device listed ( as unmounted ). if for any reason the USB device is mounted - then "umount" your device FIRST and then RESTART ALL above YAST2 from scratch. changes on mounting/umounting are NOT shown in open YAST2 and errors will occur.

so you click on your USB VFAT
then select "edit"
then a pop-up window appears saying
"editing existing devices /dev/sdxy ( sdxy being the device name of your USB device )

change NOTHING at all in the format section of your "edit existing partition" window. NO formatting unless you WANT to format and thus to loose all data !

on the right you see "Fstab Options" >> select

then you see a list of fstab options existing in your USB device

- in top section you decide under whch name the device is mounted. For example myself I have many USB devices 3 sticks and many more USB drives and give each a Volume LABEL = a unique NAME relevant to the content of the device to make sure I know which content is mounted.

- you also see below several options about mounting options
if you want your USB to automatically be mounted at boot time, then you need to UNselect the "Do Not Mount at System Start-up"

it appears that is what you want. however if you auto-mount at system start up that device NEEDS to be present / plugged in to your computer else you most likely get a system error on BOOTING your machine for missing drive !!

after making any changes in THIS Fstab options, normally NO loss of data occurs. I have done this Fstab option changes multipel times in past many years using current opensuse without any data loss. however you do at your own risk and may want a full data backup BEFORE making changes in Fstab options on your USB device.
 
Old 09-30-2009, 07:33 AM   #8
DarkVenger
Member
 
Registered: Mar 2004
Location: VCO
Distribution: Arch
Posts: 43

Rep: Reputation: 26
I believe you just need to make yourself part of the storage group, this is done with
Code:
gpasswd -a [user] [group]
in console.

To know which groups are you in, just type
Code:
groups
on the console.

If that doesn't work you can add the following to the /etc/dbus-1/system.d/hal.conf

Code:
  <policy group="storage">
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
  </policy>
Note: If you added yourself to the storage group you need to logout/login in order for that change to take effect.
 
Old 09-30-2009, 06:49 PM   #9
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Original Poster
Rep: Reputation: 18
There is no storage group, should I make one?
 
Old 09-30-2009, 06:57 PM   #10
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Original Poster
Rep: Reputation: 18
this is from the dmesg | tail

mag1strate@linux-o6a5:~> dmesg | tail
sd 11:0:0:0: [sdf] Mode Sense: 21 00 00 00
sd 11:0:0:0: [sdf] Assuming drive cache: write through
sdf: sdf1
sd 11:0:0:0: [sdf] Attached SCSI disk
sd 11:0:0:0: Attached scsi generic sg6 type 0
usb-storage: device scan complete
SFW2-OUT-ERROR IN= OUT=eth1 SRC=192.168.1.45 DST=208.113.241.52 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=10915 DF PROTO=TCP SPT=56834 DPT=80 WINDOW=54 RES=0x00 ACK FIN URGP=0 OPT (0101080A014A4B6607FD2C2D)
SFW2-OUT-ERROR IN= OUT=eth1 SRC=192.168.1.45 DST=212.58.226.77 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=62823 DF PROTO=TCP SPT=41638 DPT=80 WINDOW=408 RES=0x00 ACK FIN URGP=0 OPT (0101080A014A4ECF70C67F72)
SFW2-OUT-ERROR IN= OUT=eth1 SRC=192.168.1.45 DST=63.245.209.93 LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=39466 DF PROTO=TCP SPT=33055 DPT=80 WINDOW=6590 RES=0x00 ACK FIN URGP=0
SFW2-OUT-ERROR IN= OUT=eth1 SRC=192.168.1.45 DST=63.245.209.93 LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=51064 DF PROTO=TCP SPT=33056 DPT=80 WINDOW=7010 RES=0x00 ACK FIN URGP=0
 
Old 09-30-2009, 07:01 PM   #11
purevw
Member
 
Registered: Jan 2007
Location: Texas
Distribution: OpenSuSE 13, Kernel 3.13.3
Posts: 118

Rep: Reputation: 47
Did you installed all updates after you installed OpenSuSE 11.1? I remember that there was some kind of "permissions" issue concerning removable media when 11.1 first came out. I have no problems with my external USB drive. I did however go into fstab and modify the mount points and made the disk mountable by user.
 
Old 09-30-2009, 07:03 PM   #12
purevw
Member
 
Registered: Jan 2007
Location: Texas
Distribution: OpenSuSE 13, Kernel 3.13.3
Posts: 118

Rep: Reputation: 47
I see that you added to your post. The extra info helps. Try "mount /dev/sdf1". If you don't get an error, the you will probably find the drive somewhere under the "/media/" directory.
 
Old 09-30-2009, 07:09 PM   #13
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Original Poster
Rep: Reputation: 18
I got this as an error.

mag1strate@linux-o6a5:~> mount /dev/sdf1
mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
 
Old 09-30-2009, 09:45 PM   #14
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
tell it where to put it

Quote:
Originally Posted by mag1strate View Post
I got this as an error.

mag1strate@linux-o6a5:~> mount /dev/sdf1
mount: can't find /dev/sdf1 in /etc/fstab or /etc/mtab
you have to tell it where to mount
mkdir /media/removable (this will make a directory in the typical mount dir in suse)

then do the same command with that dir as the mount point, ie...

mount /dev/sdf1 /media/removable

it's still weird that it happens at all.
I use suse and have never had a problem with things auto mounting.
maybe try a different desktop like xfce just to see if it's a problem with the desktop you're using.
does this happen with cdroms or things like that?

Last edited by axobeauvi; 09-30-2009 at 09:48 PM. Reason: added question
 
Old 09-30-2009, 10:31 PM   #15
mag1strate
Member
 
Registered: Apr 2009
Distribution: Fedora 16, Arch
Posts: 136

Original Poster
Rep: Reputation: 18
Quote:
it's still weird that it happens at all.
I use suse and have never had a problem with things auto mounting.
maybe try a different desktop like xfce just to see if it's a problem with the desktop you're using.
does this happen with cdroms or things like that?
yeah i have used suse for a long time but i never had this problem, I am currently using xfce for the first time on suse. And this is occuring on cdroms as well, they won't mount!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting usb drives in BSD sharathg786 *BSD 2 07-31-2007 10:55 AM
On Mounting USB Hard Drives jerm1701 Linux - Hardware 2 04-17-2007 02:24 AM
Mounting USB drives (external HD and two at once) jrdioko Linux - Software 4 07-25-2006 07:40 PM
Mounting USB drives under 2.6.x hussar Linux - General 1 03-07-2004 01:58 PM
mounting usb drives? neon Linux - Newbie 2 10-29-2003 09:06 PM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration