LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2005, 07:03 AM   #1
richo7
LQ Newbie
 
Registered: May 2005
Location: Australia
Distribution: Mandrake 10.1
Posts: 13

Rep: Reputation: 0
USB Drives


OK i´ve got a 128mb USB Flashdrive, and an ipod, and i connect them through my USB Ports and Linux can never ever recognise them, so is there any solution to this?
 
Old 06-09-2005, 07:45 AM   #2
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Rep: Reputation: 30
Please post information about what you do, which OS version you use, kernel version, etc.
 
Old 06-09-2005, 08:32 AM   #3
richo7
LQ Newbie
 
Registered: May 2005
Location: Australia
Distribution: Mandrake 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
ok i plug in the USB drive, and nufin happens what so ever... and i use Mandrake 10.1 and i duno what kernal i use? how can i find that out? i´ve only just installed mandrake 10.1 so i guess it would be the standard 1
 
Old 06-09-2005, 05:39 PM   #4
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
You need to create a mount point for these devices. When I use my flashdrive with slackware, I mount it at /dev/sda1.
To create a mount point, you use the command 'mkdir' (make directory) without the quotes. example: mkdir /mnt/sda1
Also, you must add a line to your /etc/fstab file. something like this:
/dev/sda1 /mnt/sda1 vfat noauto,users,ro 0 0
not sure about the ipod, haven't hooked my ipod up to my pc with slackware.
 
Old 06-09-2005, 10:43 PM   #5
richo7
LQ Newbie
 
Registered: May 2005
Location: Australia
Distribution: Mandrake 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
ok, i´ve made the directory of /dev/sda1, now im trying to add a like to fstab that line being
/dev/sda1 /mnt/sda1 vfat noauto,users,ro 0 0
but yea i add that line but i cant save it, and then i try to open it up when im in root in a Konsole session, and it says
¨[root@localhost etc]# ./fstab
bash: ./fstab: Permission denied¨
so how do i create that line in fstab?
 
Old 06-10-2005, 12:21 AM   #6
Bluenoser
Member
 
Registered: Jun 2004
Location: Nova Scotia, Canada
Distribution: Ubuntu 8.04 LTS
Posts: 138

Rep: Reputation: 15
/etc/fstab is a text file you have to edit with an editor

Aside from that, you should be able to mount it with

# mkdir /mnt/usb or /mnt/whatever you want
# mount /dev/sda1 /mnt/usb

That's all it took to mount my mp3 player....... ymmv
 
Old 06-10-2005, 12:37 AM   #7
richo7
LQ Newbie
 
Registered: May 2005
Location: Australia
Distribution: Mandrake 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
ok, i try and edit it with emacs, kate or kwrite and yea still wont save it or anything...... and i go into properties of fstab and i cant change it from being a read only file....
 
Old 06-10-2005, 11:20 PM   #8
Bluenoser
Member
 
Registered: Jun 2004
Location: Nova Scotia, Canada
Distribution: Ubuntu 8.04 LTS
Posts: 138

Rep: Reputation: 15
You have to edit it as root
 
Old 06-11-2005, 07:13 AM   #9
richo7
LQ Newbie
 
Registered: May 2005
Location: Australia
Distribution: Mandrake 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
and how do i edit in root?
 
Old 06-11-2005, 02:36 PM   #10
Bluenoser
Member
 
Registered: Jun 2004
Location: Nova Scotia, Canada
Distribution: Ubuntu 8.04 LTS
Posts: 138

Rep: Reputation: 15
Open a console, type su <enter> then your root password and then start your favorite editor such as pico

$ su
# pico /etc/fstab
 
Old 06-11-2005, 03:37 PM   #11
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Quote:
Originally posted by richo7
ok i plug in the USB drive, and nufin happens what so ever... and i use Mandrake 10.1 and i duno what kernal i use? how can i find that out? i´ve only just installed mandrake 10.1 so i guess it would be the standard 1
Mandrake most always automounts your USB devices automatically unless you delibertly disable them. After you plug your Thumbdrive in check for an existing mount point. Just type:

mount <enter>

Look for something like:
/dev/sda1 on /mnt/???

then try to list contents:
ls -al /mnt/???

If it is not mounted check your fstab for a mount point and then mount the drive:

cat /etc/fstab

KC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any problems with USB-port PCMCIA cards and USB Floppy Drives? DreameR-X Linux - Laptop and Netbook 9 05-14-2005 02:37 PM
udev, USB Flash Drives, and usb-mount talkingwires Debian 13 11-07-2004 01:15 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
Where are my USB drives ? Forpus Linux - Hardware 5 06-26-2004 09:42 AM
USB drives pteren Linux - Hardware 2 04-04-2003 12:58 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration