LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-26-2005, 12:58 PM   #1
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Rep: Reputation: 15
USB Drive As HD for Knoppix


I have a crappy 64 mb USB 1.1 drive I got for free and would like to use to create a persistent home directory for Knoppix as well as save my settings onto. I've been running into trouble because I can't seem to format the disk as ext2 or ext3 or any other writable linux partition. Both cfdisk and fdisk can't see the drive. Also when you anwser this I would also like to know about any sort of tools for viewing linux partitions in Windows.
 
Old 03-26-2005, 01:03 PM   #2
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
USB drives are shown as SCSI devices in Linux. Most likely your usbdrive is /dev/sda1. I would personally keep it FAT because that way you'll be able to use it in Windows machines also. Writing to a FAT filesystem is no problem in Linux, just make sure you mount it writeable. If you do decide to convert it to ext2 or 3, you have to start (c)fdisk with cfdisk /dev/sda or such.

Last edited by alienDog; 03-26-2005 at 01:08 PM.
 
Old 03-26-2005, 01:12 PM   #3
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Original Poster
Rep: Reputation: 15
Well I did find where it was mounted
But cfdisk and fdisk wouldn't let me mount it


I had tried FAT32 and NTFS but not FAT yet

I'll give that a shot and write back
 
Old 03-26-2005, 01:47 PM   #4
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Original Poster
Rep: Reputation: 15
Ok the FAT file system works like a dream, however now all my files are stored under a file called knoppix.img

Is there anyway to open this in Windows and access the files?
 
Old 03-26-2005, 07:49 PM   #5
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
FAT32 should work also (it's just a variant of FAT). Furthermore, you should probably use -t VFAT option with your mount command to enable filenames longer than 8+3 characters.

Can't help you with knoppix.img though because I have no experience in Knoppix. If you mount your usbdrive (be it /dev/sda1 or whatever) to for example /mnt/usbdrive, I see no reason why the files would be placed under some strange .img file. Sounds extremely strange to me... This is certainly not standard behaviour, must be some knoppix oddity. Could you tell me exactly how you mount the drive under linux and what software you use to access it?

Last edited by alienDog; 03-26-2005 at 07:55 PM.
 
Old 03-26-2005, 09:36 PM   #6
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Original Poster
Rep: Reputation: 15
Well I just make sure everything is hooked up then I type at the boot screen for Knoppix

Code:
knoppix myconfig=/mnt/sda1 home=sda1
 
Old 03-26-2005, 09:50 PM   #7
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Well there's your problem then It seems that with your boot parameters sda1 gets mounted to /mnt/sda1, so you could just try saving your files to /mnt/sda1 instead of your home directory. Not sure if this works, but try it.

OR you could bootup your knoppix first without all the myconfig=/mnt/sda1 home=sda1 stuff. Then after it's booted, mount the usbdrive with normal mount command: mount -t vfat /dev/sda1 /mnt/sda1 -o uid=[yourusername]. It won't be your home directory then (instead you can access it from /mnt/sda1), but at least the files will be readable in other systems too. Not sure what will happen to your changes to system settings then...

OR you could just try leaving the last home=sda1 part away from your boot parameters and use /mnt/sda1 to save your files (I would think it will get mounted, but if not, use the above mount command).

Knoppix seems to use this strange .img file because of your boot parameters. Don't ask me why, because to me it seems plain stupid... It could just as well just save the files directly to the filesystem. I guess there is a reason for this, but you have to ask it from someone who knows knoppix better than I do.

Hope you get it working, good luck

Last edited by alienDog; 03-26-2005 at 09:56 PM.
 
Old 03-26-2005, 10:56 PM   #8
aeuzent
Member
 
Registered: Jan 2005
Location: Maryland, USA
Distribution: Ubuntu/Debian
Posts: 102

Original Poster
Rep: Reputation: 15
I think it had to do with the fact that I'm not using a linux filesystem. Either that or it's some kind of compression.
 
Old 03-27-2005, 05:01 AM   #9
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
I would suspect the prior. I think it wants to manage file permissions correct and of course this is not possible with FAT (since it doesn't have permissions). However using FAT filesystem is possible without such tricks, you just need to set the file permissions and ownership when mounting the filesystem and you cannot change them later.I think that the .img file is actually a ext2/3/reiserfs filesystem that can be mounted using a loop device on linux. Unfortunately there is no way (at least to my knowledge) with which you could handle such files under other operating systems. Did you manage to get it working the way you wanted?

Last edited by alienDog; 03-27-2005 at 05:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
booting knoppix via external usb cd drive Kirmonkey Linux - Laptop and Netbook 0 04-24-2005 06:07 AM
Accessing USB Thumb Drive in Knoppix 3.7 jessjackson Linux - Newbie 0 02-14-2005 02:29 PM
Need help using a USB drive in Knoppix Orange Sunshine Linux - Software 3 07-20-2004 11:27 PM
Can't mount USB drive in knoppix bennettg Linux - Hardware 9 02-19-2004 08:07 AM
Can't mount USB drive in knoppix bennettg Linux - Newbie 7 02-17-2004 07:48 AM


All times are GMT -5. The time now is 05:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration