LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-11-2004, 09:06 AM   #1
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
USB device problem


Hello everybody,

I installed slackware 9.0 on a system and it won't mount the USB stick. It did on other PC's... When trying to mount (as root) it says: "/dev/sda1 is not a valid block device". however, ls -al /dev/sda1 tells me: "brw-r----- 1 root disk 8, 1 1995-04-29 09:33 sda1", the 'b' means block device?

greetz,
.-=~ iluvatar ~=-.

edit: I tried other possible devices too, like sda2 or sdb1 etc etc, all same problem...
 
Old 10-11-2004, 09:13 AM   #2
jbogins
LQ Newbie
 
Registered: Nov 2003
Distribution: fedora core 1
Posts: 29

Rep: Reputation: 15
plug the device in the do this command
# tail /var/log/messages

it will probably tell you what you need to mount...

(i am not for sure if that is messages lives in /var/log/ )
(n00b myself so maybe not the best answer!!)
 
Old 10-11-2004, 12:34 PM   #3
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
Your best bet is to run `dmesg | tail` after you plug in the device. This will list all known information about the device as the driver sees it.

If nothing appears in dmesg, check `lsmod` for a module named uhci or ohci. This is your 'usb module'.

If dmesg does show your device registering with the driver, then you'll need to make sure that you have the usb-storage module loaded. lsmod will tell you that, as well.

Check those things, and we can go from there .
 
Old 10-11-2004, 01:19 PM   #4
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
also, type
#cat /proc/scsi/scsi

to make sure that the kernel sees it properly.

Is there a line in you /etc/fstab file to allow for the drive to mount?
 
Old 10-11-2004, 05:05 PM   #5
servnov
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2
Posts: 276

Rep: Reputation: 30
Yeah. Like the guy above said, did you make a USB mount point in /etc/fstab? It's ok if you did not, you will just have to specify when you mount it. Like 'mount /dev/sda1 /mnt' then just change to /mnt and do whatever you want. then umount it
 
Old 10-12-2004, 12:20 AM   #6
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
As valid as the previous two replys are, I believe that they are discussing the wrong problem. It is true that an entry in /etc/fstab would be needed for implicit mounting, however, when an error message such as the one quoted by the OP occurs, it isn't because of an fstab problem - it's usually a driver issue. When mount looks at a 'device' and tries to mount it, it needs to verify that it is, in fact, mountable. The error that the OP mentioned occurs when mount says, 'Uh oh, I can't mount that one...'. _Typically_ this is a problem with drivers ( Department of Redundancy Department ).
 
Old 10-12-2004, 03:28 AM   #7
trophy
LQ Newbie
 
Registered: Mar 2004
Posts: 29

Rep: Reputation: 15
I have Red Hat 9 and I had the some error coming up ("/dev/sda1 is not a valid block device") I changed /dev/sda1 to /dev/sda in the fstab file and it works fine now.
 
Old 10-13-2004, 02:26 AM   #8
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Original Poster
Rep: Reputation: 30
I looked at the /var/log/messages and it says something like "no module for usb device". Maybe it's 'cause I compiled a custom kernel (needed for video driver) and I forgot something to compile...? what options are exactly needed then?

thanx!
.-=~ iluvatar ~=-.
 
Old 10-13-2004, 02:33 AM   #9
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
Yup. You forgot usb-storage. First make sure that you have SCSI support. Then enable USB Mass Storage in your kernel. Here are the relevant options from my .config:

CONFIG_SCSI=y
...
CONFIG_USB_STORAGE=m

That should be it...
 
Old 10-13-2004, 02:33 AM   #10
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
[Edit] Deleted accidental repost. See above. [/Edit]

Last edited by magicsmoke; 10-13-2004 at 02:34 AM.
 
Old 10-13-2004, 02:38 AM   #11
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Original Poster
Rep: Reputation: 30
I'll check that as soon as I've some time left (and @ home)

thanx,
.-~ iluvatar ~=-.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 07:32 AM
USB device problem Pr_009 Fedora 3 11-16-2005 12:52 PM
USB Scanner problem: usb 1-2: device not accepting address 3, error -71 lagartoflojo Slackware 1 11-13-2004 04:26 PM
Problem with a USB device under 2.6.5 kernel EwanG Linux - Hardware 4 08-13-2004 08:46 PM
Problem with USB Device monowar Linux - General 1 07-13-2002 05:38 PM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration