LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   USB device problem (http://www.linuxquestions.org/questions/linux-newbie-8/usb-device-problem-241309/)

iluvatar 10-11-2004 10:06 AM

USB device problem
 
Hello everybody,

I installed slackware 9.0 on a system and it won't mount the USB stick. It did on other PC's... When trying to mount (as root) it says: "/dev/sda1 is not a valid block device". however, ls -al /dev/sda1 tells me: "brw-r----- 1 root disk 8, 1 1995-04-29 09:33 sda1", the 'b' means block device?

greetz,
.-=~ iluvatar ~=-.

edit: I tried other possible devices too, like sda2 or sdb1 etc etc, all same problem...

jbogins 10-11-2004 10:13 AM

plug the device in the do this command
# tail /var/log/messages

it will probably tell you what you need to mount...

(i am not for sure if that is messages lives in /var/log/ )
(n00b myself so maybe not the best answer!!)

magicsmoke 10-11-2004 01:34 PM

Your best bet is to run `dmesg | tail` after you plug in the device. This will list all known information about the device as the driver sees it.

If nothing appears in dmesg, check `lsmod` for a module named uhci or ohci. This is your 'usb module'.

If dmesg does show your device registering with the driver, then you'll need to make sure that you have the usb-storage module loaded. lsmod will tell you that, as well.

Check those things, and we can go from there ;).

busbarn 10-11-2004 02:19 PM

also, type
#cat /proc/scsi/scsi

to make sure that the kernel sees it properly.

Is there a line in you /etc/fstab file to allow for the drive to mount?

servnov 10-11-2004 06:05 PM

Yeah. Like the guy above said, did you make a USB mount point in /etc/fstab? It's ok if you did not, you will just have to specify when you mount it. Like 'mount /dev/sda1 /mnt' then just change to /mnt and do whatever you want. then umount it

magicsmoke 10-12-2004 01:20 AM

As valid as the previous two replys are, I believe that they are discussing the wrong problem. It is true that an entry in /etc/fstab would be needed for implicit mounting, however, when an error message such as the one quoted by the OP occurs, it isn't because of an fstab problem - it's usually a driver issue. When mount looks at a 'device' and tries to mount it, it needs to verify that it is, in fact, mountable. The error that the OP mentioned occurs when mount says, 'Uh oh, I can't mount that one...'. _Typically_ this is a problem with drivers ( Department of Redundancy Department ).

trophy 10-12-2004 04:28 AM

I have Red Hat 9 and I had the some error coming up ("/dev/sda1 is not a valid block device") I changed /dev/sda1 to /dev/sda in the fstab file and it works fine now.

iluvatar 10-13-2004 03:26 AM

I looked at the /var/log/messages and it says something like "no module for usb device". Maybe it's 'cause I compiled a custom kernel (needed for video driver) and I forgot something to compile...? what options are exactly needed then?

thanx!
.-=~ iluvatar ~=-.

magicsmoke 10-13-2004 03:33 AM

Yup. You forgot usb-storage. First make sure that you have SCSI support. Then enable USB Mass Storage in your kernel. Here are the relevant options from my .config:

CONFIG_SCSI=y
...
CONFIG_USB_STORAGE=m

That should be it... ;)

magicsmoke 10-13-2004 03:33 AM

[Edit] Deleted accidental repost. See above. [/Edit]

iluvatar 10-13-2004 03:38 AM

I'll check that as soon as I've some time left (and @ home)

thanx,
.-~ iluvatar ~=-.


All times are GMT -5. The time now is 10:22 PM.