LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2011, 11:21 AM   #1
nyamutambog
LQ Newbie
 
Registered: Jul 2011
Location: Zimbabwe
Distribution: Ubuntu Natty
Posts: 2

Rep: Reputation: Disabled
usb cdma qualcomm modem not working in ubuntu natty 11.04


cdma usb modem recognized on as mass storage device. installed wvdialler and made appropriate lines to conf file and still does not work. help
 
Old 07-19-2011, 02:20 PM   #2
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
You need to convert...

Wvdialer establishes the connection by dialing the mobile telephone network, but you must first convert the modem so that it is seen as the right kind of device.

Open a terminal and use the command "lsusb" to get the ID numbers of the modem, then use google for more information on configuration.

Your modem may be one of those that can use USB_ModeSwitch. Check on the list of supported devices. There is also a useful Forum.

http://www.draisberghof.de/usb_modeswitch/

USB_ModeSwitch is included in many linux distributions, but your chances are better with the latest version and you will probably need to compile it yourself.

You are not the first with this task. Read this and check the links provided.

http://www.linuxquestions.org/questi...photon-877671/

Last edited by thorkelljarl; 07-19-2011 at 02:29 PM.
 
Old 07-19-2011, 03:03 PM   #3
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
Before even trying USB_modeswitch there are two things to try. First, try to eject the usb drive that the modem is showing as! (on my modem it comes up as an optical drive)
Second try booting up with the modem already plugged in. Some modems start in modem mode by default if the system is booted while the modem is plugged in.
My modem uses a Qualcom chipset and I have to use
Code:
sudo modprobe usbserial vendor=0x17af product=0x6002
to get it to be correctly recognised. I added the line,
Code:
usbserial vendor=0x17af product=0x6002
to etc/modules to do this automatically! (note that the vendor/product id may be different for your modem so please check lsusb to get that if you need to go this route)
 
Old 07-19-2011, 03:28 PM   #4
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Perhaps...

Might it not be the case that qlue's modem is being switched by a copy of USB_ModeSwitch installed in his distribution? If USB_ModeSwitch finds a modem to its liking it does a switch without being noticeable.

qlue has loaded the proper driver and insured that the device is correctly identified but only on the basis of the device being present as a modem, not as a storage device.
 
Old 07-20-2011, 10:05 PM   #5
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbangified Debian 8 (Jessie)
Posts: 747
Blog Entries: 1

Rep: Reputation: 172Reputation: 172
Quote:
Originally Posted by thorkelljarl View Post
Perhaps...

Might it not be the case that qlue's modem is being switched by a copy of USB_ModeSwitch installed in his distribution? If USB_ModeSwitch finds a modem to its liking it does a switch without being noticeable.

qlue has loaded the proper driver and insured that the device is correctly identified but only on the basis of the device being present as a modem, not as a storage device.
Just to clarify, I switch my modem by ejecting the fake cd-rom. This automatically switches the device to modem mode! That is exactly what USB_modeswitch does for most modems.
However, my modem only needs switching if it is connected to a system that is already running. It defaults to modem mode if it is already connected when booting up.

I recommend that USB_modeswitch should only be used if ejecting the fake cd-rom doesn't work. If your modem doesn't default to modem mode at boot time, you could rather add the eject command to the startup script.

However, since my modem's interface is a serial emulator, it needed the usbserial module which caused much confusion when I first tried using it!
 
Old 07-21-2011, 10:25 AM   #6
nyamutambog
LQ Newbie
 
Registered: Jul 2011
Location: Zimbabwe
Distribution: Ubuntu Natty
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you very much for all the help. Its a big world out there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Detect USB CDMA Modem in Fedora 8 Ferianto Fedora 1 05-31-2008 10:19 AM
i have this error message when i connected cdma usb modem debianlam Linux - Networking 1 05-04-2008 08:38 AM
lg cdma usb modem drivers required ummer k m Fedora 1 11-19-2007 03:29 AM
CDMA Modem via USB not working in SuSE 10 akabatman2 SUSE / openSUSE 3 11-09-2005 11:02 PM
USB to serial convertor + CDMA modem priya_siddharth Linux - Hardware 1 04-11-2004 08:34 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration